gnu: seed: Fix tests.
[jackhill/guix/guix.git] / gnu / packages / gnome.scm
index 2abb73a..6923522 100644 (file)
@@ -329,6 +329,12 @@ bindings.")
                         "configure"
                         "Makefile.in"))
              #t))
+         (add-after 'unpack 'patch-tests
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* (find-files "." "\\.js$")
+              (("#!/usr/bin/env seed")
+               (string-append "#!" (getcwd) "/src/seed")))
+             #t))
          (add-before 'build 'patch-docbook-xml
            (lambda* (#:key inputs #:allow-other-keys)
              (with-directory-excursion "doc"