gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / dico.scm
index 1a674df..ec897d1 100644 (file)
@@ -1,6 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public dico
   (package
     (name "dico")
-    (version "2.3")
+    (version "2.10")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://gnu/dico/dico-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "13by0zimx90v2j8v7n4k9y3xwmh4q9jdc2f4f8yjs3x7f5bzm2pk"))
-             (snippet
-              ;; Upstream commit 89922fc.
-              '(substitute* "include/dico/markup.h"
-                 (("const char \\*dico_markup_type;")
-                  "extern const char *dico_markup_type;")))
-             (modules '((guix build utils)))))
+               "0qag47mzs00d53hnrmh381r0jay42766vp5xrffmzmsn2307x8vl"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
                       ;; infrastructure.  Gag it.
                       (setenv "GUILE_AUTO_COMPILE" "0")
                       (setenv "GUILE_WARN_DEPRECATED" "no")
-                      #t)))))
+                      #t))
+                  (replace 'check
+                    (lambda _
+                      ;; Test '71: append + dooffs + env' fails if $V is not 2.
+                      (invoke "make" "check" "V=2"))))))
+    (native-inputs `(("groff" ,groff)))
     (inputs
      `(("m4" ,m4)                                 ;used at run time
        ("pcre" ,pcre)
        ("python" ,python-2)
-       ("guile" ,guile-2.0)
+       ("guile" ,guile-2.2)
        ("gsasl" ,gsasl)
-       ("groff" ,groff)
        ("readline" ,readline)
        ("zlib" ,zlib)
-       ;; ("wordnet" ,wordnet) ;FIXME: link failure
+       ("wordnet" ,wordnet)
        ("libltdl" ,libltdl)))
-    (home-page "http://www.gnu.org/software/dico/")
+    (home-page "https://www.gnu.org/software/dico/")
     (synopsis "Implementation of DICT server (RFC 2229)")
     (description
      "GNU Dico implements a flexible dictionary server and client according to