gnu: emacs: Remove unneeded import.
[jackhill/guix/guix.git] / gnu / packages / kde-multimedia.scm
index 5aca29a..639d74d 100644 (file)
@@ -26,6 +26,7 @@
   #:use-module (gnu packages audio)
   #:use-module (gnu packages base)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cdrom)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages xiph)
   #:use-module (gnu packages xorg))
 
+(define-public audiocd-kio
+  (package
+    (name "audiocd-kio")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/audiocd-kio-" version ".tar.xz"))
+       (sha256
+        (base32 "1924w7li16qkmqsvbgfihjd7id6mb00m9k3acfwkkf32yzg3dn4q"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("kdoctools" ,kdoctools)))
+    (inputs
+     `(("cdparanoia" ,cdparanoia)
+       ("flac" ,flac)
+       ("kcmutils" ,kcmutils)
+       ("kconfig" ,kconfig)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("libkcddb" ,libkcddb)
+       ("libkcompactdisc", libkcompactdisc)
+       ("libvorbis" ,libvorbis)
+       ("phonon" ,phonon)
+       ("qtbase" ,qtbase)))
+    (home-page "https://kde.org/applications/multimedia/org.kde.kio_audiocd")
+    (synopsis "Transparent audio CD integration for applications using the KDE
+Platform")
+    (description "KIO AudioCD is a KIO slave that enables KIO-aware
+applications (such as Dolphin or k3b) to access audio and CD text data on the
+audio compact disks.  It allows transparent drag and drop conversion of audio
+data into the popular formats and has a configuration System Settings module
+available in the \"Multimedia\" section.
+
+This package is part of the KDE multimedia module.")
+    (license ;; GPL for programs, FDL for documentation
+     (list license:gpl2+ license:fdl1.2+))))
+
 (define-public dragon
   (package
     (name "dragon")
@@ -150,13 +191,44 @@ This package is part of the KDE multimedia module.")
     (home-page "https://kde.org/applications/multimedia/org.kde.elisa")
     (synopsis "Powerful music player for Plasma 5")
     (description "Elisa is a simple music player aiming to provide a nice
-experience for its users.  Elisa allows to browse music by album, artist or
+experience for its users.  Elisa browses music by album, artist or
 all tracks.  The music is indexed using either a private indexer or an indexer
 using Baloo.  The private one can be configured to scan music on chosen paths.
 The Baloo one is much faster because Baloo is providing all needed data from
 its own database.  You can build and play your own playlist.")
     (license license:lgpl3+)))
 
+(define-public ffmpegthumbs
+  (package
+    (name "ffmpegthumbs")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/ffmpegthumbs-" version ".tar.xz"))
+       (sha256
+        (base32 "1w6070ng40nf99wpl6p5s8nx0icfx2c26vvnz4f9fx7l7pldh6n9"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("ffmpeg" ,ffmpeg)
+       ("kconfig" ,kconfig)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("qtbase" ,qtbase)))
+    (home-page "https://kde.org/applications/multimedia/org.kde.ffmpegthumbs")
+    (synopsis "Video thumbnail generator for KDE using ffmpeg")
+    (description "
+FFMpegThumbs is a video thumbnail generator for KDE file managers
+like Dolphin and Konqueror.  It enables them to show preview images
+of video files using FFMpeg.
+
+This package is part of the KDE multimedia module.")
+    (license license:gpl2+)))
+
 (define-public juk
   (package
     (name "juk")
@@ -616,6 +688,8 @@ Its features include:
        ("solid" ,solid)))
     (home-page "https://cgit.kde.org/libkcompactdisc.git/")
     (synopsis "KDE library for playing & ripping CDs")
-    (description "KDE library for playing & ripping CDs.")
+    (description "The KDE Compact Disc library provides an API for
+applications using the KDE Platform to interface with the CD drives for audio
+CDs.")
     (license ;; GPL for programs, LGPL for libraries
      (list license:gpl2+ license:lgpl2.0+))))