gnu: Add python-trytond-analytic-account.
[jackhill/guix/guix.git] / gnu / packages / tryton.scm
index 7cde0db..8f6c89a 100644 (file)
@@ -413,6 +413,59 @@ Template and Product.")
 most of accounting needs.")
     (license license:gpl3+)))
 
+(define-public python-trytond-analytic-account
+  (package
+    (name "python-trytond-analytic-account")
+    (version "5.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "trytond_analytic_account" version))
+       (sha256
+        (base32 "02hv3mmhadz248vy4azrw8rs2mwgsixd4cnzsm82z15gjmfxl34q"))))
+    (build-system python-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (let ((runtest
+                  (string-append
+                   (assoc-ref %build-inputs "python-trytond")
+                   "/lib/python"
+                   ,(version-major+minor (package-version python))
+                   "/site-packages/trytond/tests/run-tests.py")))
+             (lambda* (#:key inputs outputs #:allow-other-keys)
+               (add-installed-pythonpath inputs outputs)
+               (invoke "python" runtest "-m" "analytic_account")))))))
+    (native-inputs
+     `(("python" ,python-minimal-wrapper)
+       ("python-dateutil" ,python-dateutil)
+       ("python-genshi" ,python-genshi)
+       ("python-lxml" ,python-lxml)
+       ("python-magic" ,python-magic)
+       ("python-passlib" ,python-passlib)
+       ("python-polib" ,python-polib)
+       ("python-proteus" ,python-proteus)
+       ("python-relatorio" ,python-relatorio)
+       ("python-werkzeug" ,python-werkzeug)
+       ("python-wrapt" ,python-wrapt)))
+    (propagated-inputs
+     `(("python-sql" ,python-sql)
+       ("python-trytond" ,python-trytond)
+       ("python-trytond-account"
+        ,python-trytond-account)
+       ("python-trytond-company"
+        ,python-trytond-company)
+       ("python-trytond-currency"
+        ,python-trytond-currency)
+       ("python-trytond-party" ,python-trytond-party)))
+    (home-page "https://www.tryton.org/")
+    (synopsis "Tryton module for analytic accounting")
+    (description
+     "This package provides a Tryton module that adds the fundamentals
+required to analyse accounting using multiple different axes.")
+    (license license:gpl3+)))
+
 (define-public python-trytond-stock
   (package
     (name "python-trytond-stock")