gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / scheme.scm
index 4d71712..43853fa 100644 (file)
@@ -118,14 +118,14 @@ development cycle.")
 (define-public bigloo
   (package
     (name "bigloo")
-    (version "4.0a")
+    (version "4.0b")
     (source (origin
              (method url-fetch)
              (uri (string-append "ftp://ftp-sop.inria.fr/indes/fp/Bigloo/bigloo"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "1771z43nmf9awjvlvrpjfhzcfxsbw2qipir8g9r47sygf2vn59yl"))))
+               "1fck2h48f0bvh8fl437cagmp0syfxy9lqacy1zwsis20fc76jvzi"))))
     (build-system gnu-build-system)
     (arguments
      `(#:patches (list (assoc-ref %build-inputs "patch/shebangs"))
@@ -150,8 +150,14 @@ development cycle.")
                                      "/lib/bigloo/" ,version)))
 
                    ;; Those variables are used by libgc's `configure'.
-                   (setenv "SHELL" (which "bash"))
-                   (setenv "CONFIG_SHELL" (which "bash"))
+                   (setenv "SHELL" (which "sh"))
+                   (setenv "CONFIG_SHELL" (which "sh"))
+
+                   ;; ... but they turned out to be overridden later, so work
+                   ;; around that.
+                   (substitute* (find-files "gc" "^configure-gc")
+                     (("sh=/bin/sh")
+                      (string-append "sh=" (which "sh"))))
 
                    ;; The `configure' script doesn't understand options
                    ;; of those of Autoconf.
@@ -162,21 +168,14 @@ development cycle.")
                                (string-append"--mv=" (which "mv"))
                                (string-append "--rm=" (which "rm"))))))
                  (alist-cons-after
-                  'patch 'patch-absolute-file-names
-                  (lambda _
-                    (substitute* (cons "configure"
-                                       (find-files "gc" "^install-gc"))
-                      (("/bin/rm") (which "rm"))
-                      (("/bin/mv") (which "mv"))))
-                  (alist-cons-after
-                   'install 'install-emacs-modes
-                   (lambda* (#:key outputs #:allow-other-keys)
-                     (let* ((out (assoc-ref outputs "out"))
-                            (dir (string-append out "/share/emacs/site-lisp")))
-                       (zero? (system* "make" "-C" "bmacs" "all" "install"
-                                       (string-append "EMACSBRAND=emacs24")
-                                       (string-append "EMACSDIR=" dir)))))
-                   %standard-phases)))))
+                  'install 'install-emacs-modes
+                  (lambda* (#:key outputs #:allow-other-keys)
+                    (let* ((out (assoc-ref outputs "out"))
+                           (dir (string-append out "/share/emacs/site-lisp")))
+                      (zero? (system* "make" "-C" "bmacs" "all" "install"
+                                      (string-append "EMACSBRAND=emacs24")
+                                      (string-append "EMACSDIR=" dir)))))
+                  %standard-phases))))
     (inputs
      `(("emacs" ,emacs)
        ("patch/shebangs" ,(search-patch "bigloo-gc-shebangs.patch"))
@@ -252,6 +251,7 @@ between Scheme and C# programs.")
                                         "\\.so$")))))
          %standard-phases))
        #:tests? #f                                ; no test suite
+       #:patches (list (assoc-ref %build-inputs "patch/bigloo-4.0b"))
        #:modules ((guix build gnu-build-system)
                   (guix build utils)
                   (ice-9 popen)
@@ -260,7 +260,10 @@ between Scheme and C# programs.")
                   (srfi srfi-1))))
     (inputs `(("bigloo" ,bigloo)
               ("which" ,which)
-              ("patchelf" ,patchelf)))
+              ("patchelf" ,patchelf)
+
+              ("patch/bigloo-4.0b"
+               ,(search-patch "hop-bigloo-4.0b.patch"))))
     (home-page "http://hop.inria.fr/")
     (synopsis "A multi-tier programming language for the Web 2.0")
     (description