gnu: Add texlive-etoolbox.
[jackhill/guix/guix.git] / gnu / packages / ebook.scm
index 964fdd7..cf424f2 100644 (file)
@@ -2,7 +2,7 @@
 ;;; Copyright © 2015, 2016 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017 Alex Griffin <a@ajgrf.com>
-;;; Copyright © 2017 Brendan Tildesley <brendan.tildesley@openmailbox.org>
+;;; Copyright © 2017, 2019 Brendan Tildesley <mail@brendan.scot>
 ;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
@@ -79,7 +79,7 @@
 (define-public calibre
   (package
     (name "calibre")
-    (version "3.41.3")
+    (version "3.42.0")
     (source
       (origin
         (method url-fetch)
                             version ".tar.xz"))
         (sha256
          (base32
-          "167hhv4wimkjnyfgqkyqmaiixhicbxacy6190gps98jyj4csi8ra"))
-        ;; Remove non-free or doubtful code, see
+          "0ymdhws3cb44p3fb24vln1wx6s7qnb8rr241jvm6qbj5rnp984dm"))
+        ;; Unbundle python2-odfpy. 
         ;; https://lists.gnu.org/archive/html/guix-devel/2015-02/msg00478.html
         (modules '((guix build utils)))
         (snippet
           '(begin
-            (delete-file "src/odf/thumbnail.py")
-            #t))
+             (delete-file-recursively "src/odf")
+             (delete-file "resources/viewer.js")
+             (delete-file "resources/viewer.html")
+             (delete-file "resources/mozilla-ca-certs.pem")
+             (delete-file "resources/calibre-portable.bat")
+             (delete-file "resources/calibre-portable.sh")
+             #t))
         (patches (search-patches "calibre-no-updates-dialog.patch"
+                                 "calibre-remove-test-bs4.patch" ; TODO: fix test.
+                                 "calibre-remove-test-sqlite.patch" ; TODO: fix test.
                                  "calibre-remove-test-unrar.patch"))))
     (build-system python-build-system)
     (native-inputs
        ("libmtp" ,libmtp)
        ("libpng" ,libpng)
        ("libusb" ,libusb)
-       ("libxrender" ,libxrender)
        ("openssl" ,openssl)
        ("optipng" ,optipng)
        ("podofo" ,podofo)
        ;; python2-msgpack is needed for the network content server to work.
        ("python2-msgpack" ,python2-msgpack)
        ("python2-netifaces" ,python2-netifaces)
+       ("python2-odfpy" ,python2-odfpy)
        ("python2-pillow" ,python2-pillow)
        ("python2-psutil" ,python2-psutil)
        ("python2-pygments" ,python2-pygments)
        ("python2-pyqt" ,python2-pyqt)
        ("python2-sip" ,python2-sip)
        ("python2-regex" ,python2-regex)
-       ;; python2-unrardll is needed for decompressing RAR files.
-       ;; A program called 'pdf2html' is needed for reading PDF books
-       ;; in the web interface.
        ("sqlite" ,sqlite)))
     (arguments
      `(#:python ,python-2
-       #:test-target "check"
-       #:tests? #f ; FIXME: enable once flake8 is packaged
        ;; Calibre is using setuptools by itself, but the setup.py is not
        ;; compatible with the shim wrapper (taken from pip) we are using.
        #:use-setuptools? #f
               ;; This informs the tests we are a continuous integration
               ;; environment and thus have no networking.
               (setenv "CI" "true")
+              ;; The Qt test complains about being unable to load all image plugins, and I
+              ;; notice the available plugins list it shows lacks 'svg'. Adding qtsvg doesn't
+              ;; fix it, so I'm not sure how to fix it.  TODO: Fix test and remove this.
+              (setenv "SKIP_QT_BUILD_TEST" "true")
               #t)))
          (add-after 'build 'build-extra
            (lambda* (#:key inputs #:allow-other-keys)
-             (invoke "python2" "setup.py" "mathjax""--system-mathjax" "--path-to-mathjax"
-                     (string-append (assoc-ref inputs "js-mathjax") "/share/javascript/mathjax"))
+             (invoke "python2" "setup.py" "mathjax""--system-mathjax"
+                     "--path-to-mathjax" (string-append
+                                          (assoc-ref inputs "js-mathjax")
+                                          "/share/javascript/mathjax"))
              (invoke "python2" "setup.py" "rapydscript")))
+         (add-after 'install 'install-man-pages
+           (lambda* (#:key outputs #:allow-other-keys)
+             (copy-recursively
+              "man-pages"
+              (string-append (assoc-ref outputs "out") "/share/man"))
+             #t))
          ;; The font TTF files are used in some miscellaneous tests, so we
          ;; unbundle them here to avoid patching the tests.
          (add-after 'install 'unbundle-font-liberation