gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / emacs.scm
index 9a10796..e517dc8 100644 (file)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages texinfo)
   #:use-module (gnu packages gnutls)
   #:use-module (gnu packages pkg-config)
-  #:use-module (gnu packages guile))
+  #:use-module (gnu packages guile)
+  #:use-module (gnu packages xorg)
+  #:use-module (gnu packages lesstif)
+  #:use-module (gnu packages libjpeg)
+  #:use-module (gnu packages libtiff)
+  #:use-module (gnu packages libpng)
+  #:use-module ((gnu packages compression)
+                #:renamer (symbol-prefix-proc 'compression:))
+  #:use-module (gnu packages xml)
+  #:use-module (gnu packages glib))
 
 (define-public emacs
   (package
@@ -43,7 +53,8 @@
     (arguments
      '(#:configure-flags
        (list (string-append "--with-crt-dir=" (assoc-ref %build-inputs "libc")
-                            "/lib"))
+                            "/lib")
+             "--with-gif=no")                     ; XXX: add libungif
        #:patches (list (assoc-ref %build-inputs "patch/epaths"))
        #:phases (alist-cons-before
                  'configure 'fix-/bin/pwd
        ("ncurses" ,ncurses)
 
        ;; TODO: Add the optional dependencies.
-       ;; ("xlibs" ,xlibs)
-       ;; ("gtk+" ,gtk+)
-       ;; ("libXft" ,libXft)
-       ;; ("libtiff" ,libtiff)
+       ("xlibs" ,libx11)
+       ("gtk+" ,gtk+)
+       ("libXft" ,libxft)
+       ("libtiff" ,libtiff)
        ;; ("libungif" ,libungif)
-       ;; ("libjpeg" ,libjpeg)
-       ;; ("libpng" ,libpng)
-       ;; ("libXpm" ,libXpm)
-       ;; ("libxml2" ,libxml2)
-       ;; ("dbus-library" ,dbus-library)
+       ("libjpeg" ,libjpeg-8)
+
+       ;; When looking for libpng `configure' links with `-lpng -lz', so we
+       ;; must also provide zlib as an input.
+       ("libpng" ,libpng)
+       ("zlib" ,compression:zlib)
+
+       ("libXpm" ,libxpm)
+       ("libxml2" ,libxml2)
+       ("dbus" ,dbus)
 
        ("patch/epaths" ,(search-patch "emacs-configure-sh.patch"))
        ))
     (home-page "http://www.gnu.org/software/emacs/")
-    (synopsis
-     "GNU Emacs 24, the extensible, customizable text editor")
+    (synopsis "The extensible, customizable, self-documenting text editor")
     (description
      "GNU Emacs is an extensible, customizable text editor—and more.  At its
 core is an interpreter for Emacs Lisp, a dialect of the Lisp
@@ -101,13 +116,13 @@ separately.")
 (define-public geiser
   (package
     (name "geiser")
-    (version "0.3")
+    (version "0.4")
     (source (origin
              (method url-fetch)
-             (uri (string-append "mirror://savannah/geiser/0.3/geiser-"
-                                 version ".tar.gz"))
+             (uri (string-append "mirror://savannah/geiser/" version
+                                 "/geiser-" version ".tar.gz"))
              (sha256
-              (base32 "1yzx0k1y5dq0m9dr3zdrxd8li0pddzblzj1ngd0spvsvvzz6v13j"))))
+              (base32 "0ds7zk9b1839l9fsqfsgrby6manvy1cf5bjniiqhxl55h0cr6ijp"))))
     (build-system gnu-build-system)
     (inputs `(("guile" ,guile-2.0)
               ("emacs" ,emacs)))