gnu: rust-schannel-0.1: Don't hide package.
[jackhill/guix/guix.git] / gnu / packages / w3m.scm
index 9199cbd..1ec0767 100644 (file)
@@ -1,5 +1,9 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
+;;; Copyright © 2016, 2017, 2018 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
+;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 
 (define-module (gnu packages w3m)
   #:use-module ((guix licenses) #:select (x11-style))
-  #:use-module ((gnu packages gettext)
-                #:renamer (symbol-prefix-proc 'guix:))
+  #:use-module (gnu packages gettext)
   #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages ncurses)
-  #:use-module (gnu packages openssl)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages xorg)
   #:use-module (gnu packages)
   #:use-module (guix packages)
-  #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu))
 
 (define-public w3m
   (package
     (name "w3m")
-    (version "0.5.3")
-    (source
-     (origin
-      (method url-fetch)
-      (uri (string-append "mirror://sourceforge/w3m/w3m-"
-                          version ".tar.gz"))
-      (sha256
-       (base32
-        "1qx9f0kprf92r1wxl3sacykla0g04qsi0idypzz24b7xy9ix5579"))))
+    (version "0.5.3+git20190105")
+    (source (origin
+              (method git-fetch)
+              ;; Debian's fork of w3m is the only one that is still maintained.
+              (uri (git-reference
+                    (url "https://salsa.debian.org/debian/w3m.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1fbg2p8qh2gvi3g4iz4q6vc0k70pf248r4yndi5lcn2m3mzvjx0i"))))
     (build-system gnu-build-system)
-    (arguments `(#:tests? #f  ; no check target
-                 #:phases (alist-cons-before
-                           'configure 'fix-perl
-                           (lambda _
-                             ;; https://launchpad.net/bugs/935540
-                             ;; 'struct file_handle' is used by 'glibc'
-                             (substitute* '("istream.c" "istream.h")
-                              (("struct[[:blank:]]+file_handle")
-                               "struct w3m_file_handle"))
-                             (substitute* '("scripts/w3mmail.cgi.in"
-                                            "scripts/dirlist.cgi.in")
-                               (("@PERL@") (which "perl"))))
-                           %standard-phases)
-                 ;; cf. https://bugs.archlinux.org/task/33397
-                 #:patches (list (assoc-ref %build-inputs
-                                            "patch/fix-compile"))
-                 #:patch-flags '("-p0")))
+    (arguments
+     '(#:tests? #f  ; no check target
+       ;; Use $EDITOR instead of a hard-coded value.
+       #:configure-flags '("--with-editor=")
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'fix-perl
+           (lambda _ (substitute* '("scripts/w3mmail.cgi.in"
+                                    "scripts/dirlist.cgi.in")
+                       (("@PERL@") (which "perl")))
+             #t)))))
     (inputs
-     `(("gettext" ,guix:gettext)
+     `(("gdk-pixbuf" ,gdk-pixbuf)
        ("libgc" ,libgc)
+       ("libx11" ,libx11)
        ("ncurses" ,ncurses)
        ("openssl" ,openssl)
+       ("zlib" ,zlib)))
+    (native-inputs
+     `(("gettext" ,gettext-minimal)
        ("perl" ,perl)
-       ("pkg-config" ,pkg-config)
-       ("zlib" ,zlib)
-       ("patch/fix-compile" ,(search-patch "w3m-fix-compile.patch"))))
+       ("pkg-config" ,pkg-config)))
     (home-page "http://w3m.sourceforge.net/")
-    (synopsis "w3m, a text-mode web browser")
+    (synopsis "Text-mode web browser")
     (description
-     "w3m is a text-based web browser as well as a pager like 'more' or
-'less'.  With w3m you can browse web pages through a terminal emulator
+     "w3m is a text-based web browser as well as a pager like @code{more} or
+@code{less}.  With w3m you can browse web pages through a terminal emulator
 window.  Moreover, w3m can be used as a text formatting tool which
 typesets HTML into plain text.")
     (license (x11-style "file://doc/README"