gnu: Add texlive-times.
[jackhill/guix/guix.git] / gnu / packages / audio.scm
index f3f592c..c6c42f6 100644 (file)
@@ -21,6 +21,7 @@
 ;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -321,7 +322,7 @@ engineers, musicians, soundtrack editors and composers.")
 (define-public audacity
   (package
     (name "audacity")
-    (version "2.2.2")
+    (version "2.3.2")
     (source
      (origin
        (method git-fetch)
@@ -331,7 +332,7 @@ engineers, musicians, soundtrack editors and composers.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "10maxmjxbmjybj7n4m7a9bbm7g8xxw8f8vbsf7c9ih5j2gr15ihs"))
+         "08w96124vv8k4myd4vifq73ningq6404x889wvg2sk016kc4dfv1"))
        (patches (search-patches "audacity-build-with-system-portaudio.patch"))
        (modules '((guix build utils)))
        (snippet
@@ -2120,14 +2121,14 @@ different audio devices such as ALSA or PulseAudio.")
 (define-public qjackctl
   (package
     (name "qjackctl")
-    (version "0.5.8")
+    (version "0.5.9")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/qjackctl/qjackctl/"
                                   version "/qjackctl-" version ".tar.gz"))
               (sha256
                (base32
-                "1r5hf3hcr20n93jrrm7xk2zf6yx264pcr4d10cpybhrancxh602n"))))
+                "1saywsda9m124rmjp7i3n0llryaliabjxhqhvqr6dm983qy7pypk"))))
     (build-system gnu-build-system)
     (arguments
      '(#:tests? #f))                    ; no check target
@@ -2428,17 +2429,17 @@ the Turtle syntax.")
 (define-public suil
   (package
     (name "suil")
-    (version "0.10.2")
+    (version "0.10.4")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "https://download.drobilla.net/suil-"
-                                 version ".tar.bz2"))
-             (sha256
-              (base32
-               "00d43m0nai63ajb7rkm9v084jcih206y17ib3160zcvzc885ji4z"))))
+              (method url-fetch)
+              (uri (string-append "https://download.drobilla.net/suil-"
+                                  version ".tar.bz2"))
+              (sha256
+               (base32
+                "0ay7hl6nr6ip1nn9k2m8ri3b52b6sx9mhixmcy4fy3kr2a88ksd1"))))
     (build-system waf-build-system)
     (arguments
-     `(#:tests? #f        ; no check target
+     `(#:tests? #f                      ; no check target
        #:configure-flags
        '("CXXFLAGS=-std=gnu++11")))
     (inputs
@@ -2869,19 +2870,17 @@ interface.")
 (define-public qsynth
   (package
     (name "qsynth")
-    (version "0.5.6")
+    (version "0.5.7")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/qsynth/qsynth/" version
                            "/qsynth-" version ".tar.gz"))
        (sha256
-        (base32 "0h4hhja8qbyzd6v24flw9wr4mwl03nplryx1gyrppn7sg13l1sx6"))))
+        (base32 "18im4w8agj60nkppwbkxqnhpp13z5li3w30kklv4lgs20rvgbvl6"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; no "check" phase
-       #:configure-flags
-       '("CXXFLAGS=-std=gnu++11")))
+     `(#:tests? #f))                    ; no "check" phase
     (native-inputs
      `(("qttools" ,qttools)
        ("pkg-config" ,pkg-config)))
@@ -2889,7 +2888,7 @@ interface.")
      `(("fluidsynth" ,fluidsynth)
        ("qtbase" ,qtbase)
        ("qtx11extras" ,qtx11extras)))
-    (home-page "http://qsynth.sourceforge.net")
+    (home-page "https://qsynth.sourceforge.io")
     (synopsis "Graphical user interface for FluidSynth")
     (description
      "Qsynth is a GUI front-end application for the FluidSynth SoundFont
@@ -3383,14 +3382,14 @@ on the ALSA software PCM plugin.")
 (define-public snd
   (package
     (name "snd")
-    (version "19.3")
+    (version "19.5")
     (source (origin
               (method url-fetch)
               (uri (string-append "ftp://ccrma-ftp.stanford.edu/pub/Lisp/"
                                   "snd-" version ".tar.gz"))
               (sha256
                (base32
-                "16j3fqyw361wdsr1076f0p3va2y7wdzq1lvr4ijz1ajmbxdlc723"))))
+                "0sk6iyykwi2mm3f1g4r0iqbsrwk3zmyagp6jjqkh8njbq42cjr1y"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
@@ -3568,7 +3567,7 @@ representations.")
     (arguments
      `(#:configure-flags
        (list (string-append "PREFIX=" %output)
-             (string-append "FONT_DIR=" %output "/usr/share/consolefonts"))
+             (string-append "FONT_DIR=" %output "/share/consolefonts"))
        #:make-flags
        (let ((lib (string-append %output "/lib")))
          (list (string-append "cava_LDFLAGS = -L" lib " -Wl,-rpath " lib)))
@@ -3701,7 +3700,7 @@ library.")
 (define-public faudio
   (package
     (name "faudio")
-    (version "19.06")
+    (version "19.07")
     (source
      (origin
        (method git-fetch)
@@ -3710,7 +3709,7 @@ library.")
              (commit version)))
        (file-name (string-append name "-" version "-checkout"))
        (sha256
-        (base32 "1azjf972hik1cizsblbvfp38xz7dx368pbpw3pd6z1xk9mnrhi6s"))))
+        (base32 "1wf6skc5agaikc9qgwk8bx56sad31fafs53lqqn4jmx8i76pl0lw"))))
     (arguments
      '(#:tests? #f                      ; No tests.
        #:configure-flags '("-DFFMPEG=ON")))
@@ -3723,3 +3722,65 @@ library.")
     (description "FAudio is an XAudio reimplementation that focuses solely on
 developing fully accurate DirectX Audio runtime libraries.")
     (license license:zlib)))
+
+(define-public gnaural
+  (package
+    (name "gnaural")
+    (version "20110606")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/gnaural/Gnaural/gnaural_"
+                           version ".tar.xz"))
+       (sha256
+        (base32
+         "1gq519c0imsh57zklyi0f8h64l3ai48lh672c834470z8c6kvbfi"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("gtk+" ,gtk+-2)
+       ("libsndfile" ,libsndfile)
+       ("portaudio" ,portaudio)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://gnaural.sourceforge.net/")
+    (synopsis "Binaural beat synthesizer")
+    (description "Gnaural is a programmable auditory binaural beat synthesizer
+intended to be used for brainwave entrainment.  Gnaural supports creation of
+binaural beat tracks of different frequencies and exporting of tracks into
+different audio formats.  Gnaural can also be linked over the internet with
+other Gnaural instances, allowing synchronous sessions between many users.")
+    (license license:gpl2+)))
+
+(define-public darkice
+  (package
+    (name "darkice")
+    (version "1.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/darkice/darkice/"
+                                  version "/darkice-" version ".tar.gz"))
+              (sha256
+               (base32 "1rlxds7ssq7nk2in4s46xws7xy9ylxsqgcz85hxjgh17lsm0y39c"))
+              (patches
+               (search-patches "darkice-workaround-fpermissive-error.patch"))))
+    (build-system gnu-build-system)
+    (native-inputs `(("pkg-config" ,pkg-config)))
+    (inputs `(("lame" ,lame)
+              ("libvorbis" ,libvorbis)
+              ("opus" ,opus)
+              ("twolame" ,twolame)
+              ("alsa-lib" ,alsa-lib)
+              ("pulseaudio" ,pulseaudio)
+              ("jack" ,jack-1)
+              ("libsamplerate" ,libsamplerate)))
+    (arguments
+     `(#:configure-flags
+       (list (string-append "--with-lame-prefix="
+                            (assoc-ref %build-inputs "lame")))))
+    (home-page "http://www.darkice.org/")
+    (synopsis "Live audio streamer")
+    (description "DarkIce is a live audio streamer.  It takes audio input from
+a sound card, encodes it into Ogg Vorbis and/or mp3, and sends the audio
+stream to one or more IceCast and/or ShoutCast servers.")
+    (license license:gpl3+)))