gnu: tuxguitar: Build with icedtea-8.
[jackhill/guix/guix.git] / gnu / packages / inkscape.scm
index e20ca66..4c68af0 100644 (file)
@@ -2,6 +2,7 @@
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2014, 2016 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public inkscape
   (package
     (name "inkscape")
-    (version "0.92.0")
+    (version "0.92.1")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://media.inkscape.org/dl/"
                                   "resources/file/"
                                   "inkscape-" version ".tar.bz2"))
+              (patches
+               (list
+                ;; Fix compatibility with poppler >= 0.58.
+                (origin
+                  (method url-fetch)
+                  (uri (string-append "https://gitlab.com/inkscape/inkscape/commit/"
+                                      "9418824967eb4c53371ef8588243fed4cab496e0.patch"))
+                  (sha256
+                   (base32
+                    "0wwyhkqb1qyazz5f6wqrc223l6k8qnmadiw28q8gihlgvh38rvll")))))
               (sha256
                (base32
-                "0mmssxnxsvb3bpm7ck5pqvwyacrz1nkyacs571jx8j04l1cw3d5q"))))
+                "01chr3vh728dkg7l7lilwgmh5nrp784khdhjgpqjbq9dh2zhax15"))))
     (build-system cmake-build-system)
     (inputs
      `(("aspell" ,aspell)