gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / mpd.scm
index 4138f4d..7df0d82 100644 (file)
@@ -5,7 +5,7 @@
 ;;; Copyright © 2014 Ian Denhardt <ian@zenhack.net>
 ;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
 ;;; Copyright © 2016, 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Evan Straw <evan.straw99@gmail.com>
 ;;; Copyright © 2020 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2020 Lars-Dominik Braun <lars@6xq.net>
@@ -105,7 +105,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
 (define-public mpd
   (package
     (name "mpd")
-    (version "0.22.4")
+    (version "0.22.6")
     (source (origin
               (method url-fetch)
               (uri
@@ -114,7 +114,7 @@ interfacing MPD in the C, C++ & Objective C languages.")
                               "/mpd-" version ".tar.xz"))
               (sha256
                (base32
-                "1l4x2jrv04hp4q9gyfg79g78bk68lrd6wd3hysl6y91rln9sj7l9"))))
+                "0pjdd8qwia1dsfkzyxcasfhxiqwk6lcz333z8w9vcg2wi6j4kq9b"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags '("-Ddocumentation=enabled")))
@@ -196,7 +196,7 @@ player daemon.")
 (define-public ncmpc
   (package
     (name "ncmpc")
-    (version "0.42")
+    (version "0.45")
     (source (origin
               (method url-fetch)
               (uri
@@ -205,7 +205,7 @@ player daemon.")
                               "/ncmpc-" version ".tar.xz"))
               (sha256
                (base32
-                "0kfdyvqd2dfrxll5bla8mm10xvpngshlmyjf6wic4wbafqflgxx5"))))
+                "11gpy6kd7xr8x7f7gwdwfryxyc58cd135ds28gnz40p08xj49zqp"))))
     (build-system meson-build-system)
     (arguments
      `(#:configure-flags
@@ -307,9 +307,6 @@ information about tracks being played to a scrobbler, such as Libre.FM.")
 interface for the Music Player Daemon.")
     (license license:lgpl3+)))
 
-(define-public python2-mpd2
-  (package-with-python2 python-mpd2))
-
 (define-public sonata
   (package
     (name "sonata")
@@ -444,7 +441,7 @@ support")
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("eudev"eudev)
+     `(("eudev" ,eudev)
        ("ffmpeg" ,ffmpeg)
        ("libcdio-paranoia" ,libcdio-paranoia)
        ("libebur128" ,libebur128)