gnu: python-flask: Run test suite.
[jackhill/guix/guix.git] / gnu / packages / python-web.scm
index 832ca93..8056c86 100644 (file)
@@ -1591,6 +1591,14 @@ minimum of WSGI.")
                (base32
                 "0j6f4a9rpfh25k1gp7azqhnni4mb4fgy50jammgjgddw1l3w0w92"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (invoke "python" "-m" "pytest"))))))
+    (native-inputs
+     `(("python-pytest" ,python-pytest)))
     (propagated-inputs
      `(("python-itsdangerous" ,python-itsdangerous)
        ("python-jinja2" ,python-jinja2)