gnu: facter: Update to 4.0.33.
[jackhill/guix/guix.git] / gnu / packages / valgrind.scm
index 44a8381..75e8529 100644 (file)
@@ -1,5 +1,9 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016, 2020 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public valgrind
   (package
     (name "valgrind")
-    (version "3.10.0")
+    (version "3.15.0")
     (source (origin
-             (method url-fetch)
-             (uri (string-append "http://valgrind.org/downloads/valgrind-"
-                                 version ".tar.bz2"))
-             (sha256
-              (base32
-               "1jgd42vsx0bcblp91bd61hd5wpy0gghh09wxgm65m666vy17y103"))))
+              (method url-fetch)
+              (uri (list (string-append "https://sourceware.org/pub/valgrind"
+                                        "/valgrind-" version ".tar.bz2")
+                         (string-append "ftp://sourceware.org/pub/valgrind"
+                                        "/valgrind-" version ".tar.bz2")))
+              (sha256
+               (base32
+                "1ccawxrni8brcvwhygy12iprkvz409hbr9xkk1bd03gnm2fplz21"))
+              (patches (search-patches "valgrind-enable-arm.patch"))))
     (build-system gnu-build-system)
+    (outputs '("doc"                              ;16 MB
+               "out"))
     (arguments
-     '(#:phases (alist-cons-after
-                 'install 'patch-suppression-files
-                 (lambda* (#:key outputs #:allow-other-keys)
-                   ;; Don't assume the FHS.
-                   (let* ((out (assoc-ref outputs "out"))
-                          (dir (string-append out "/lib/valgrind")))
-                     (substitute* (find-files dir "\\.supp$")
-                       (("obj:/lib") "obj:*/lib")
-                       (("obj:/usr/X11R6/lib") "obj:*/lib")
-                       (("obj:/usr/lib") "obj:*/lib"))
-                     #t))
-                 %standard-phases)))
-    (inputs `(;; GDB is needed to provide a sane default for `--db-command'.
-              ("gdb" ,gdb)))
-    (native-inputs `(("perl" ,perl)))
-    (home-page "http://www.valgrind.org/")
+     `(,@(if (string-prefix? "powerpc" (or (%current-target-system)
+                                           (%current-system)))
+           `(#:make-flags '("CFLAGS+=-maltivec"))
+           '())
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'patch-suppression-files
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; Don't assume the FHS.
+             (let* ((out (assoc-ref outputs "out"))
+                    (dir (string-append out "/lib/valgrind")))
+               (substitute* (find-files dir "\\.supp$")
+                 (("obj:/lib") "obj:*/lib")
+                 (("obj:/usr/X11R6/lib") "obj:*/lib")
+                 (("obj:/usr/lib") "obj:*/lib"))
+               #t)))
+         (add-after 'install 'install-doc
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((orig (format #f "~a/share/doc" (assoc-ref outputs "out")))
+                   (dest (format #f "~a/share" (assoc-ref outputs "doc"))))
+               (mkdir-p dest)
+               (rename-file orig dest)
+               #t))))))
+    (inputs
+     ;; GDB is needed to provide a sane default for `--db-command'.
+     `(("gdb" ,gdb)))
+    (native-inputs
+     `(("perl" ,perl)))
+    (home-page "https://www.valgrind.org/")
     (synopsis "Debugging and profiling tool suite")
     (description
      "Valgrind is an instrumentation framework for building dynamic analysis
 tools.  There are Valgrind tools that can automatically detect many memory
-management and threading bugs, and profile your programs in detail. You can
+management and threading bugs, and profile your programs in detail.  You can
 also use Valgrind to build new tools.")
-    (license gpl2+)
-
-    ;; Building VEX on mips64el-linux fails with "opcode not supported on this
-    ;; processor: mips3".
-    (supported-systems (delete "mips64el-linux" %supported-systems))))
+    (license gpl2+)))