gnu: khal: Use HTTPS home page.
[jackhill/guix/guix.git] / gnu / packages / calendar.scm
index 0080542..2969228 100644 (file)
@@ -5,6 +5,7 @@
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
 ;;; Copyright © 2016 Stefan Reichoer <stefan@xsteve.at>
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 Troy Sankey <sankeytms@gmail.com>
 ;;; Copyright © 2016 Stefan Reichoer <stefan@xsteve.at>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 
 (define-module (gnu packages calendar)
   #:use-module (gnu packages)
 
 (define-module (gnu packages calendar)
   #:use-module (gnu packages)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix packages)
   #:use-module (guix download)
-  #:use-module (guix build utils)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system python)
   #:use-module (gnu packages base)
   #:use-module (gnu packages check)
-  #:use-module (gnu packages databases)
   #:use-module (gnu packages dav)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages dav)
   #:use-module (gnu packages freedesktop)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages icu4c)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python)
+  #:use-module (gnu packages python-xyz)
+  #:use-module (gnu packages sqlite)
   #:use-module (gnu packages time)
   #:use-module (gnu packages time)
+  #:use-module (gnu packages xml)
   #:use-module (srfi srfi-26))
 
 (define-public libical
   (package
     (name "libical")
   #:use-module (srfi srfi-26))
 
 (define-public libical
   (package
     (name "libical")
-    (version "2.0.0")
+    (version "3.0.4")
     (source (origin
               (method url-fetch)
               (uri (string-append
     (source (origin
               (method url-fetch)
               (uri (string-append
                     version "/libical-" version ".tar.gz"))
               (sha256
                (base32
                     version "/libical-" version ".tar.gz"))
               (sha256
                (base32
-                "1njn2kr0rrjqv5g3hdhpdzrhankyj4fl1bgn76z3g4n1b7vi2k35"))))
+                "0ifisnh42cw5z53hp9p52l3ggc7k877zlqk0n06gdhrk0bhidckj"))))
     (build-system cmake-build-system)
     (arguments
      '(#:tests? #f ; test suite appears broken
     (build-system cmake-build-system)
     (arguments
      '(#:tests? #f ; test suite appears broken
+       #:configure-flags '("-DSHARED_ONLY=true")
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'patch-paths
        #:phases
        (modify-phases %standard-phases
          (add-before 'configure 'patch-paths
-           (lambda _
-             (let ((tzdata (assoc-ref %build-inputs "tzdata")))
+           (lambda* (#:key inputs #:allow-other-keys)
+             ;; FIXME: This should be patched to use TZDIR so we can drop
+             ;; the tzdata dependency.
+             (let ((tzdata (assoc-ref inputs "tzdata")))
                (substitute* "src/libical/icaltz-util.c"
                  (("\\\"/usr/share/zoneinfo\\\",")
                   (string-append "\"" tzdata "/share/zoneinfo\""))
                (substitute* "src/libical/icaltz-util.c"
                  (("\\\"/usr/share/zoneinfo\\\",")
                   (string-append "\"" tzdata "/share/zoneinfo\""))
                  (("\\\"/usr/share/lib/zoneinfo\\\"") "")))
              #t)))))
     (native-inputs
                  (("\\\"/usr/share/lib/zoneinfo\\\"") "")))
              #t)))))
     (native-inputs
-     `(("perl" ,perl)))
+     `(("perl" ,perl)
+       ("pkg-config" ,pkg-config)))
     (inputs
     (inputs
-     `(("icu4c" ,icu4c)
+     `(("glib" ,glib)
+       ("libxml2" ,libxml2)
        ("tzdata" ,tzdata)))
        ("tzdata" ,tzdata)))
+    (propagated-inputs
+     ;; In Requires.private of libical.pc.
+     `(("icu4c" ,icu4c)))
     (home-page "https://libical.github.io/libical/")
     (synopsis "iCalendar protocols and data formats implementation")
     (description
      "Libical is an implementation of the iCalendar protocols and protocol
 data units.")
     (home-page "https://libical.github.io/libical/")
     (synopsis "iCalendar protocols and data formats implementation")
     (description
      "Libical is an implementation of the iCalendar protocols and protocol
 data units.")
-    (license lgpl2.1)))
+    ;; Can be used with either license.  See COPYING.
+    (license (list license:lgpl2.1 license:mpl2.0))))
 
 (define-public khal
   (package
     (name "khal")
 
 (define-public khal
   (package
     (name "khal")
-    (version "0.9.8")
+    (version "0.10.1")
     (source (origin
              (method url-fetch)
              (uri (pypi-uri "khal" version))
              (sha256
               (base32
     (source (origin
              (method url-fetch)
              (uri (pypi-uri "khal" version))
              (sha256
               (base32
-               "1blx3gxnv7sj302biqphfw7i6ilzl2xlmvzp130n3113scg9w17y"))))
+               "1r8bkgjwkh7i8ygvsv51h1cnax50sb183vafg66x5snxf3dgjl6l"))))
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
     (build-system python-build-system)
     (arguments
      `(#:phases (modify-phases %standard-phases
@@ -98,31 +111,25 @@ data units.")
           (lambda* (#:key inputs outputs #:allow-other-keys)
             ;; Make installed package available for running the tests
             (add-installed-pythonpath inputs outputs)
           (lambda* (#:key inputs outputs #:allow-other-keys)
             ;; Make installed package available for running the tests
             (add-installed-pythonpath inputs outputs)
-            (and
-              (zero? (system* "make" "--directory=doc/" "man"))
-              (install-file
-                "doc/build/man/khal.1"
-                (string-append (assoc-ref outputs "out") "/share/man/man1")))))
+            (invoke "make" "--directory=doc/" "man")
+            (install-file
+             "doc/build/man/khal.1"
+             (string-append (assoc-ref outputs "out") "/share/man/man1"))
+            #t))
         (replace 'check
           (lambda* (#:key inputs #:allow-other-keys)
             ;; The tests require us to choose a timezone.
             (setenv "TZ"
                     (string-append (assoc-ref inputs "tzdata")
                                    "/share/zoneinfo/Zulu"))
         (replace 'check
           (lambda* (#:key inputs #:allow-other-keys)
             ;; The tests require us to choose a timezone.
             (setenv "TZ"
                     (string-append (assoc-ref inputs "tzdata")
                                    "/share/zoneinfo/Zulu"))
-            (zero? (system* "py.test" "tests" "-k"
-                            (string-append
-                              ;; These tests are known to fail in when not
-                              ;; running in a TTY:
-                              ;; https://github.com/pimutils/khal/issues/683
-                              "not test_printics_read_from_stdin "
-                              "and not test_import_from_stdin"))))))))
+            (invoke "py.test" "tests"))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-pytest-cov" ,python-pytest-cov)
        ("python-setuptools-scm" ,python-setuptools-scm)
        ;; Required for tests
        ("python-freezegun" ,python-freezegun)
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-pytest-cov" ,python-pytest-cov)
        ("python-setuptools-scm" ,python-setuptools-scm)
        ;; Required for tests
        ("python-freezegun" ,python-freezegun)
-       ("tzdata" ,tzdata)
+       ("tzdata" ,tzdata-for-tests)
        ("vdirsyncer" ,vdirsyncer)
        ;; Required to build manpage
        ("python-sphinxcontrib-newsfeed" ,python-sphinxcontrib-newsfeed)
        ("vdirsyncer" ,vdirsyncer)
        ;; Required to build manpage
        ("python-sphinxcontrib-newsfeed" ,python-sphinxcontrib-newsfeed)
@@ -139,29 +146,28 @@ data units.")
     (synopsis "Console calendar program")
     (description "Khal is a standards based console calendar program,
 able to synchronize with CalDAV servers through vdirsyncer.")
     (synopsis "Console calendar program")
     (description "Khal is a standards based console calendar program,
 able to synchronize with CalDAV servers through vdirsyncer.")
-    (home-page "http://lostpackets.de/khal/")
-    (license expat)))
+    (home-page "https://lostpackets.de/khal/")
+    (license license:expat)))
 
 (define-public remind
   (package
     (name "remind")
 
 (define-public remind
   (package
     (name "remind")
-    (version "3.1.15")
+    (version "3.1.16")
     (source
      (origin
        (method url-fetch)
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://www.roaringpenguin.com/files/download/"
+       (uri (string-append "https://dianne.skoll.ca/projects/remind/download/"
                            "remind-"
                            (string-join (map (cut string-pad <> 2 #\0)
                                              (string-split version #\.))
                                         ".")
                            ".tar.gz"))
        (sha256
                            "remind-"
                            (string-join (map (cut string-pad <> 2 #\0)
                                              (string-split version #\.))
                                         ".")
                            ".tar.gz"))
        (sha256
-        (base32
-         "1hcfcxz5fjzl7606prlb7dgls5kr8z3wb51h48s6qm8ang0b9nla"))))
+        (base32 "14yavwqmimba8rdpwx3wlav9sfb0v5rcd1iyzqrs08wx07a9pdzf"))))
     (build-system gnu-build-system)
     (arguments
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f))  ;no "check" target
-    (home-page "http://www.roaringpenguin.com/products/remind/")
+     '(#:tests? #f))                    ; no "check" target
+    (home-page "https://dianne.skoll.ca/projects/remind/")
     (synopsis "Sophisticated calendar and alarm program")
     (description
      "Remind allows you to remind yourself of upcoming events and appointments.
     (synopsis "Sophisticated calendar and alarm program")
     (description
      "Remind allows you to remind yourself of upcoming events and appointments.
@@ -169,7 +175,7 @@ Each reminder or alarm can consist of a message sent to standard output, or a
 program to be executed.  It also features: sophisticated date calculation,
 moon phases, sunrise/sunset, Hebrew calendar, alarms, PostScript output and
 proper handling of holidays.")
 program to be executed.  It also features: sophisticated date calculation,
 moon phases, sunrise/sunset, Hebrew calendar, alarms, PostScript output and
 proper handling of holidays.")
-    (license gpl2)))
+    (license license:gpl2)))
 
 (define-public libhdate
   (package
 
 (define-public libhdate
   (package
@@ -190,4 +196,4 @@ proper handling of holidays.")
 of day, written in C, and including bindings for C++, pascal, perl, php, python,
 and ruby.  It includes two illustrative command-line programs, @code{hcal} and
 @code{hdate}, and some snippets and scripts written in the binding languages.")
 of day, written in C, and including bindings for C++, pascal, perl, php, python,
 and ruby.  It includes two illustrative command-line programs, @code{hcal} and
 @code{hdate}, and some snippets and scripts written in the binding languages.")
-    (license gpl3+)))
+    (license license:gpl3+)))