gnu: freecad: Update to 0.18.4.
[jackhill/guix/guix.git] / gnu / packages / nvi.scm
index 8fd736d..187de31 100644 (file)
@@ -18,7 +18,7 @@
 
 (define-module (gnu packages nvi)
   #:use-module (gnu packages)
-  #:use-module (gnu packages databases)
+  #:use-module (gnu packages dbm)
   #:use-module (gnu packages ncurses)
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -37,7 +37,9 @@
                          ".tar.bz2"))
         (sha256
           (base32 "0nbbs1inyrqds0ywn3ln5slv54v5zraq7lszkg8nsavv4kivhh9l"))
-        (patches (list (search-patch "nvi-assume-preserve-path.patch")))
+        (patches (search-patches "nvi-assume-preserve-path.patch"
+                                 "nvi-dbpagesize-binpower.patch"
+                                 "nvi-db4.patch"))
         (snippet
           ;; Create a wrapper for the configure script, make it executable.
           '(let ((conf-wrap (open-output-file "configure")))
                conf-wrap)
              (newline conf-wrap)
              (close-output-port conf-wrap)
-             (chmod "configure" #o0755)))))
+             (chmod "configure" #o0755)
+             #t))))
 
     (build-system gnu-build-system)
     (arguments
-      `(#:out-of-source? #t))
+      `(#:out-of-source? #t
+        #:configure-flags '("--enable-widechar")))
     (inputs
       `(("bdb" ,bdb)
         ("ncurses" ,ncurses)))