gnu: icecat: Update to 78.10.0-guix0-preview1 [security fixes].
[jackhill/guix/guix.git] / gnu / packages / ibus.scm
index f68eaf3..e6001ef 100644 (file)
@@ -1,10 +1,12 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2018 Meiyo Peng <meiyo.peng@gmail.com>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019, 2020 Peng Mei Yu <i@pengmeiyu.com>
+;;; Copyright © 2020 kanichos <kanichos@yandex.ru>
+;;; Copyright © 2020 Vincent Legoll <vincent.legoll@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix build-system cmake)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system glib-or-gtk)
+  #:use-module (guix utils)
   #:use-module (gnu packages)
   #:use-module (gnu packages anthy)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages base)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages cmake)
   #:use-module (gnu packages databases)
   #:use-module (gnu packages datastructures)
+  #:use-module (gnu packages dbm)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages serialization)
+  #:use-module (gnu packages sqlite)
   #:use-module (gnu packages textutils)
+  #:use-module (gnu packages unicode)
   #:use-module (gnu packages xorg))
 
 (define-public ibus
   (package
     (name "ibus")
-    (version "1.5.19")
+    (version "1.5.22")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/ibus/ibus/"
                                   version "/ibus-" version ".tar.gz"))
               (sha256
                (base32
-                "0a94bnpm24581317hdnihwr4cniriml10p4ffgxg14xhvaccfrjb"))))
+                "0jmy2w01phpmqnjnfnak7nvfna57mpgfnl87jwc4iai8ijjynw41"))))
     (build-system glib-or-gtk-build-system)
     (arguments
      `(#:tests? #f  ; tests fail because there's no connection to dbus
-       #:configure-flags `("--disable-emoji-dict" ; cannot find emoji.json path
-                           "--disable-python2"
-                           "--enable-python-library"
-                           ,(string-append "--with-ucd-dir="
-                                           (getcwd) "/ucd")
-                           "--enable-wayland")
-       #:make-flags
-       (list "CC=gcc"
-             (string-append "pyoverridesdir="
-                            (assoc-ref %outputs "out")
-                            "/lib/python3.6/site-packages/gi/overrides/"))
+       #:parallel-build? #f ; race condition discovered with emoji support
+       #:configure-flags (list "--enable-python-library"
+                               (string-append
+                                "--with-unicode-emoji-dir="
+                                (assoc-ref %build-inputs "unicode-emoji")
+                                "/share/unicode/emoji")
+                               (string-append
+                                "--with-emoji-annotation-dir="
+                                (assoc-ref %build-inputs "unicode-cldr-common")
+                                "/share/unicode/cldr/common/annotations")
+                               (string-append "--with-ucd-dir="
+                                              (assoc-ref %build-inputs "ucd")
+                                              "/share/ucd")
+                               "--enable-wayland")
        #:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'prepare-ucd-dir
-           (lambda* (#:key inputs #:allow-other-keys)
-             (mkdir-p "../ucd")
-             (symlink (assoc-ref inputs "unicode-blocks") "../ucd/Blocks.txt")
-             (symlink (assoc-ref inputs "unicode-nameslist") "../ucd/NamesList.txt")
+         (add-after 'unpack 'patch-python-target-directories
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let ((root (string-append (assoc-ref outputs "out")
+                                        "/lib/python"
+                                        ,(version-major+minor (package-version python))
+                                        "/site-packages")))
+               (substitute* "configure"
+                 (("(py2?overridesdir)=.*" _ var)
+                  (string-append var "=" root "/gi/overrides/"))
+                 (("(pkgpython2dir=).*" _ var)
+                  (string-append var root "/ibus"))))
              #t))
          (add-before 'configure 'disable-dconf-update
            (lambda _
                                "/share/X11/locale")))
              (substitute* "ui/gtk3/xkblayout.vala"
                (("\"(setxkbmap|xmodmap)\"" _ prog)
-                (string-append "\"" (assoc-ref inputs prog) "\"")))
+                (string-append "\"" (assoc-ref inputs prog) "/bin/" prog "\"")))
              #t))
          (add-after 'wrap-program 'wrap-with-additional-paths
            (lambda* (#:key outputs #:allow-other-keys)
        ("gconf" ,gconf)
        ("gtk2" ,gtk+-2)
        ("gtk+" ,gtk+)
-       ("intltool" ,intltool)
        ("json-glib" ,json-glib)
        ("libnotify" ,libnotify)
        ("libx11" ,libx11)
        ("python" ,python)))
     (native-inputs
      `(("glib" ,glib "bin") ; for glib-genmarshal
+       ("gettext" ,gettext-minimal)
        ("gobject-introspection" ,gobject-introspection) ; for g-ir-compiler
-       ("unicode-nameslist"
-        ,(origin
-           (method url-fetch)
-           (uri "https://www.unicode.org/Public/UNIDATA/NamesList.txt")
-           (sha256
-            (base32 "0yr2h0nfqhirfi3bxl33z6cc94qqshlpgi06c25xh9754irqsgv8"))))
-       ("unicode-blocks"
-        ,(origin
-           (method url-fetch)
-           (uri "https://www.unicode.org/Public/UNIDATA/Blocks.txt")
-           (sha256
-            (base32 "0lnh9iazikpr548bd7nkaq9r3vfljfvz0rg2462prac8qxk7ni8b"))))
+       ("ucd" ,ucd)
+       ("unicode-emoji" ,unicode-emoji)
+       ("unicode-cldr-common" ,unicode-cldr-common)
        ("vala" ,vala)
        ("pkg-config" ,pkg-config)))
     (native-search-paths
@@ -167,7 +174,7 @@ may also simplify input method development.")
 (define-public ibus-libpinyin
   (package
     (name "ibus-libpinyin")
-    (version "1.10.0")
+    (version "1.12.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/libpinyin/ibus-libpinyin/"
@@ -175,10 +182,12 @@ may also simplify input method development.")
                                   "/ibus-libpinyin-" version ".tar.gz"))
               (sha256
                (base32
-                "0yq8aw4lddiviag8cnik6fp52vvk8lxv6bym13a3xya84c6zii3c"))))
+                "0xl2lmffy42f6h6za05z4vpazpza1a9gsrva65giwyv3kpf652dd"))))
     (build-system glib-or-gtk-build-system)
     (arguments
-     `(#:phases
+     `(#:configure-flags
+       '("--enable-opencc")
+       #:phases
        (modify-phases %standard-phases
          (add-after 'wrap-program 'wrap-with-additional-paths
            (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -186,21 +195,26 @@ may also simplify input method development.")
              ;; PYTHONPATH and GI_TYPELIB_PATH.
              (let ((out (assoc-ref outputs "out")))
                (wrap-program (string-append out "/libexec/ibus-setup-libpinyin")
-                 `("PYTHONPATH" ":" prefix
+                 `("PYTHONPATH" ":" =
                    (,(getenv "PYTHONPATH")
                     ,(string-append (assoc-ref inputs "ibus")
-                                    "/lib/girepository-1.0")))
+                                    "/lib/girepository-1.0")
+                    ,(string-append (assoc-ref outputs "out")
+                                    "/share/ibus-libpinyin/setup/")))
                  `("GI_TYPELIB_PATH" ":" prefix
                    (,(string-append (assoc-ref inputs "ibus")
-                                    "/lib/girepository-1.0"))))
+                                    "/lib/girepository-1.0")
+                    ,(string-append (assoc-ref outputs "out")
+                                    "/share/ibus-libpinyin/setup/"))))
                #t))))))
     (inputs
      `(("ibus" ,ibus)
        ("libpinyin" ,libpinyin)
        ("bdb" ,bdb)
        ("sqlite" ,sqlite)
+       ("opencc" ,opencc)
        ("python" ,python)
-       ("pyxdg" ,python-pyxdg)
+       ("pygobject2" ,python-pygobject)
        ("gtk+" ,gtk+)))
     (native-inputs
      `(("pkg-config" ,pkg-config)
@@ -211,20 +225,20 @@ may also simplify input method development.")
      "This package includes a Chinese pinyin input method and a Chinese
 ZhuYin (Bopomofo) input method based on libpinyin for IBus.")
     (home-page "https://github.com/libpinyin/ibus-libpinyin")
-    (license gpl2+)))
+    (license gpl3+)))
 
 (define-public libpinyin
   (package
     (name "libpinyin")
-    (version "2.2.0")
+    (version "2.6.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/libpinyin/libpinyin/"
                                   "releases/download/" version
-                                  "/libpinyin-2.2.0.tar.gz"))
+                                  "/libpinyin-" version ".tar.gz"))
               (sha256
                (base32
-                "1c4wxvcvjxvk23mcwqvsfsv4nhimx4kpjhabxa28gx1ih10l88gj"))))
+                "10h5mjgv4ibhispvr3s1k36a4aclx4dcvcc2knd4sg1xibw0dp4w"))))
     (build-system gnu-build-system)
     (inputs
      `(("glib" ,glib)
@@ -292,24 +306,46 @@ Japanese language input in most graphical applications.")
 (define-public librime
   (package
     (name "librime")
-    (version "1.3.2")
+    (version "1.6.1")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/rime/librime.git")
+             (url "https://github.com/rime/librime")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "06q10cv7a3i6d8l3sq79nasw3p1njvmjgh4jq2hqw9abcx351m1r"))))
+        (base32
+         "1avmy2yyag22cl2j8085n5czsk93sxv440pdb3a2diwcxwwmzm9v"))
+       (modules '((guix build utils)))
+       (snippet
+        '(begin
+           (delete-file-recursively "thirdparty/src")
+           (delete-file-recursively "thirdparty/bin")
+           (delete-file-recursively "thirdparty/include/X11")
+           #t))))
     (build-system cmake-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-source
+           (lambda _
+             (substitute* "CMakeLists.txt"
+               (("include_directories\\($\\{PROJECT_SOURCE_DIR\\}/thirdparty/include\\)") "")
+               (("link_directories\\($\\{PROJECT_SOURCE_DIR\\}/thirdparty/lib\\)") ""))
+             #t)))))
     (inputs
      `(("boost" ,boost)
+       ("capnproto" ,capnproto)
        ("glog" ,glog)
        ("leveldb" ,leveldb)
        ("marisa" ,marisa)
        ("opencc" ,opencc)
        ("yaml-cpp" ,yaml-cpp)))
+    (native-inputs
+     `(("googletest" ,googletest)
+       ("pkg-config" ,pkg-config)
+       ("xorgproto" ,xorgproto))) ; keysym.h
     (home-page "https://rime.im/")
     (synopsis "The core library of Rime Input Method Engine")
     (description "@dfn{librime} is the core library of Rime Input Method
@@ -323,292 +359,293 @@ traditional Chinese output.")
 (define-public rime-data
   (package
     (name "rime-data")
-    (version "0.38.20181029")
+    (version "0.38.20200623")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/rime/plum.git")
-             (commit "fb4f829da2007f2dbb37d60a79bc67c25ea16568")))
+             (url "https://github.com/rime/plum")
+             (commit "397d601dd22cfc857613973724724b8f44db9f9c")))
        (file-name "plum-checkout")
        (sha256
-        (base32 "1m1wiv9j5bay4saga58c7dj4h8gqivsbyp16y245ifvxvp9czj67"))))
+        (base32 "06ad5c4m7xsfr4if5ywshfj2aj5g5b5hwzh38dzccn7c1l2ibi0z"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                  ; no tests
+     `(#:modules ((ice-9 match)
+                  ,@%gnu-build-system-modules)
+       #:tests? #f                  ; no tests
        #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
                           "no_update=1")
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-source
            (lambda _
-             ;; Set .DEFAULT_GOAL to `all'.
-             ;; Don't build binary schemas. The output is not deterministic.
+             ;; Don't build binary Rime schema.  The binary Rime schema files
+             ;; are platform dependent and contains timestamp information.
+             ;; Thus they are not reproducible.
+
+             ;; Change `.DEFAULT_GOAL' to `all'.
              (substitute* "Makefile"
                (("^\\.DEFAULT_GOAL := preset")
                 ".DEFAULT_GOAL := all"))
+             ;; Disable git operations.
+             (substitute* "scripts/install-packages.sh"
+               ((".*update-package\\.sh.*") ""))
              #t))
-         ;; Add schema packages into "package/rime" directory.
-         (add-after 'unpack 'add-packages
+         ;; Copy Rime schemas into the "package/rime" directory.
+         (add-after 'unpack 'copy-rime-schemas
            (lambda* (#:key inputs #:allow-other-keys)
-             (let* ((dest-dir "package/rime"))
+             (let ((dest-dir "package/rime"))
                (mkdir-p dest-dir)
-               (for-each (lambda (pkg)
-                           (symlink (assoc-ref inputs pkg)
-                                    (string-append dest-dir "/" pkg)))
-                         '("array"
-                           "bopomofo"
-                           "cangjie"
-                           "combo-pinyin"
-                           "double-pinyin"
-                           "emoji"
-                           "essay"
-                           "ipa"
-                           "jyutping"
-                           "luna-pinyin"
-                           "middle-chinese"
-                           "pinyin-simp"
-                           "prelude"
-                           "quick"
-                           "scj"
-                           "soutzoe"
-                           "stenotype"
-                           "stroke"
-                           "terra-pinyin"
-                           "wubi"
-                           "wugniu")))
+               (for-each
+                (match-lambda
+                  ((name . path)
+                   (if (string-prefix? "rime-" name)
+                       (let ((schema (substring name (string-length "rime-"))))
+                         (symlink path (string-append dest-dir "/" schema))))))
+                inputs))
              #t))
          (delete 'configure))))
-    (native-inputs
-     `(("array"
+    (inputs
+     `(("rime-array"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-array.git")
-                 (commit "906e923902147584b0b0247028a782abbfbfd8a0")))
+                 (url "https://github.com/rime/rime-array")
+                 (commit "93cc99238f120606a076220ec4ddcad164f6396a")))
            (file-name "rime-array-checkout")
            (sha256
             (base32
-             "1alk6ghn4ji4kvp7lfm57bwm2gjh99i79r0w9naz6wkdim8idvb1"))))
-       ("bopomofo"
+             "06yxrv3x702751jvx46rfw3ix34jk7jh183rz6bllznzi7lxz7sz"))))
+       ("rime-bopomofo"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-bopomofo.git")
-                 (commit "8dc44ca1b6ef4e45b452e070b9da737f5da165e3")))
+                 (url "https://github.com/rime/rime-bopomofo")
+                 (commit "ed25098386f5efd3d70b08650f0d1b70c41c11a3")))
            (file-name "rime-bopomofo-checkout")
            (sha256
             (base32
-             "16k6wfhcrw3a77rmbrp21ca0gmsmb3f68s193c1cfwr8i68k46nf"))))
-       ("cangjie"
+             "1ip1pbfb1hadf2mcymr5939iagf25ywfl67d9198jahzyr6rdyvc"))))
+       ("rime-cangjie"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-cangjie.git")
-                 (commit "ab085e90856b3399b374dc3c8b4cb40d11f307a8")))
+                 (url "https://github.com/rime/rime-cangjie")
+                 (commit "5fd8ce6f64039e505ca02655a621f2e830b97c19")))
            (file-name "rime-cangjie-checkout")
            (sha256
             (base32
-             "11fgj0rbv9nyzfijwm2l8pm8fznhif4h27ndrrcaaylkp7p5zsx2"))))
-       ("combo-pinyin"
+             "1gf6r0q593ixar6v0jyvs56cik2gjp7pf9v799rfd2yydyia3bfg"))))
+       ("rime-cantonese"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-combo-pinyin.git")
-                 (commit "f1bae63f20504f2b8113c5cbdf2700e858aa91eb")))
+                 (url "https://github.com/rime/rime-cantonese")
+                 (commit "e06fe8e79d7d64db2f2b6339aabc004d8cbc1f67")))
+           (file-name "rime-cantonese-checkout")
+           (sha256
+            (base32
+             "0j6kbhdfj7dx812yzykndzbk53s2v1rsaa2jlyma03hz7qlnnl0s"))))
+       ("rime-combo-pinyin"
+        ,(origin
+           (method git-fetch)
+           (uri (git-reference
+                 (url "https://github.com/rime/rime-combo-pinyin")
+                 (commit "67b29cdc786928ea46b43a9c660dee3db8f1adff")))
            (file-name "rime-combo-pinyin-checkout")
            (sha256
             (base32
-             "1l1079akwm1hw4kkn0q6x9fpylnl2ka6z2fn7lmdpfpsr0xgn0n7"))))
-       ("double-pinyin"
+             "1v6ax51xll2aizbz1xzjyk6p3lmq8cyzbxkrwcffa723zaj0zz4l"))))
+       ("rime-double-pinyin"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-double-pinyin.git")
-                 (commit "2101a5cd40e511ec38835769aa66d2dddf059c2e")))
+                 (url "https://github.com/rime/rime-double-pinyin")
+                 (commit "69bf85d4dfe8bac139c36abbd68d530b8b6622ea")))
            (file-name "rime-double-pinyin-checkout")
            (sha256
             (base32
-             "19hh2qm0njbfk2js678hfm2hw9b796s43vs11yy3m1v9m0gk2vi7"))))
-       ("emoji"
+             "093wif5avvvw45fqbwj5wkbxrychy4pagl4mwsmbrayc8jkp69ak"))))
+       ("rime-emoji"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-emoji.git")
-                 (commit "6e6611b315f03ee4c33f958f9dbe960b13a0ed19")))
+                 (url "https://github.com/rime/rime-emoji")
+                 (commit "c99d34e4a837349e4679a110bb4b94f71fe015ae")))
            (file-name "rime-emoji-checkout")
            (sha256
             (base32
-             "1brfs3214w36j3345di9ygp468hbvbqdqpkjxxs1dbp437rayhyy"))))
-       ("essay"
+             "1wiwlxjjml9xfgg7z1wzaf4b1bsg81dkwvsfff2b61fwxq61zkgw"))))
+       ("rime-essay"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-essay.git")
-                 (commit "5e5c7a0ef41c9b030abdad81a9df07b56b1661e9")))
+                 (url "https://github.com/rime/rime-essay")
+                 (commit "88055afa3752e4582fa887765d962a30e02bb1fa")))
            (file-name "rime-essay-checkout")
            (sha256
             (base32
-             "0ana9is0zhh79m4gjshvmaxbrg3jiqysydx5bpm151i7i6vw5y1i"))))
-       ("ipa"
+             "0ap7xqv6v0x6mdkw2cv93cbr6qhpla3803z04522wb8l9hr7iryg"))))
+       ("rime-ipa"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-ipa.git")
-                 (commit "02a9e2c181921a2e95e1a81f88188c41132755c3")))
+                 (url "https://github.com/rime/rime-ipa")
+                 (commit "22b71710e029bcb412e9197192a638ab11bc2abf")))
            (file-name "rime-ipa-checkout")
            (sha256
             (base32
-             "1szrxgvqlgmxapj2aflw2cvbv0p6pl0sw0gyxa13dvdhhf7s9rvr"))))
-       ("jyutping"
+             "0zdk4f9qkfj3q5hmjnairj1lv6f6y27mic12k886n6sxywwbwr2k"))))
+       ("rime-jyutping"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-jyutping.git")
-                 (commit "1402ec3d6cc0973f952fe3f9ef531294e4ffe9e0")))
+                 (url "https://github.com/rime/rime-jyutping")
+                 (commit "6fe0d727b3178feabd0f01e6cd82599202764735")))
            (file-name "rime-jyutping-checkout")
            (sha256
             (base32
-             "17g03dy4gw6vyc9da1wjn3iy9hx64dfnwiwsfc7bkzan22x2m4dv"))))
-       ("luna-pinyin"
+             "0wz6d3pmi72ysh2c0nml3rsz9hd2vazsyhnz34gq26yf4j85phfs"))))
+       ("rime-luna-pinyin"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-luna-pinyin.git")
-                 (commit "3b05132576f5c347ff8a70857d2dae080936ac3b")))
+                 (url "https://github.com/rime/rime-luna-pinyin")
+                 (commit "f1268e192ca88b9526467ce04ac3e47c837891ad")))
            (file-name "rime-luna-pinyin-checkout")
            (sha256
             (base32
-             "0kgnpxjn10dm2d9718r12rdjlwqd2s2h84jvkhxhh5v0dkv1anl2"))))
-       ("middle-chinese"
+             "0nxnjp1ybcrsan1mxnzwbkfhwl99kza6i9k1s7m9wzmhv7x7zahg"))))
+       ("rime-middle-chinese"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-middle-chinese.git")
-                 (commit "9ba8d70330654b9a730f882d35cfad7dbeddfd75")))
+                 (url "https://github.com/rime/rime-middle-chinese")
+                 (commit "ed6d44f8d0bedf6e0c1c3183a270f8f01a211a40")))
            (file-name "rime-middle-chinese-checkout")
            (sha256
             (base32
-             "0hwg5zby5kphh0bcfay8mfxwr5bwqhamiw3cmmmf7kp9fbns5s23"))))
-       ("pinyin-simp"
+             "09mql88lsrxa99pyllby5z22kaiwwa037ha8gwaxjnnlsjgvz7zx"))))
+       ("rime-pinyin-simp"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-pinyin-simp.git")
-                 (commit "74357ffd62c05fb60edf6eab5b86bc8c8c1907d0")))
+                 (url "https://github.com/rime/rime-pinyin-simp")
+                 (commit "b73df7fc0994912ce785462b3be569ae81258ac2")))
            (file-name "rime-pinyin-simp-checkout")
            (sha256
             (base32
-             "1paw3c7pv5bl54abnp9pidfxrkchdacyxy5m9zb311p5sgm7fhxh"))))
-       ("prelude"
+             "1m9hchnj1xf5s5185qm66ja0g1324drc98b2jjhnqgcp47bwz9fx"))))
+       ("rime-prelude"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-prelude.git")
-                 (commit "33040568c3ddb2ee6340c9b669494317db21b77c")))
+                 (url "https://github.com/rime/rime-prelude")
+                 (commit "8a52b4f86a59f3eb602f9a4cf6a680a67c15df8c")))
            (file-name "rime-prelude-checkout")
            (sha256
             (base32
-             "1gwcasyyg6f0ib6s4qsrrjcqr1lcs7j3xqxl65rznsw44nhnbwwq"))))
-       ("quick"
+             "039fr3996vfxzn2milaq1f5fw08f6zgjsxsql6cfhsc5b55fidm7"))))
+       ("rime-quick"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-quick.git")
-                 (commit "910a97d403ad8e72f322488da146da79c19d623f")))
+                 (url "https://github.com/rime/rime-quick")
+                 (commit "3fe5911ba608cb2df1b6301b76ad1573bd482a76")))
            (file-name "rime-quick-checkout")
            (sha256
             (base32
-             "0yrq3gbfmm29xlr52rmxc41mqfrb0295q7sdhbc3ax71677mpr0y"))))
-       ("scj"
+             "08bh87ym5qvw55lyw20l3m7jd4c2z5rvil8h5q8790r7z6j6ijy9"))))
+       ("rime-scj"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-scj.git")
-                 (commit "e0eae889f4376d2a434ac3b38523e0da7400db68")))
+                 (url "https://github.com/rime/rime-scj")
+                 (commit "cab5a0858765eff0553dd685a2d61d5536e9149c")))
            (file-name "rime-scj-checkout")
            (sha256
             (base32
-             "1whnv9zs349kvy0zi7dnmpqwil8i6gqwrzvhy3qdrjzy58y6gwxn"))))
-       ("soutzoe"
+             "0ard2bjp4896a8dimmcwyjwgmp9kl4rz92yc92jnd3y4rgwl6fvk"))))
+       ("rime-soutzoe"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-soutzoe.git")
-                 (commit "e47841a8ad6341731c41cdb814b7a25c837603c4")))
+                 (url "https://github.com/rime/rime-soutzoe")
+                 (commit "beeaeca72d8e17dfd1e9af58680439e9012987dc")))
            (file-name "rime-soutzoe-checkout")
            (sha256
             (base32
-             "1rgpmkxa72jy6gyy44fn8azpk3amk9s9lrdf7za03nv95d0fvm0p"))))
-       ("stenotype"
+             "0jyqx0q9s0qxn168l5n8zav8jcl2g5ppr7pa8jm1vwrllf20slcc"))))
+       ("rime-stenotype"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-stenotype.git")
-                 (commit "d4ff379314fd95283853d1734854979cf3cbd287")))
+                 (url "https://github.com/rime/rime-stenotype")
+                 (commit "f3e9189d5ce33c55d3936cc58e39d0c88b3f0c88")))
            (file-name "rime-stenotype-checkout")
            (sha256
             (base32
-             "1kckpi4l4884hvydr3d6vid3v7rsc1app29kmk7v8jf8vn16afhl"))))
-       ("stroke"
+             "0dl6px7lrh3xa87knjzwzdcwjj1k1dg4l72q7lb48an4s9f1cy5d"))))
+       ("rime-stroke"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-stroke.git")
-                 (commit "cfd29c675c46cf70b7a7f0a3836a913059316a0a")))
+                 (url "https://github.com/rime/rime-stroke")
+                 (commit "ea8576d1accd6fda339e96b415caadb56e2a07d1")))
            (file-name "rime-stroke-checkout")
            (sha256
             (base32
-             "135is9c1p4lm98fd9l1gxyflkm69cv5an129ka7sk614bq84m08d"))))
-       ("terra-pinyin"
+             "07h6nq9867hjrd2v3h1pnr940sdrw4mqrzj43siz1rzjxz3s904r"))))
+       ("rime-terra-pinyin"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-terra-pinyin.git")
-                 (commit "15b5c73a796571cd6f9ef6c89f96656cb9df86f9")))
+                 (url "https://github.com/rime/rime-terra-pinyin")
+                 (commit "492aaf914f9de37cc9d26b846dc693116de70ae8")))
            (file-name "rime-terra-pinyin-checkout")
            (sha256
             (base32
-             "1xsd84h1zw417h5hr4dbgyk5009zi7q2p9774w3ccr5sxgc3i3cm"))))
-       ("wubi"
+             "1l4l2w42mc3sf7jwbadx95gzrsq11ld9f6yj2hwaq9accainw3bf"))))
+       ("rime-wubi"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-wubi.git")
-                 (commit "d44403728a0b1cd8b47cb1f81b83f58e5f790b74")))
+                 (url "https://github.com/rime/rime-wubi")
+                 (commit "dd052ee158a38cb791755318b1aef9b4a3ed0316")))
            (file-name "rime-wubi-checkout")
            (sha256
             (base32
-             "0ld31bdn94lncxd1ka44w4sbl03skh08mc927dhdmwq5bpvrgn36"))))
-       ("wugniu"
+             "00xzv3sbwqh2jz4i7s315h7rw17qa2dgj7kflyy3blxk0s2cqiqa"))))
+       ("rime-wugniu"
         ,(origin
            (method git-fetch)
            (uri (git-reference
-                 (url "https://github.com/rime/rime-wugniu.git")
-                 (commit "65bcc354ada3839591d7546a64c71dbdd0592b02")))
+                 (url "https://github.com/rime/rime-wugniu")
+                 (commit "abd1ee98efbf170258fcf43875c21a4259e00b61")))
            (file-name "rime-wugniu-checkout")
            (sha256
             (base32
-             "0g31awp40s778sp5c290x40s8np86n8aw011s17sslxrqhhb0bkx"))))))
+             "0qn54d3cclny106ixdw08r5n6wn52ffs1hgrma3k0j4pv0kr9nlq"))))))
     (home-page "https://rime.im/")
     (synopsis "Schema data of Rime Input Method Engine")
     (description "@dfn{rime-data} provides the schema data of Rime Input
 Method Engine.")
-    (license lgpl3+)))
+    (license lgpl3)))
 
 (define-public ibus-rime
   (package
     (name "ibus-rime")
-    (version "1.3.0")
+    (version "1.4.0")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
-             (url "https://github.com/rime/ibus-rime.git")
+             (url "https://github.com/rime/ibus-rime")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "1nqi7ymv34a9kx24say3xj98lkrs9nkpv1n2ijb91wdz3cr012ly"))))
+        (base32 "12y6jdz1amhgrnqa7zjim63dfsz6zyxyahbirfan37wmcfp6gp1d"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f                      ; no tests
@@ -634,6 +671,13 @@ Method Engine.")
                                (assoc-ref inputs "rime-data")
                                "/share/rime-data\"\n")))
              #t))
+         (add-after 'unpack 'fix-file-names
+           (lambda* (#:key outputs #:allow-other-keys)
+             ;; IBus uses the component file rime.xml to start the Rime
+             ;; engine.  It must be patched with appropriate file names.
+             (substitute* "rime.xml"
+               (("/usr") (assoc-ref outputs "out")))
+             #t))
          (delete 'configure))))
     (inputs
      `(("gdk-pixbuf" ,gdk-pixbuf)
@@ -643,7 +687,7 @@ Method Engine.")
        ("librime" ,librime)
        ("rime-data" ,rime-data)))
     (native-inputs
-     `(("cmake" ,cmake)
+     `(("cmake" ,cmake-minimal)
        ("pkg-config" ,pkg-config)))
     (home-page "https://rime.im/")
     (synopsis "Rime Input Method Engine for IBus")
@@ -653,4 +697,68 @@ various input schemas including glyph-based input methods, romanization-based
 input methods as well as those for Chinese dialects.  It has the ability to
 compose phrases and sentences intelligently and provide very accurate
 traditional Chinese output.")
-    (license gpl3+)))
+    (license gpl3)))
+
+(define-public libhangul
+  (package
+    (name "libhangul")
+    (version "0.1.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://kldp.net/hangul/release/"
+                           "3442-libhangul-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0ni9b0v70wkm0116na7ghv03pgxsfpfszhgyj3hld3bxamfal1ar"))))
+    (build-system gnu-build-system)
+    (home-page "https://github.com/libhangul/libhangul")
+    (synopsis "Library to support hangul input method logic")
+    (description
+     "This package provides a library to support hangul input method logic,
+hanja dictionary and small hangul character classification.")
+    (license lgpl2.1+)))
+
+(define-public ibus-libhangul
+  (package
+    (name "ibus-libhangul")
+    (version "1.5.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/libhangul/ibus-hangul/"
+                           "releases/download/" version
+                           "/ibus-hangul-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1400ba2p34vr9q285lqvjm73f6m677cgfdymmjpiwyrjgbbiqrjy"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-after 'install 'wrap
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (wrap-program (string-append (assoc-ref outputs "out")
+                                          "/libexec/ibus-setup-hangul")
+               `("PYTHONPATH" ":" prefix (,(getenv "PYTHONPATH")))
+               `("LD_LIBRARY_PATH" ":" prefix
+                 (,(string-append (assoc-ref inputs "libhangul") "/lib")))
+               `("GI_TYPELIB_PATH" ":" prefix
+                 (,(getenv "GI_TYPELIB_PATH"))))
+             #t)))))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("gettext" ,gettext-minimal)
+       ("glib:bin" ,glib "bin")))
+    (inputs
+     `(("ibus" ,ibus)
+       ("glib" ,glib)
+       ("python-pygobject" ,python-pygobject)
+       ("gtk+" ,gtk+)
+       ("libhangul" ,libhangul)
+       ("python" ,python)))
+    (home-page "https://github.com/libhangul/ibus-hangul")
+    (synopsis "Hangul engine for IBus")
+    (description
+     "ibus-hangul is a Korean input method engine for IBus.")
+    (license gpl2+)))