gnu: kdenlive: Add missing dependencies.
[jackhill/guix/guix.git] / gnu / packages / slang.scm
index 953291b..404a453 100644 (file)
@@ -2,6 +2,7 @@
 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public slang
   (package
     (name "slang")
-    (version "2.3.0")
+    (version "2.3.2")
     (source (origin
               (method url-fetch)
-              (uri (string-append
-                    "http://www.jedsoft.org/releases/slang/slang-"
-                    version
-                    ".tar.gz"))
+              (uri (string-append "http://www.jedsoft.org/releases/slang/slang-"
+                                  version ".tar.bz2"))
               (sha256
                (base32
-                "0aqd2cjabj6nhd4r3dc4vhqif2bf3dmqnrn2gj0xm4gqyfd177jy"))
+                "06p379fqn6w38rdpqi98irxi2bf4llb0rja3dlgkqz7nqh7kp7pw"))
               (modules '((guix build utils)))
               (snippet
                '(begin
                   (substitute* "src/Makefile.in"
                     (("/bin/ln") "ln"))
-                  (substitute* "configure"
-                    (("-ltermcap") ""))))))
+                  #t))))
     (build-system gnu-build-system)
     (arguments
      '(#:parallel-tests? #f
-       #:parallel-build? #f)) ; there's at least one race
+       #:parallel-build? #f  ; there's at least one race
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'configure 'substitute-before-config
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((ncurses (assoc-ref inputs "ncurses")))
+               (substitute* "configure"
+                 (("MISC_TERMINFO_DIRS=\"\"")
+                  (string-append "MISC_TERMINFO_DIRS="
+                                 "\"" ncurses "/share/terminfo" "\"")))
+               #t))))))
     (inputs
      `(("readline" ,readline)
        ("zlib" ,zlib)
        ("libpng" ,libpng)
        ("pcre" ,pcre)
        ("ncurses" ,ncurses)))
-    (home-page "http://www.jedsoft.org/slang/")
+    (home-page "https://www.jedsoft.org/slang/")
     (synopsis "Library for interactive applications and extensibility")
     (description
      "S-Lang is a multi-platform programmer's library designed to allow a
@@ -79,14 +87,14 @@ slsh, which is part of the S-Lang distribution.")
 (define-public newt
   (package
     (name "newt")
-    (version "0.52.18")
+    (version "0.52.21")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://pagure.io/releases/"
-                                  name "/" name "-" version ".tar.gz"))
+              (uri (string-append "https://pagure.io/releases/newt/"
+                                  "newt-" version ".tar.gz"))
               (sha256
                (base32
-                "07n9f2mqsjfj35wx5ldhvl9sqcjqpcl0g4fdd9mawmny9rihw6vp"))))
+                "0cdvbancr7y4nrj8257y5n45hmhizr8isynagy4fpsnpammv8pi6"))))
     (build-system gnu-build-system)
     (outputs '("out" "python"))
     (inputs
@@ -100,8 +108,9 @@ slsh, which is part of the S-Lang distribution.")
        ;; Set the correct RUNPATH in binaries.
        (list (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
        #:make-flags
-       ;; configure does not allow us to override this variable from the
-       ;; command-line.  Fortunately, the Makefile does, so provide it here.
+       ;; configure uses a hard-coded search of /usr/include/python* to set
+       ;; this variable, and does not allow us to override it from the
+       ;; command line.  Fortunately, the Makefile does, so provide it here.
        (list (string-append "PYTHONVERS=python"
                             ,(version-major+minor (package-version python))))
        #:phases