gnu: facter: Update to 4.0.33.
[jackhill/guix/guix.git] / gnu / packages / texinfo.scm
index 04f63da..dea26a6 100644 (file)
@@ -6,6 +6,8 @@
 ;;; Copyright © 2019 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
+;;; Copyright © 2020 Jan (janneke) Nieuwenhuizen <janneke@gnu.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
                     "env "))
                  #t))))
          '()))
-    (inputs `(("ncurses" ,ncurses)))
+    (inputs `(("ncurses" ,ncurses)
+              ;; TODO: remove `if' in the next rebuild cycle.
+              ,@(if (%current-target-system)
+                    `(("perl" ,perl))
+                    '())))
     ;; When cross-compiling, texinfo will build some of its own binaries with
     ;; the native compiler. This means ncurses is needed both in both inputs
     ;; and native-inputs.
@@ -228,6 +234,18 @@ Texi2HTML.")
     ;; Files in /lib under lgpl2.1+ and x11
     (license gpl2+)))
 
+(define-public texi2html-1.82
+  (package
+    (inherit texi2html)
+    (version "1.82")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://savannah/texi2html/"
+                           "texi2html-" version ".tar.bz2"))
+       (sha256
+        (base32 "1wdli2szkgm3l0vx8rf6lylw0b0m47dlz9iy004n928nqkzix76n"))))))
+
 (define-public pinfo
   (package
     (name "pinfo")
@@ -235,7 +253,7 @@ Texi2HTML.")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                    (url "https://github.com/baszoetekouw/pinfo.git")
+                    (url "https://github.com/baszoetekouw/pinfo")
                     (commit (string-append "v" version))))
               (file-name (git-file-name name version))
               (sha256
@@ -264,7 +282,7 @@ Texi2HTML.")
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
-       ("gettext" ,gnu-gettext)
+       ("gettext" ,gettext-minimal)
        ("libtool" ,libtool)
        ("texinfo" ,texinfo)))
     (home-page "https://github.com/baszoetekouw/pinfo")
@@ -273,6 +291,6 @@ Texi2HTML.")
      "Pinfo is an Info file viewer.  Pinfo is similar in use to the Lynx web
 browser.  You just move across info nodes, and select links, follow them, etc.
 It supports many colors.  Pinfo also supports viewing of manual pages -- they
-are colorized like in the midnight commander's viewer, and additionaly they
+are colorized like in the midnight commander's viewer, and additionally they
 are hypertextualized.")
     (license gpl2+)))