system: 'hosts-file' is now a file-like object.
[jackhill/guix/guix.git] / gnu / packages / tor.scm
index a756ebd..0f19d9f 100644 (file)
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public tor
   (package
     (name "tor")
-    (version "0.2.4.23")
+    (version "0.2.5.12")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://www.torproject.org/dist/tor-"
                                  version ".tar.gz"))
              (sha256
               (base32
-               "0a8l6d82hk4wbn7nlphd3c1maxhgdli8338wbg5r9dk6zcy7k8q5"))))
+               "0j9byw3i2b7ji88vsqwmsxxg2nlxwkk45k5qbc1y7hdlzvzxl3sm"))))
     (build-system gnu-build-system)
     (inputs
      `(("zlib" ,zlib)
     ;; TODO: Recommend `torsocks' since `torify' needs it.
 
     (home-page "http://www.torproject.org/")
-    (synopsis "An anonymous network router to improve privacy on the Internet")
+    (synopsis "Anonymous network router to improve privacy on the Internet")
     (description
      "Tor protects you by bouncing your communications around a distributed
 network of relays run by volunteers all around the world: it prevents
 somebody watching your Internet connection from learning what sites you
 visit, and it prevents the sites you visit from learning your physical
-location. Tor works with many of your existing applications, including
+location.  Tor works with many of your existing applications, including
 web browsers, instant messaging clients, remote login, and other
 applications based on the TCP protocol.")
     (license bsd-3)))
@@ -99,8 +99,8 @@ rejects UDP traffic from the application you're using.")
        #:configure-flags (list (string-append "--sysconfdir="
                                               (assoc-ref %outputs "out")
                                               "/etc/privoxy"))
-       #:phases (alist-cons-before
-                 'configure 'autoconf
+       #:phases (alist-cons-after
+                 'unpack 'autoconf
                  (lambda _
                    ;; Unfortunately, this is not a tarball produced by
                    ;; "make dist".