gnu: Add datafly.
[jackhill/guix/guix.git] / gnu / packages / pumpio.scm
index 4a6375f..b874152 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2015 David Thompson <davet@gnu.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages aspell)
-  #:use-module (gnu packages kde)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages web))
 
 (define-public pumpa
   (package
     (name "pumpa")
-    (version "0.9")
+    (version "0.9.3")
     (source (origin
               (method git-fetch) ; no source tarballs
               (uri (git-reference
-                    (url "https://gitorious.org/pumpa/pumpa.git")
+                    (url "git://pumpa.branchable.com/")
                     (commit (string-append "v" version))))
               (sha256
                (base32
-                "0v55xq17wnc9mvpmrm5r3rjrsg9npnjv1lznbz8ppk77ba8pwimy"))))
+                "14072vis539zjgryjr5a77j2cprxii5znyg3p01qbb11lijk9nj7"))
+              (file-name (string-append name "-" version "-checkout"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:phases (alist-replace
-                 'configure
-                 (lambda* (#:key inputs outputs #:allow-other-keys)
-                   ;; Fix dependency tests.
-                   (substitute* "pumpa.pro"
-                     (("/usr/include/tidy\\.h")
-                      (string-append (assoc-ref inputs "tidy")
-                                     "/include/tidy.h"))
-                     (("/usr/include/aspell.h")
-                      (string-append (assoc-ref inputs "aspell")
-                                     "/include/aspell.h")))
-                   ;; Run qmake with proper installation prefix.
-                   (let ((prefix (string-append "PREFIX="
-                                                (assoc-ref outputs "out"))))
-                     (zero? (system* "qmake" prefix))))
-                 %standard-phases)))
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             ;; Fix dependency tests.
+             (substitute* "pumpa.pro"
+               (("/usr/include/tidy\\.h")
+                (string-append (assoc-ref inputs "tidy")
+                               "/include/tidy.h"))
+               (("/usr/include/aspell.h")
+                (string-append (assoc-ref inputs "aspell")
+                               "/include/aspell.h")))
+             ;; Run qmake with proper installation prefix.
+             (let ((prefix (string-append "PREFIX="
+                                          (assoc-ref outputs "out"))))
+               (invoke "qmake" prefix))
+             #t)))))
     (inputs
      `(("aspell" ,aspell)
-       ("qt" ,qt)
-       ("qjson" ,qjson)
+       ("qtbase" ,qtbase)
        ("tidy" ,tidy)))
     (synopsis "Qt-based pump.io client")
     (description "Pumpa is a simple pump.io client written in C++ and Qt.")