gnu: guix: Update snapshot.
[jackhill/guix/guix.git] / gnu / packages / valgrind.scm
index 82e3b80..5e5a1d9 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public valgrind
   (package
     (name "valgrind")
-    (version "3.10.0")
+    (version "3.10.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "http://valgrind.org/downloads/valgrind-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "1jgd42vsx0bcblp91bd61hd5wpy0gghh09wxgm65m666vy17y103"))))
+               "15xrzhfnwwn7n1sfbkwvdbvs6zk0zx718n6zd5i1nrnvdp13s9gs"))
+             (patches (list (search-patch "valgrind-glibc-2.21.patch")))))
     (build-system gnu-build-system)
     (arguments
      '(#:phases (alist-cons-after
     (description
      "Valgrind is an instrumentation framework for building dynamic analysis
 tools.  There are Valgrind tools that can automatically detect many memory
-management and threading bugs, and profile your programs in detail. You can
+management and threading bugs, and profile your programs in detail.  You can
 also use Valgrind to build new tools.")
-    (license gpl2+)))
+    (license gpl2+)
+
+    ;; Building VEX on mips64el-linux fails with "opcode not supported on this
+    ;; processor: mips3".
+    (supported-systems (delete "mips64el-linux" %supported-systems))))