gnu: rust-md5-0.6: Don't hide package.
[jackhill/guix/guix.git] / gnu / packages / bioconductor.scm
index f506bb4..e2b4f6e 100644 (file)
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2016, 2017, 2018 Roel Janssen <roel@gnu.org>
 ;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Simon Tournier <zimon.toutoune@gmail.com>
 \f
 ;;; Annotations
 
+(define-public r-reactome-db
+  (package
+    (name "r-reactome-db")
+    (version "1.70.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "reactome.db" version 'annotation))
+       (sha256
+        (base32
+         "05wc4fp0faq6h3kq5rwafnips043as31yq11mrjngfxvf5i10srg"))))
+    (properties `((upstream-name . "reactome.db")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)))
+    (home-page "https://bioconductor.org/packages/reactome.db/")
+    (synopsis "Annotation maps for reactome")
+    (description
+     "This package provides a set of annotation maps for the REACTOME
+database, assembled using data from REACTOME.")
+    (license license:cc-by4.0)))
+
 (define-public r-bsgenome-celegans-ucsc-ce6
   (package
     (name "r-bsgenome-celegans-ucsc-ce6")
@@ -275,7 +297,7 @@ provided by UCSC (mm9, July 2007) and stored in Biostrings objects.")
      `(("r-bsgenome" ,r-bsgenome)
        ("r-bsgenome-mmusculus-ucsc-mm9"
         ,r-bsgenome-mmusculus-ucsc-mm9)))
-    (home-page "http://bioconductor.org/packages/BSgenome.Mmusculus.UCSC.mm9.masked/")
+    (home-page "https://bioconductor.org/packages/BSgenome.Mmusculus.UCSC.mm9.masked/")
     (synopsis "Full masked genome sequences for Mouse")
     (description
      "This package provides full genome sequences for Mus musculus (Mouse) as
@@ -878,6 +900,39 @@ examples' of Affymetrix data, unlike the artificial examples included in the
 package @code{affy}.")
     (license license:gpl2+)))
 
+(define-public r-curatedtcgadata
+  (package
+    (name "r-curatedtcgadata")
+    (version "1.8.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "curatedTCGAData" version 'experiment))
+       (sha256
+        (base32
+         "02y6cgihmsl9b4a9mmcdjjgjp06lpz04biyvxd3n5lk5gnqd9r3y"))))
+    (properties
+     `((upstream-name . "curatedTCGAData")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationhub" ,r-annotationhub)
+       ("r-experimenthub" ,r-experimenthub)
+       ("r-hdf5array" ,r-hdf5array)
+       ("r-multiassayexperiment" ,r-multiassayexperiment)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-summarizedexperiment" ,r-summarizedexperiment)))
+    (home-page "https://bioconductor.org/packages/curatedTCGAData/")
+    (synopsis "Curated data from The Cancer Genome Atlas")
+    (description
+     "This package provides publicly available data from The Cancer Genome
+Atlas (TCGA) as @code{MultiAssayExperiment} objects.
+@code{MultiAssayExperiment} integrates multiple assays (e.g., RNA-seq, copy
+number, mutation, microRNA, protein, and others) with clinical / pathological
+data.  It also links assay barcodes with patient identifiers, enabling
+harmonized subsetting of rows (features) and columns (patients / samples)
+across the entire multi-'omics experiment.")
+    (license license:artistic2.0)))
+
 \f
 ;;; Packages
 
@@ -998,14 +1053,14 @@ problems in CEL-level data to help evaluate performance of quality metrics.")
 (define-public r-affycoretools
   (package
     (name "r-affycoretools")
-    (version "1.58.2")
+    (version "1.58.4")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "affycoretools" version))
        (sha256
         (base32
-         "0cgy9phwdk4x9lr11xh6zs7v8r5xq959fmsmzwrpnd50dr7hzkvd"))))
+         "1p283ysib04qzaayxmrpsmk5bq0jdq2rlky180jrlskpyg6risfw"))))
     (properties `((upstream-name . "affycoretools")))
     (build-system r-build-system)
     (propagated-inputs
@@ -1016,6 +1071,7 @@ problems in CEL-level data to help evaluate performance of quality metrics.")
        ("r-dbi" ,r-dbi)
        ("r-edger" ,r-edger)
        ("r-gcrma" ,r-gcrma)
+       ("r-glimma" ,r-glimma)
        ("r-ggplot2" ,r-ggplot2)
        ("r-gostats" ,r-gostats)
        ("r-gplots" ,r-gplots)
@@ -1110,14 +1166,14 @@ the Human Protein Atlas project.")
 (define-public r-regioner
   (package
     (name "r-regioner")
-    (version "1.18.0")
+    (version "1.18.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "regioneR" version))
        (sha256
         (base32
-         "0m073hrqp62zpd2blnqm5ka539hcilir05m8av14vdhzhjzp13ya"))))
+         "0if7r6njz3ahm545383z5mzmzw8fdvw80a9lfz160j5pcgpx2dq9"))))
     (properties `((upstream-name . "regioneR")))
     (build-system r-build-system)
     (propagated-inputs
@@ -1344,7 +1400,7 @@ problems in genomics, brain imaging, astrophysics, and data mining.")
        ("r-s4vectors" ,r-s4vectors)
        ("r-summarizedexperiment" ,r-summarizedexperiment)
        ("r-systempiper" ,r-systempiper)))
-    (home-page "http://bioconductor.org/packages/DiffBind")
+    (home-page "https://bioconductor.org/packages/DiffBind")
     (synopsis "Differential binding analysis of ChIP-Seq peak data")
     (description
      "This package computes differentially bound sites from multiple
@@ -1373,7 +1429,7 @@ occupancy (overlap) analysis and plotting functions.")
        ("r-rsamtools" ,r-rsamtools)
        ("r-genomicalignments" ,r-genomicalignments)
        ("r-rtracklayer" ,r-rtracklayer)))
-    (home-page "http://bioconductor.org/packages/RIPSeeker")
+    (home-page "https://bioconductor.org/packages/RIPSeeker")
     (synopsis
      "Identifying protein-associated transcripts from RIP-seq experiments")
     (description
@@ -1402,7 +1458,7 @@ processing to visualization and annotation.")
        ("r-biocgenerics" ,r-biocgenerics)
        ("r-biobase" ,r-biobase)
        ("r-mass" ,r-mass)))
-    (home-page "http://bioconductor.org/packages/multtest")
+    (home-page "https://bioconductor.org/packages/multtest")
     (synopsis "Resampling-based multiple hypothesis testing")
     (description
      "This package can do non-parametric bootstrap and permutation
@@ -1513,7 +1569,7 @@ determining dependencies between variables, code improvement suggestions.")
        ("r-seqinr" ,r-seqinr)
        ("r-summarizedexperiment" ,r-summarizedexperiment)
        ("r-venndiagram" ,r-venndiagram)))
-    (home-page "http://bioconductor.org/packages/ChIPpeakAnno")
+    (home-page "https://bioconductor.org/packages/ChIPpeakAnno")
     (synopsis "Peaks annotation from ChIP-seq and ChIP-chip experiments")
     (description
      "The package includes functions to retrieve the sequences around the peak,
@@ -1538,7 +1594,7 @@ enrichedGO (addGeneIDs).")
     (build-system r-build-system)
     (propagated-inputs
      `(("r-limma" ,r-limma)))
-    (home-page "http://bioconductor.org/packages/marray")
+    (home-page "https://bioconductor.org/packages/marray")
     (synopsis "Exploratory analysis for two-color spotted microarray data")
     (description "This package contains class definitions for two-color spotted
 microarray data.  It also includes functions for data input, diagnostic plots,
@@ -1559,7 +1615,7 @@ normalization and quality checking.")
    (propagated-inputs
     `(("r-biobase" ,r-biobase)
       ("r-marray" ,r-marray)))
-   (home-page "http://bioconductor.org/packages/CGHbase")
+   (home-page "https://bioconductor.org/packages/CGHbase")
    (synopsis "Base functions and classes for arrayCGH data analysis")
    (description "This package contains functions and classes that are needed by
 the @code{arrayCGH} packages.")
@@ -1582,7 +1638,7 @@ the @code{arrayCGH} packages.")
       ("r-impute" ,r-impute)
       ("r-dnacopy" ,r-dnacopy)
       ("r-snowfall" ,r-snowfall)))
-   (home-page "http://bioconductor.org/packages/CGHcall")
+   (home-page "https://bioconductor.org/packages/CGHcall")
    (synopsis "Base functions and classes for arrayCGH data analysis")
    (description "This package contains functions and classes that are needed by
 @code{arrayCGH} packages.")
@@ -1611,7 +1667,7 @@ the @code{arrayCGH} packages.")
        ("r-matrixstats" ,r-matrixstats)
        ("r-r-utils" ,r-r-utils)
        ("r-rsamtools" ,r-rsamtools)))
-    (home-page "http://bioconductor.org/packages/QDNAseq")
+    (home-page "https://bioconductor.org/packages/QDNAseq")
     (synopsis "Quantitative DNA sequencing for chromosomal aberrations")
     (description "The genome is divided into non-overlapping fixed-sized bins,
 number of sequence reads in each counted, adjusted with a simultaneous
@@ -1944,14 +2000,14 @@ genes or proteins in these datasets.")
 (define-public r-inspect
   (package
     (name "r-inspect")
-    (version "1.16.0")
+    (version "1.16.2")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "INSPEcT" version))
        (sha256
         (base32
-         "043066zygf2y2jp6dvfwl56hkzcdvkmymhjx3gh4mhi48l71zqv9"))))
+         "1g8la7k4pnyr2hvk4yjd1bwvjy6nqbbb0fwxrrh2ifgqf4h21x2p"))))
     (properties `((upstream-name . "INSPEcT")))
     (build-system r-build-system)
     (propagated-inputs
@@ -1960,6 +2016,7 @@ genes or proteins in these datasets.")
        ("r-biocparallel" ,r-biocparallel)
        ("r-deseq2" ,r-deseq2)
        ("r-desolve" ,r-desolve)
+       ("r-gdata" ,r-gdata)
        ("r-genomeinfodb" ,r-genomeinfodb)
        ("r-genomicalignments" ,r-genomicalignments)
        ("r-genomicfeatures" ,r-genomicfeatures)
@@ -2071,14 +2128,14 @@ achieved for all methods using the BiocParallel framework.")
 (define-public r-biocsingular
   (package
     (name "r-biocsingular")
-    (version "1.2.0")
+    (version "1.2.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "BiocSingular" version))
        (sha256
         (base32
-         "0qd7r2k56ym7ivjgapxbk7fyj2d7396f1ad1hkgnicgyw1an5q1r"))))
+         "0fjfmmpda7pszsck2hm7bp4509pl3xaz02q2q03d5vla62h1h81k"))))
     (properties `((upstream-name . "BiocSingular")))
     (build-system r-build-system)
     (propagated-inputs
@@ -3368,14 +3425,14 @@ data.")
 (define-public r-enrichplot
   (package
     (name "r-enrichplot")
-    (version "1.6.0")
+    (version "1.6.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "enrichplot" version))
        (sha256
         (base32
-         "1jblx00b869xhx1c4n9m2g1hqr00rm9ywr1hrlx42bdd8k5ax1xh"))))
+         "0707f5ll58psh7pr001cmmk5di7dprnbry1cy2mw20vn8p24nf3x"))))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-annotationdbi" ,r-annotationdbi)
@@ -3403,14 +3460,14 @@ All the visualization methods are developed based on ggplot2 graphics.")
 (define-public r-clusterprofiler
   (package
     (name "r-clusterprofiler")
-    (version "3.14.0")
+    (version "3.14.3")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "clusterProfiler" version))
        (sha256
         (base32
-         "0mm9iafrsjb8sj27k9mg40ab13vq4rmrzhaajm6g1wdkb2jqikjk"))))
+         "08pd7bmqmyxncj09ilz8yb9sf1pv9ni98y8b93pz2giy7pl407hg"))))
     (properties
      `((upstream-name . "clusterProfiler")))
     (build-system r-build-system)
@@ -3436,14 +3493,14 @@ profiles (GO and KEGG) of gene and gene clusters.")
 (define-public r-mlinterfaces
   (package
     (name "r-mlinterfaces")
-    (version "1.66.0")
+    (version "1.66.2")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "MLInterfaces" version))
        (sha256
         (base32
-         "1vnzqd3y3jk1wgxybckzrcgwk0ly7zgcz5ki1ib0bk1jwv6xk5x8"))))
+         "1wc280iw9vllg6f58vsdj895yaqs8w42kl7jk8sgii009gwlaj8d"))))
     (properties `((upstream-name . "MLInterfaces")))
     (build-system r-build-system)
     (propagated-inputs
@@ -3461,7 +3518,6 @@ profiles (GO and KEGG) of gene and gene clusters.")
        ("r-mlbench" ,r-mlbench)
        ("r-pls" ,r-pls)
        ("r-rcolorbrewer" ,r-rcolorbrewer)
-       ("r-rda" ,r-rda)
        ("r-rpart" ,r-rpart)
        ("r-sfsmisc" ,r-sfsmisc)
        ("r-shiny" ,r-shiny)
@@ -3737,19 +3793,20 @@ fitting a three-component normal mixture on z-scores.")
 (define-public r-rgadem
   (package
     (name "r-rgadem")
-    (version "2.34.0")
+    (version "2.34.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "rGADEM" version))
        (sha256
         (base32
-         "14ylbrzb9haqwfdd9g813mzhll6gwvqf2r7cmbaxz5lkl0j0nglx"))))
+         "12xm4p4qsczf57kip8bvi6pr8sb5gvn11dnbz7lbh6sc03sx3q2h"))))
     (properties `((upstream-name . "rGADEM")))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-biostrings" ,r-biostrings)
        ("r-bsgenome" ,r-bsgenome)
+       ("r-genomicranges" ,r-genomicranges)
        ("r-iranges" ,r-iranges)
        ("r-seqlogo" ,r-seqlogo)))
     (home-page "https://bioconductor.org/packages/rGADEM/")
@@ -5107,14 +5164,14 @@ packages.")
 (define-public r-ropls
   (package
     (name "r-ropls")
-    (version "1.18.0")
+    (version "1.18.6")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "ropls" version))
        (sha256
         (base32
-         "05w1zrq92w3jfwq5sdyj27m5qjg4zv7acywia8vd6y5fbgcnyzlp"))))
+         "1sm2fmygrra9gdcs90lmk5y1ag6arga6159kggx4ij8bkhyc66vb"))))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-biobase" ,r-biobase)
@@ -5529,14 +5586,14 @@ for other R packages to compile and link against.")
 (define-public r-flowworkspace
   (package
     (name "r-flowworkspace")
-    (version "3.34.0")
+    (version "3.34.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "flowWorkspace" version))
        (sha256
         (base32
-         "0hvbkxyylsygra31l1lxyvbsr5hc50lqy1y7gwrfgrfil4a2m762"))))
+         "1ijbc6z9ljhrw3cqr02smgplhrfg44gzrb1dq4gbrpq3nj4khhpn"))))
     (properties `((upstream-name . "flowWorkspace")))
     (build-system r-build-system)
     (propagated-inputs
@@ -6394,14 +6451,14 @@ arrays based on fast wavelet-based functional models.")
 (define-public r-variancepartition
   (package
     (name "r-variancepartition")
-    (version "1.16.0")
+    (version "1.16.1")
     (source
      (origin
        (method url-fetch)
        (uri (bioconductor-uri "variancePartition" version))
        (sha256
         (base32
-         "1ygx7f2sp4b7ilgspm6vqcbjxs7br9s6g3gwcdb978kx03ymp4i8"))))
+         "02pzsff14j4am2d949mh8xgi0c7k44g09q4lr6nqm08vf92brb6g"))))
     (properties
      `((upstream-name . "variancePartition")))
     (build-system r-build-system)
@@ -6753,3 +6810,600 @@ manipulating hypergraphs.")
     (description
      "This package provides functions for visualizing hypergraphs.")
     (license license:gpl2+)))
+
+(define-public r-biggr
+  (package
+    (name "r-biggr")
+    (version "1.22.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BiGGR" version))
+       (sha256
+        (base32
+         "1n2ypc84abmhn6br0yi87k7lvjc11k7abzhgvzdabc2ai1qgcqif"))))
+    (properties `((upstream-name . "BiGGR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-hyperdraw" ,r-hyperdraw)
+       ("r-hypergraph" ,r-hypergraph)
+       ("r-lim" ,r-lim)
+       ("r-limsolve" ,r-limsolve)
+       ("r-rsbml" ,r-rsbml)
+       ("r-stringr" ,r-stringr)))
+    (home-page "https://bioconductor.org/packages/BiGGR/")
+    (synopsis "Constraint based modeling using metabolic reconstruction databases")
+    (description
+     "This package provides an interface to simulate metabolic reconstruction
+from the @url{http://bigg.ucsd.edu/, BiGG database} and other metabolic
+reconstruction databases.  The package facilitates @dfn{flux balance
+analysis} (FBA) and the sampling of feasible flux distributions.  Metabolic
+networks and estimated fluxes can be visualized with hypergraphs.")
+    (license license:gpl3+)))
+
+(define-public r-bigmemoryextras
+  (package
+    (name "r-bigmemoryextras")
+    (version "1.34.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "bigmemoryExtras" version))
+       (sha256
+        (base32
+         "17dk7c44ikphcrpi8hnxyvlmj30qmj098kc0ihfi69bp9rw1cibq"))))
+    (properties
+     `((upstream-name . "bigmemoryExtras")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bigmemory" ,r-bigmemory)))
+    (home-page "https://github.com/phaverty/bigmemoryExtras")
+    (synopsis "Extension of the bigmemory package")
+    (description
+     "This package defines a @code{BigMatrix} @code{ReferenceClass} which adds
+safety and convenience features to the @code{filebacked.big.matrix} class from
+the @code{bigmemory} package.  @code{BigMatrix} protects against segfaults by
+monitoring and gracefully restoring the connection to on-disk data and it also
+protects against accidental data modification with a filesystem-based
+permissions system.  Utilities are provided for using @code{BigMatrix}-derived
+classes as @code{assayData} matrices within the @code{Biobase} package's
+@code{eSet} family of classes.  @code{BigMatrix} provides some optimizations
+related to attaching to, and indexing into, file-backed matrices with
+dimnames.  Additionally, the package provides a @code{BigMatrixFactor} class,
+a file-backed matrix with factor properties.")
+    (license license:artistic2.0)))
+
+(define-public r-bigpint
+  (package
+    (name "r-bigpint")
+    (version "1.2.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "bigPint" version))
+       (sha256
+        (base32
+         "10vs0lzfyxp6sm4r9pxfwipjvzmmaqnvwn1hc5q37s5qz44fg0hk"))))
+    (properties `((upstream-name . "bigPint")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-dplyr" ,r-dplyr)
+       ("r-ggally" ,r-ggally)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-gridextra" ,r-gridextra)
+       ("r-hexbin" ,r-hexbin)
+       ("r-hmisc" ,r-hmisc)
+       ("r-htmlwidgets" ,r-htmlwidgets)
+       ("r-plotly" ,r-plotly)
+       ("r-plyr" ,r-plyr)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-reshape" ,r-reshape)
+       ("r-shiny" ,r-shiny)
+       ("r-shinycssloaders" ,r-shinycssloaders)
+       ("r-shinydashboard" ,r-shinydashboard)
+       ("r-stringr" ,r-stringr)
+       ("r-tidyr" ,r-tidyr)))
+    (home-page "https://github.com/lindsayrutter/bigPint")
+    (synopsis "Big multivariate data plotted interactively")
+    (description
+     "This package provides methods for visualizing large multivariate
+datasets using static and interactive scatterplot matrices, parallel
+coordinate plots, volcano plots, and litre plots.  It includes examples for
+visualizing RNA-sequencing datasets and differentially expressed genes.")
+    (license license:gpl3)))
+
+(define-public r-chemminer
+  (package
+    (name "r-chemminer")
+    (version "3.38.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "ChemmineR" version))
+       (sha256
+        (base32
+         "1j6vmkhc03dmmkm5wgbcv62pw5dclp49f906xkx1pwg27bdldbga"))))
+    (properties `((upstream-name . "ChemmineR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-base64enc" ,r-base64enc)
+       ("r-bh" ,r-bh)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-dbi" ,r-dbi)
+       ("r-digest" ,r-digest)
+       ("r-dt" ,r-dt)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-gridextra" ,r-gridextra)
+       ("r-png" ,r-png)
+       ("r-rcpp" ,r-rcpp)
+       ("r-rcurl" ,r-rcurl)
+       ("r-rjson" ,r-rjson)
+       ("r-rsvg" ,r-rsvg)))
+    (home-page "https://github.com/girke-lab/ChemmineR")
+    (synopsis "Cheminformatics toolkit for R")
+    (description
+     "ChemmineR is a cheminformatics package for analyzing drug-like small
+molecule data in R.  It contains functions for efficient processing of large
+numbers of molecules, physicochemical/structural property predictions,
+structural similarity searching, classification and clustering of compound
+libraries with a wide spectrum of algorithms.  In addition, it offers
+visualization functions for compound clustering results and chemical
+structures.")
+    (license license:artistic2.0)))
+
+(define-public r-bioassayr
+  (package
+    (name "r-bioassayr")
+    (version "1.24.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "bioassayR" version))
+       (sha256
+        (base32
+         "08vxkvxhqnryfbj4dwk3ifb9pn544www9zk2pj9fjbh5xfpwi7zw"))))
+    (properties `((upstream-name . "bioassayR")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocgenerics" ,r-biocgenerics)
+       ("r-chemminer" ,r-chemminer)
+       ("r-dbi" ,r-dbi)
+       ("r-matrix" ,r-matrix)
+       ("r-rjson" ,r-rjson)
+       ("r-rsqlite" ,r-rsqlite)
+       ("r-xml" ,r-xml)))
+    (home-page "https://github.com/TylerBackman/bioassayR")
+    (synopsis "Cross-target analysis of small molecule bioactivity")
+    (description
+     "bioassayR is a computational tool that enables simultaneous analysis of
+thousands of bioassay experiments performed over a diverse set of compounds
+and biological targets.  Unique features include support for large-scale
+cross-target analyses of both public and custom bioassays, generation of
+@dfn{high throughput screening fingerprints} (HTSFPs), and an optional
+preloaded database that provides access to a substantial portion of publicly
+available bioactivity data.")
+    (license license:artistic2.0)))
+
+(define-public r-biobroom
+  (package
+    (name "r-biobroom")
+    (version "1.18.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "biobroom" version))
+       (sha256
+        (base32
+         "1480ycdsh9xdhbpr47vdw5g6m8arqsnp8hc19wwhzm8npxh4qqlb"))))
+    (properties `((upstream-name . "biobroom")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biobase" ,r-biobase)
+       ("r-broom" ,r-broom)
+       ("r-dplyr" ,r-dplyr)
+       ("r-tidyr" ,r-tidyr)))
+    (home-page "https://github.com/StoreyLab/biobroom")
+    (synopsis "Turn Bioconductor objects into tidy data frames")
+    (description
+     "This package contains methods for converting standard objects
+constructed by bioinformatics packages, especially those in Bioconductor, and
+converting them to @code{tidy} data.  It thus serves as a complement to the
+@code{broom} package, and follows the same tidy, augment, glance division of
+tidying methods.  Tidying data makes it easy to recombine, reshape and
+visualize bioinformatics analyses.")
+    ;; Any version of the LGPL.
+    (license license:lgpl3+)))
+
+(define-public r-graphite
+  (package
+    (name "r-graphite")
+    (version "1.32.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "graphite" version))
+       (sha256
+        (base32
+         "1r9fk0cpdwm7012pa85dkjcpkml2j89zcznpf4hfdz66anfyyycd"))))
+    (properties `((upstream-name . "graphite")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)
+       ("r-checkmate" ,r-checkmate)
+       ("r-graph" ,r-graph)
+       ("r-httr" ,r-httr)
+       ("r-rappdirs" ,r-rappdirs)))
+    (home-page "https://bioconductor.org/packages/graphite/")
+    (synopsis "Networks from pathway databases")
+    (description
+     "Graphite provides networks derived from eight public pathway databases,
+and automates the conversion of node identifiers (e.g. from Entrez IDs to gene
+symbols).")
+    (license license:agpl3+)))
+
+(define-public r-reactomepa
+  (package
+    (name "r-reactomepa")
+    (version "1.30.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "ReactomePA" version))
+       (sha256
+        (base32
+         "1vwc9kj1l4yi7c4f4lnq0i3wl2nrmmhcxyakz8qak122fi92z3j1"))))
+    (properties `((upstream-name . "ReactomePA")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)
+       ("r-dose" ,r-dose)
+       ("r-enrichplot" ,r-enrichplot)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-ggraph" ,r-ggraph)
+       ("r-graphite" ,r-graphite)
+       ("r-igraph" ,r-igraph)
+       ("r-reactome-db" ,r-reactome-db)))
+    (home-page "https://guangchuangyu.github.io/software/ReactomePA")
+    (synopsis "Reactome pathway analysis")
+    (description
+     "This package provides functions for pathway analysis based on the
+REACTOME pathway database.  It implements enrichment analysis, gene set
+enrichment analysis and several functions for visualization.")
+    (license license:gpl2)))
+
+(define-public r-ebarrays
+  (package
+    (name "r-ebarrays")
+    (version "2.50.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "EBarrays" version))
+       (sha256
+        (base32
+         "063rhsdp8x0f881kslq06zxfp6b2qabrz4vmfrn8a4v3pd3n7s13"))))
+    (properties `((upstream-name . "EBarrays")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biobase" ,r-biobase)
+       ("r-cluster" ,r-cluster)
+       ("r-lattice" ,r-lattice)))
+    (home-page "https://bioconductor.org/packages/EBarrays/")
+    (synopsis "Gene clustering and differential expression identification")
+    (description
+     "EBarrays provides tools for the analysis of replicated/unreplicated
+microarray data.")
+    (license license:gpl2+)))
+
+(define-public r-bioccasestudies
+  (package
+    (name "r-bioccasestudies")
+    (version "1.48.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BiocCaseStudies" version))
+       (sha256
+        (base32
+         "1sg9vxs24zfz3dg9y0qlrdsq43y0pbahbvcfxzlxjzjw80xzxpbd"))))
+    (properties
+     `((upstream-name . "BiocCaseStudies")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-biobase" ,r-biobase)))
+    (home-page "https://bioconductor.org/packages/BiocCaseStudies")
+    (synopsis "Support for the case studies monograph")
+    (description
+     "This package provides software and data to support the case studies
+monograph.")
+    (license license:artistic2.0)))
+
+(define-public r-biocgraph
+  (package
+    (name "r-biocgraph")
+    (version "1.48.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "biocGraph" version))
+       (sha256
+        (base32
+         "1rv2lwiqwg7h7za23n896fs4dpla3xhw6kzwghb6iw5nlm2m61yw"))))
+    (properties `((upstream-name . "biocGraph")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocgenerics" ,r-biocgenerics)
+       ("r-geneplotter" ,r-geneplotter)
+       ("r-graph" ,r-graph)
+       ("r-rgraphviz" ,r-rgraphviz)))
+    (home-page "https://bioconductor.org/packages/biocGraph/")
+    (synopsis "Graph examples and use cases in Bioinformatics")
+    (description
+     "This package provides examples and code that make use of the
+different graph related packages produced by Bioconductor.")
+    (license license:artistic2.0)))
+
+(define-public r-experimenthub
+  (package
+    (name "r-experimenthub")
+    (version "1.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "ExperimentHub" version))
+       (sha256
+        (base32
+         "054w2lkyirbmhgia0rp4nk9zzw3zphz6jxg6fc9zlarp90g64z24"))))
+    (properties `((upstream-name . "ExperimentHub")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationhub" ,r-annotationhub)
+       ("r-biocfilecache" ,r-biocfilecache)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-biocmanager" ,r-biocmanager)
+       ("r-curl" ,r-curl)
+       ("r-rappdirs" ,r-rappdirs)
+       ("r-s4vectors" ,r-s4vectors)))
+    (home-page "https://bioconductor.org/packages/ExperimentHub/")
+    (synopsis "Client to access ExperimentHub resources")
+    (description
+     "This package provides a client for the Bioconductor ExperimentHub web
+resource.  ExperimentHub provides a central location where curated data from
+experiments, publications or training courses can be accessed.  Each resource
+has associated metadata, tags and date of modification.  The client creates
+and manages a local cache of files retrieved enabling quick and reproducible
+access.")
+    (license license:artistic2.0)))
+
+(define-public r-multiassayexperiment
+  (package
+    (name "r-multiassayexperiment")
+    (version "1.12.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "MultiAssayExperiment" version))
+       (sha256
+        (base32
+         "0xpi5qpffg9pn8szkvicpc43a0r534wngyqwvsip8w66zi8c9kpc"))))
+    (properties
+     `((upstream-name . "MultiAssayExperiment")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-iranges" ,r-iranges)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-summarizedexperiment" ,r-summarizedexperiment)
+       ("r-tidyr" ,r-tidyr)))
+    (home-page "http://waldronlab.io/MultiAssayExperiment/")
+    (synopsis "Integration of multi-omics experiments in Bioconductor")
+    (description
+     "MultiAssayExperiment harmonizes data management of multiple assays
+performed on an overlapping set of specimens.  It provides a familiar
+Bioconductor user experience by extending concepts from
+@code{SummarizedExperiment}, supporting an open-ended mix of standard data
+classes for individual assays, and allowing subsetting by genomic ranges or
+rownames.")
+    (license license:artistic2.0)))
+
+(define-public r-bioconcotk
+  (package
+    (name "r-bioconcotk")
+    (version "1.6.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BiocOncoTK" version))
+       (sha256
+        (base32
+         "0rnah6c01a33yb9663jim9iclan61rpcwprb56mykgn1pf5hywbj"))))
+    (properties `((upstream-name . "BiocOncoTK")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-bigrquery" ,r-bigrquery)
+       ("r-car" ,r-car)
+       ("r-complexheatmap" ,r-complexheatmap)
+       ("r-curatedtcgadata" ,r-curatedtcgadata)
+       ("r-dbi" ,r-dbi)
+       ("r-dplyr" ,r-dplyr)
+       ("r-dt" ,r-dt)
+       ("r-genomicfeatures" ,r-genomicfeatures)
+       ("r-genomicranges" ,r-genomicranges)
+       ("r-ggplot2" ,r-ggplot2)
+       ("r-ggpubr" ,r-ggpubr)
+       ("r-graph" ,r-graph)
+       ("r-httr" ,r-httr)
+       ("r-iranges" ,r-iranges)
+       ("r-magrittr" ,r-magrittr)
+       ("r-plyr" ,r-plyr)
+       ("r-rgraphviz" ,r-rgraphviz)
+       ("r-rjson" ,r-rjson)
+       ("r-s4vectors" ,r-s4vectors)
+       ("r-scales" ,r-scales)
+       ("r-shiny" ,r-shiny)
+       ("r-summarizedexperiment" ,r-summarizedexperiment)))
+    (home-page "https://bioconductor.org/packages/BiocOncoTK")
+    (synopsis "Bioconductor components for general cancer genomics")
+    (description
+     "The purpose of this package is to provide a central interface to various
+tools for genome-scale analysis of cancer studies.")
+    (license license:artistic2.0)))
+
+(define-public r-biocor
+  (package
+    (name "r-biocor")
+    (version "1.10.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BioCor" version))
+       (sha256
+        (base32
+         "1bjw02rwmz2d715sgpfp08njb15200ch7cmipsf9hd5835ppg1jl"))))
+    (properties `((upstream-name . "BioCor")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocparallel" ,r-biocparallel)
+       ("r-gseabase" ,r-gseabase)
+       ("r-matrix" ,r-matrix)))
+    (home-page "https://llrs.github.io/BioCor/")
+    (synopsis "Functional similarities")
+    (description
+     "This package provides tools to calculate functional similarities based
+on the pathways described on KEGG and REACTOME or in gene sets.  These
+similarities can be calculated for pathways or gene sets, genes, or clusters
+and combined with other similarities.  They can be used to improve networks,
+gene selection, testing relationships, and so on.")
+    (license license:expat)))
+
+(define-public r-biocpkgtools
+  (package
+    (name "r-biocpkgtools")
+    (version "1.4.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BiocPkgTools" version))
+       (sha256
+        (base32
+         "0gyhb3071pxmvaxla7cxy9k97s3z3ynl62jnqz9jnkd53c7jnd53"))))
+    (properties `((upstream-name . "BiocPkgTools")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocmanager" ,r-biocmanager)
+       ("r-biocviews" ,r-biocviews)
+       ("r-dplyr" ,r-dplyr)
+       ("r-dt" ,r-dt)
+       ("r-gh" ,r-gh)
+       ("r-graph" ,r-graph)
+       ("r-htmltools" ,r-htmltools)
+       ("r-htmlwidgets" ,r-htmlwidgets)
+       ("r-httr" ,r-httr)
+       ("r-igraph" ,r-igraph)
+       ("r-jsonlite" ,r-jsonlite)
+       ("r-magrittr" ,r-magrittr)
+       ("r-rbgl" ,r-rbgl)
+       ("r-readr" ,r-readr)
+       ("r-rex" ,r-rex)
+       ("r-rvest" ,r-rvest)
+       ("r-stringr" ,r-stringr)
+       ("r-tibble" ,r-tibble)
+       ("r-tidyr" ,r-tidyr)
+       ("r-xml2" ,r-xml2)))
+    (home-page "https://github.com/seandavi/BiocPkgTools")
+    (synopsis "Collection of tools for learning about Bioconductor packages")
+    (description
+     "Bioconductor has a rich ecosystem of metadata around packages, usage,
+and build status.  This package is a simple collection of functions to access
+that metadata from R.  The goal is to expose metadata for data mining and
+value-added functionality such as package searching, text mining, and
+analytics on packages.")
+    (license license:expat)))
+
+(define-public r-biocset
+  (package
+    (name "r-biocset")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BiocSet" version))
+       (sha256
+        (base32
+         "1xcksnvjflrdarn8xqmgf0n6wbsjkq9jazqwp35i52vqcq4ic1j9"))))
+    (properties `((upstream-name . "BiocSet")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-annotationdbi" ,r-annotationdbi)
+       ("r-dplyr" ,r-dplyr)
+       ("r-keggrest" ,r-keggrest)
+       ("r-plyr" ,r-plyr)
+       ("r-rlang" ,r-rlang)
+       ("r-rtracklayer" ,r-rtracklayer)
+       ("r-tibble" ,r-tibble)))
+    (home-page
+     "https://bioconductor.org/packages/BiocSet")
+    (synopsis
+     "Representing Different Biological Sets")
+    (description
+     "BiocSet displays different biological sets in a triple tibble format.
+These three tibbles are @code{element}, @code{set}, and @code{elementset}.
+The user has the abilty to activate one of these three tibbles to perform
+common functions from the @code{dplyr} package.  Mapping functionality and
+accessing web references for elements/sets are also available in BiocSet.")
+    (license license:artistic2.0)))
+
+(define-public r-biocworkflowtools
+  (package
+    (name "r-biocworkflowtools")
+    (version "1.12.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "BiocWorkflowTools" version))
+       (sha256
+        (base32
+         "1v4bhnpdkmllm7aghms9b7369hkrgz7mn69wbrqg1x42pgkf30ad"))))
+    (properties
+     `((upstream-name . "BiocWorkflowTools")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biocstyle" ,r-biocstyle)
+       ("r-bookdown" ,r-bookdown)
+       ("r-git2r" ,r-git2r)
+       ("r-httr" ,r-httr)
+       ("r-knitr" ,r-knitr)
+       ("r-rmarkdown" ,r-rmarkdown)
+       ("r-rstudioapi" ,r-rstudioapi)
+       ("r-stringr" ,r-stringr)
+       ("r-usethis" ,r-usethis)))
+    (home-page "https://bioconductor.org/packages/BiocWorkflowTools/")
+    (synopsis "Tools to aid the development of Bioconductor Workflow packages")
+    (description
+     "This package provides functions to ease the transition between
+Rmarkdown and LaTeX documents when authoring a Bioconductor Workflow.")
+    (license license:expat)))
+
+(define-public r-biodist
+  (package
+    (name "r-biodist")
+    (version "1.58.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "bioDist" version))
+       (sha256
+        (base32
+         "0iabw07px3ybdgbbab0vv350051cm4aq8w47rz9dnmzx4kil9h5q"))))
+    (properties `((upstream-name . "bioDist")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-biobase" ,r-biobase)
+       ("r-kernsmooth" ,r-kernsmooth)))
+    (home-page "https://bioconductor.org/packages/bioDist/")
+    (synopsis "Different distance measures")
+    (description
+     "This package provides a collection of software tools for calculating
+distance measures.")
+    (license license:artistic2.0)))