gnu: gettext: Upgrade to 0.18.3.
[jackhill/guix/guix.git] / gnu / packages / bdb.scm
index c9cdf4a..75a2b72 100644 (file)
                      "1f2g2612lf8djbwbwhxsvmffmf9d7693kh2l20195pqp0f9jmnfx"))))
    (build-system gnu-build-system)
    (arguments
-    (lambda (system)
-      `(#:tests? #f ; no check target available
-        #:phases
-        (alist-replace
-         'configure
-         (lambda* (#:key outputs #:allow-other-keys)
-           (let ((out (assoc-ref outputs "out")))
-             (zero?
-              (system* "./dist/configure"
-                       (string-append "--prefix=" out)
-                       (string-append "CONFIG_SHELL=" (which "bash"))
-                       (string-append "SHELL=" (which "bash"))))))
-         %standard-phases))))
+    '(#:tests? #f                            ; no check target available
+      #:phases
+      (alist-replace
+       'configure
+       (lambda* (#:key outputs #:allow-other-keys)
+         (let ((out (assoc-ref outputs "out")))
+           (zero?
+            (system* "./dist/configure"
+                     (string-append "--prefix=" out)
+                     (string-append "CONFIG_SHELL=" (which "bash"))
+                     (string-append "SHELL=" (which "bash"))
+
+                     ;; The compatibility mode is needed by some packages,
+                     ;; notably iproute2.
+                     "--enable-compat185"))))
+       %standard-phases)))
    (synopsis "db, the Berkeley database")
    (description
     "Berkeley DB is an embeddable database allowing developers the choice of