gnu: emacs-consult: Fix grammar.
[jackhill/guix/guix.git] / gnu / packages / file.scm
index d043570..3f1145b 100644 (file)
 (define-public file
   (package
     (name "file")
-    (version "5.33")
-    (replacement file/fixed)
+    (version "5.38")
     (source (origin
               (method url-fetch)
               (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1iipnwjkag7q04zjkaqic41r9nlw0ml6mhqian6qkkbisb1whlhw"))))
+                "0d7s376b4xqymnrsjxi3nsv3f5v89pzfspzml2pcajdk5by2yg2r"))))
    (build-system gnu-build-system)
 
    ;; When cross-compiling, this package depends upon a native install of
@@ -47,6 +46,8 @@
                       `(("self" ,this-package))
                       '()))
 
+   (properties
+    `((release-monitoring-url . "http://ftp.astron.com/pub/file/")))
    (synopsis "File type guesser")
    (description
     "The file command is a file type guesser, a command-line tool that tells
@@ -55,10 +56,3 @@ extensions to tell you the type of a file, but looks at the actual contents
 of the file.  This package provides the libmagic library.")
    (license bsd-2)
    (home-page "https://www.darwinsys.com/file/")))
-
-(define file/fixed
-  (package
-    (inherit file)
-    (source
-      (origin (inherit (package-source file))
-              (patches (search-patches "file-CVE-2018-10360.patch"))))))