gnu: Fix typos.
[jackhill/guix/guix.git] / gnu / packages / maths.scm
index 8ef4f44..af9feff 100644 (file)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gd)
   #:use-module (gnu packages ghostscript)
+  #:use-module (gnu packages glib)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages less)
+  #:use-module (gnu packages lisp)
   #:use-module (gnu packages gnome)
   #:use-module (gnu packages xorg)
   #:use-module (gnu packages gl)
+  #:use-module (gnu packages m4)
   #:use-module (gnu packages mpi)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages pcre)
@@ -120,7 +123,7 @@ numbers.")
 (define-public glpk
   (package
     (name "glpk")
-    (version "4.54")
+    (version "4.55")
     (source
      (origin
       (method url-fetch)
@@ -128,7 +131,7 @@ numbers.")
                           version ".tar.gz"))
       (sha256
        (base32
-        "18gr2anv8gyps6j9f22k7li6w07glvww666sdqblvlq2hh3whwmb"))))
+        "1rqx5fzj1mhkifilip5mkxybpj2wkniq5qcn8h1w2vkr2rzhs29p"))))
     (build-system gnu-build-system)
     (inputs
      `(("gmp" ,gmp)))
@@ -169,17 +172,18 @@ LP/MIP solver is included in the package.")
        ("gtksourceview" ,gtksourceview)
        ("zlib" ,zlib)))
     (native-inputs
-     `(("perl" ,perl)
+     `(("glib" ,glib "bin")             ;for glib-genmarshal
+       ("perl" ,perl)
        ("pkg-config" ,pkg-config)))
     (home-page "http://www.gnu.org/software/pspp/")
     (synopsis "Statistical analysis")
     (description
      "GNU PSPP is a statistical analysis program.  It can perform
-descriptive statistics, T-tests, linear regression and non-parametric tests. 
-It features both a graphical interface as well as command-line input. PSPP is
-designed to interoperate with Gnumeric, LibreOffice and OpenOffice.  Data can
-be imported from spreadsheets, text files and database sources and it can be
-output in text, PostScript, PDF or HTML.")
+descriptive statistics, T-tests, linear regression and non-parametric tests.
+It features both a graphical interface as well as command-line input.  PSPP
+is designed to interoperate with Gnumeric, LibreOffice and OpenOffice.  Data
+can be imported from spreadsheets, text files and database sources and it can
+be output in text, PostScript, PDF or HTML.")
     (license license:gpl3+)))
 
 (define-public lapack
@@ -253,7 +257,8 @@ plotting engine by third-party applications like Octave.")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-"
+      (uri (string-append "http://www.hdfgroup.org/ftp/HDF5/releases/hdf5-"
+                          version "/src/hdf5-"
                           version ".tar.bz2"))
       (sha256
        (base32 "0f9n0v3p3lwc7564791a39c6cn1d3dbrn7d1j3ikqsi27a8hy23d"))))
@@ -268,7 +273,7 @@ plotting engine by third-party applications like Octave.")
          %standard-phases)))
     (outputs '("out" "bin" "lib" "include"))
     (home-page "http://www.hdfgroup.org")
-    (synopsis "Management suite for  extremely large and complex data")
+    (synopsis "Management suite for extremely large and complex data")
     (description "HDF5 is a suite that makes possible the management of
 extremely large and complex data collections.")
     (license (license:x11-style
@@ -467,6 +472,7 @@ scientific applications modeled by partial differential equations.")
 
 (define-public petsc-complex
   (package (inherit petsc)
+    (location (source-properties->location (current-source-location)))
     (name "petsc-complex")
     (arguments
      (substitute-keyword-arguments (package-arguments petsc)
@@ -826,3 +832,40 @@ canvas.  The program supports rectangular two-dimensional plots, histograms,
 polar-axis plots and three-dimensional plots.  Plots can be printed or saved
 to BMP, JPEG or PNG image formats.")
     (license license:gpl3+)))
+
+(define-public maxima
+  (package
+    (name "maxima")
+    (version "5.33.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://sourceforge/maxima/Maxima-source/"
+                           version "-source/" name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "13axm11xw0f3frx5b0qdidi7igkn1524fzz77s9rbpl2yy2nrbz2"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:phases (alist-cons-before
+                 'check 'pre-check
+                 (lambda _ 
+                   (chmod "src/maxima" #o555))
+                 %standard-phases)))
+    (inputs 
+     `(("gcl" ,gcl)))
+    (native-inputs 
+     `(("texinfo" ,texinfo)
+       ("perl" ,perl)))
+    (home-page "http://maxima.sourceforge.net")
+    (synopsis "Numeric and symbolic expression manipulation")
+    (description "Maxima is a system for the manipulation of symbolic and
+numerical expressions.  It yields high precision numeric results by using
+exact fractions, arbitrary precision integers, and variable precision floating
+point numbers")
+    ;; Some files are lgpl2.1+. Some are gpl2+.  Some explicitly state gpl1+.
+    ;; Others simply say "GNU General Public License" without stating a
+    ;; version (which implicitly means gpl1+).
+    ;; At least one file (src/maxima.asd) says "version 2."
+    ;; GPLv2 only is therefore the smallest subset.
+    (license license:gpl2)))