Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / cryptsetup.scm
index 8645e9e..725a397 100644 (file)
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages cryptsetup)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages gnupg)
-  #:use-module (gnu packages lvm)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages python)
   #:use-module (gnu packages linux))
    (inputs
     `(("libgcrypt" ,libgcrypt)
       ("lvm2" ,lvm2)
-      ("popt" ,popt)
-      ("python" ,python-wrapper)
-      ("util-linux" ,util-linux)))
-   (synopsis "hard disk encryption tool")
+      ("util-linux" ,util-linux)
+      ("popt" ,popt)))
+   (native-inputs
+      `(("python" ,python-wrapper)))
+   (synopsis "Hard disk encryption tool")
    (description
     "LUKS (Linux Unified Key Setup)/Cryptsetup provides a standard on-disk
 encryption format, which does not only facilitate compatibility among
 distributions, but which also provides secure management of multiple user
-passwords. In contrast to existing solutions, LUKS stores all setup necessary
+passwords.  In contrast to existing solutions, LUKS stores all setup necessary
 setup information in the partition header, enabling the users to transport
 or migrate their data seamlessly.")
    (license license:gpl2)