gnu: dealii: Update to 8.5.0.
[jackhill/guix/guix.git] / gnu / packages / vpn.scm
index dbdfa22..61ebf0d 100644 (file)
@@ -1,5 +1,11 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2013, 2016 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017 Julien Lepiller <julien@lepiller.eu>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages vpn)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
+  #:use-module (guix build-system python)
   #:use-module (gnu packages)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gettext)
   #:use-module (gnu packages gnupg)
-  #:use-module (gnu packages openssl)
+  #:use-module (gnu packages linux)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages python)
+  #:use-module (gnu packages tls)
   #:use-module (gnu packages xml))
 
+(define-public gvpe
+  (package
+    (name "gvpe")
+    (version "3.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnu/gvpe/gvpe-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "1v61mj25iyd91z0ir7cmradkkcm1ffbk52c96v293ibsvjs2s2hf"))))
+    (build-system gnu-build-system)
+    (home-page "http://software.schmorp.de/pkg/gvpe.html")
+    (inputs `(("openssl" ,openssl)
+              ("zlib" ,zlib)))
+    (synopsis "Secure VPN among multiple nodes over an untrusted network")
+    (description
+     "The GNU Virtual Private Ethernet creates a virtual network
+with multiple nodes using a variety of transport protocols.  It works
+by creating encrypted host-to-host tunnels between multiple
+endpoints.")
+    (license license:gpl3+)))
+
 (define-public vpnc
   (package
    (name "vpnc")
    (version "0.5.3")
    (source (origin
             (method url-fetch)
-            (uri (string-append "http://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-"
+            (uri (string-append "https://www.unix-ag.uni-kl.de/~massar/vpnc/vpnc-"
                                 version ".tar.gz"))
             (sha256 (base32
                      "1128860lis89g1s21hqxvap2nq426c9j4bvgghncc1zj0ays7kj6"))
-            (patches (list (search-patch "vpnc-script.patch")))))
+            (patches (search-patches "vpnc-script.patch"))))
    (build-system gnu-build-system)
    (inputs `(("libgcrypt" ,libgcrypt)
-             ("perl" ,perl)))
+             ("perl" ,perl)
+
+             ;; The following packages provide commands that 'vpnc-script'
+             ;; expects.
+             ("net-tools" ,net-tools)             ;ifconfig, route
+             ("iproute2" ,iproute)))              ;ip
    (arguments
     `(#:tests? #f ; there is no check target
       #:phases
-      (alist-replace
-       'configure
-       (lambda* (#:key outputs #:allow-other-keys)
-         (let ((out (assoc-ref outputs "out")))
-           (substitute* "Makefile"
-             (("PREFIX=/usr/local") (string-append "PREFIX=" out)))
-           (substitute* "Makefile"
-             (("ETCDIR=/etc/vpnc") (string-append "ETCDIR=" out "/etc/vpnc")))))
-       %standard-phases)))
-   (synopsis "vpnc, a client for cisco vpn concentrators")
+      (modify-phases %standard-phases
+        (replace 'configure
+          (lambda* (#:key outputs #:allow-other-keys)
+            (let ((out (assoc-ref outputs "out")))
+              (substitute* "Makefile"
+                (("PREFIX=/usr/local") (string-append "PREFIX=" out)))
+              (substitute* "Makefile"
+                (("ETCDIR=/etc/vpnc") (string-append "ETCDIR=" out
+                                                     "/etc/vpnc"))))))
+        (add-after 'install 'wrap-vpnc-script
+          (lambda* (#:key inputs outputs #:allow-other-keys)
+            ;; Wrap 'etc/vpnc/vpnc-script' so that it finds the commands it
+            ;; needs.  Assume coreutils/grep/sed are in $PATH.
+            (let ((out (assoc-ref outputs "out")))
+              (wrap-program (string-append out "/etc/vpnc/vpnc-script")
+                `("PATH" ":" prefix
+                  (,(string-append (assoc-ref inputs "net-tools")
+                                   "/sbin")
+                   ,(string-append (assoc-ref inputs "net-tools")
+                                   "/bin")
+                   ,(string-append (assoc-ref inputs "iproute2")
+                                   "/sbin"))))))))))
+   (synopsis "Client for Cisco VPN concentrators")
    (description
     "vpnc is a VPN client compatible with Cisco's EasyVPN equipment.
-It supports IPSec (ESP) with Mode Configuration and Xauth. It supports only
+It supports IPSec (ESP) with Mode Configuration and Xauth.  It supports only
 shared-secret IPSec authentication with Xauth, AES (256, 192, 128), 3DES,
-1DES, MD5, SHA1, DH1/2/5 and IP tunneling. It runs entirely in userspace.
+1DES, MD5, SHA1, DH1/2/5 and IP tunneling.  It runs entirely in userspace.
 Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
    (license license:gpl2+) ; some file are bsd-2, see COPYING
    (home-page "http://www.unix-ag.uni-kl.de/~massar/vpnc/")))
@@ -71,36 +120,28 @@ Only \"Universal TUN/TAP device driver support\" is needed in the kernel.")
 (define-public openconnect
   (package
    (name "openconnect")
-   (version "4.99")
+   (version "7.08")
    (source (origin
             (method url-fetch)
-            (uri (string-append "ftp://ftp.infradead.org/pub/openconnect/openconnect-"
-                                version ".tar.gz"))
+            (uri (string-append "ftp://ftp.infradead.org/pub/openconnect/"
+                                "openconnect-" version ".tar.gz"))
             (sha256 (base32
-                     "1rd8pap455wzkx19i0sy3cqap524b6fwcjvqynxp6lhm01di4bd6"))))
+                     "00wacb79l2c45f94gxs63b9z25wlciarasvjrb8jb8566wgyqi0w"))))
    (build-system gnu-build-system)
    (inputs
-    `(("gettext" ,gnu-gettext)
-      ("libxml2" ,libxml2)
-      ("openssl" ,openssl)
-      ("pkg-config" ,pkg-config)
+    `(("libxml2" ,libxml2)
+      ("gnutls" ,gnutls)
       ("vpnc" ,vpnc)
       ("zlib" ,zlib)))
+   (native-inputs
+    `(("gettext" ,gettext-minimal)
+      ("pkg-config" ,pkg-config)))
    (arguments
-    `(#:phases
-      (alist-replace
-       'configure
-       (lambda* (#:key inputs #:allow-other-keys #:rest args)
-         (let ((vpnc (assoc-ref inputs "vpnc"))
-               (configure (assoc-ref %standard-phases 'configure)))
-           (apply configure
-                  (append args
-                          (list '#:configure-flags
-                                (list (string-append "--with-vpnc-script="
-                                                     vpnc
-                                                     "/etc/vpnc/vpnc-script")))))))
-       %standard-phases)))
-   (synopsis "client for cisco vpn")
+    `(#:configure-flags
+      `(,(string-append "--with-vpnc-script="
+                        (assoc-ref %build-inputs "vpnc")
+                        "/etc/vpnc/vpnc-script"))))
+   (synopsis "Client for Cisco VPN")
    (description
     "OpenConnect is a client for Cisco's AnyConnect SSL VPN, which is
 supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,
@@ -108,3 +149,125 @@ supported by the ASA5500 Series, by IOS 12.4(9)T or later on Cisco SR500,
 and probably others.")
    (license license:lgpl2.1)
    (home-page "http://www.infradead.org/openconnect/")))
+
+(define-public openvpn
+  (package
+    (name "openvpn")
+    (version "2.4.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://swupdate.openvpn.org/community/releases/openvpn-"
+                    version ".tar.xz"))
+              (sha256
+               (base32
+                "1yrnvvnap2ghqas10l8jfg3njx57b8swh3n9wyp556qqgz4mzq8m"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags '("--enable-iproute2=yes")))
+    (native-inputs
+     `(("iproute2" ,iproute)))
+    (inputs
+     `(("lzo" ,lzo)
+       ("openssl" ,openssl)
+       ("linux-pam" ,linux-pam)))
+    (home-page "https://openvpn.net/")
+    (synopsis "Virtual private network daemon")
+    (description "OpenVPN implements virtual private network (VPN) techniques
+for creating secure point-to-point or site-to-site connections in routed or
+bridged configurations and remote access facilities.  It uses a custom
+security protocol that utilizes SSL/TLS for key exchange.  It is capable of
+traversing network address translators (NATs) and firewalls.")
+    (license license:gpl2)))
+
+(define-public tinc
+  (package
+    (name "tinc")
+    (version "1.0.28")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://tinc-vpn.org/packages/"
+                                  name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0i5kx3hza359nclyhb60kxlzqyx0phmg175350hww28g6scjcl0b"))))
+    (build-system gnu-build-system)
+    (arguments
+     '(#:configure-flags
+       '("--sysconfdir=/etc"
+         "--localstatedir=/var")))
+    (inputs `(("zlib" ,zlib)
+              ("lzo" ,lzo)
+              ("openssl" ,openssl)))
+    (home-page "http://tinc-vpn.org")
+    (synopsis "Virtual Private Network (VPN) daemon")
+    (description
+     "Tinc is a VPN that uses tunnelling and encryption to create a secure
+private network between hosts on the internet.")
+    (license license:gpl2+)))
+
+(define-public sshuttle
+  (package
+    (name "sshuttle")
+    (version "0.78.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri name version))
+       (sha256
+        (base32
+         "12xyq5h77b57cnkljdk8qyjxzys512b73019s20x6ck5brj1m8wa"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-setuptools-scm" ,python-setuptools-scm)
+       ;; For tests only.
+       ("python-mock" ,python-mock)
+       ("python-pytest" ,python-pytest)
+       ("python-pytest-runner" ,python-pytest-runner)))
+    (home-page "https://github.com/sshuttle/sshuttle")
+    (synopsis "VPN that transparently forwards connections over SSH")
+    (description "sshuttle creates an encrypted virtual private network (VPN)
+connection to any remote server to which you have secure shell (SSH) access.
+The only requirement is a suitable version of Python on the server;
+administrative privileges are required only on the client.  Unlike most VPNs,
+sshuttle forwards entire sessions, not packets, using kernel transparent
+proxying.  This makes it faster and more reliable than SSH's own tunneling and
+port forwarding features.  It can forward both TCP and UDP traffic, including
+DNS domain name queries.")
+    (license license:lgpl2.0))) ; incorrectly identified as GPL in ‘setup.py’
+
+(define-public sshoot
+  (package
+    (name "sshoot")
+    (version "1.2.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri name version))
+       (sha256
+        (base32
+         "1ccgh0hjyxrwkgy3hnxz3hgbjbs0lmfs25d5l5jam0xbpcpj63h0"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-paths
+           (lambda _
+             (substitute* "sshoot/tests/test_manager.py"
+               (("/bin/sh") (which "sh")))
+             #t)))))
+    (inputs
+     `(("python-argcomplete" ,python-argcomplete)
+       ("python-prettytable" ,python-prettytable)
+       ("python-pyyaml" ,python-pyyaml)))
+    ;; For tests only.
+    (native-inputs
+     `(("python-fixtures" ,python-fixtures)
+       ("python-pbr" ,python-pbr)
+       ("python-testtools" ,python-testtools)))
+    (home-page "https://github.com/albertodonato/sshoot")
+    (synopsis "sshuttle VPN session manager")
+    (description "sshoot provides a command-line interface to manage multiple
+@command{sshuttle} virtual private networks.  It supports flexible profiles
+with configuration options for most of @command{sshuttle}’s features.")
+    (license license:gpl3+)))