gnu: Add ganv.
[jackhill/guix/guix.git] / gnu / packages / audio.scm
index 1105ec2..4e87fef 100644 (file)
   #:use-module (guix build-system waf)
   #:use-module (gnu packages)
   #:use-module (gnu packages algebra)
+  #:use-module (gnu packages boost)
+  #:use-module (gnu packages curl)
   #:use-module (gnu packages databases)
-  #:use-module (gnu packages glib) ;dbus
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages gnome)
+  #:use-module (gnu packages qt)
   #:use-module (gnu packages linux)
+  #:use-module (gnu packages mp3) ;taglib
+  #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages pulseaudio)  ;libsndfile, libsamplerate
   #:use-module (gnu packages python)
   #:use-module (gnu packages rdf)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages xiph)
-  #:use-module (gnu packages xml))
+  #:use-module (gnu packages xml)
+  #:use-module (srfi srfi-1))
 
 (define-public aubio
   (package
@@ -75,6 +83,79 @@ attacks, performing pitch detection, tapping the beat and producing MIDI
 streams from live audio.")
     (license license:gpl3+)))
 
+(define-public ardour
+  (package
+    (name "ardour")
+    (version "3.5.403")
+    (source (origin
+              ;; The project only provides tarballs upon individual request
+              ;; (or after payment) so we take the code from git.
+              (method git-fetch)
+              (uri (git-reference
+                    (url "git://git.ardour.org/ardour/ardour.git")
+                    (commit version)))
+              (snippet
+               '(call-with-output-file
+                    "libs/ardour/revision.cc"
+                  (lambda (port)
+                    (format port "#include \"ardour/revision.h\"
+namespace ARDOUR { const char* revision = \"3.5-403-gec2cb31\" ; }"))))
+              (sha256
+               (base32
+                "01b0wxh0wlxjfz5j8gcwwqhxc6q2kn4njz2fcmzv9fr3xaya5dbp"))
+              (file-name (string-append name "-" version))))
+    (build-system waf-build-system)
+    (arguments
+     `(#:tests? #f ; no check target
+       #:python ,python-2))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("aubio" ,aubio)
+       ("lrdf" ,lrdf)
+       ("boost" ,boost)
+       ("atkmm" ,atkmm)
+       ("cairomm" ,cairomm)
+       ("gtkmm" ,gtkmm-2)
+       ("glibmm" ,glibmm)
+       ("libart-lgpl" ,libart-lgpl)
+       ("libgnomecanvasmm" ,libgnomecanvasmm)
+       ("pangomm" ,pangomm)
+       ("liblo" ,liblo)
+       ("libsndfile" ,libsndfile)
+       ("libsamplerate" ,libsamplerate)
+       ("libxml2" ,libxml2)
+       ("libogg" ,libogg)
+       ("libvorbis" ,libvorbis)
+       ("flac" ,flac)
+       ("lv2" ,lv2)
+       ("vamp" ,vamp)
+       ("curl" ,curl)
+       ("libuuid" ,util-linux)
+       ("fftw" ,fftw)
+       ("fftwf" ,fftwf)
+       ("jack" ,jack-1)
+       ("serd" ,serd)
+       ("sord" ,sord)
+       ("sratom" ,sratom)
+       ("suil" ,suil)
+       ("lilv" ,lilv)
+       ("rasqal" ,rasqal)
+       ("raptor2" ,raptor2)
+       ("redland" ,redland)
+       ("rubberband" ,rubberband)
+       ("taglib" ,taglib)
+       ("python-rdflib" ,python-rdflib)))
+    (native-inputs
+     `(("perl" ,perl)
+       ("pkg-config" ,pkg-config)))
+    (home-page "http://ardour.org")
+    (synopsis "Digital audio workstation")
+    (description
+     "Ardour is a multi-channel digital audio workstation, allowing users to
+record, edit, mix and master audio and MIDI projects.  It is targeted at audio
+engineers, musicians, soundtrack editors and composers.")
+    (license license:gpl2+)))
+
 (define-public jack-1
   (package
     (name "jack")
@@ -90,8 +171,12 @@ streams from live audio.")
                "1mk1wnx33anp6haxfjjkfhwbaknfblsvj35nxvz0hvspcmhdyhpb"))))
     (build-system gnu-build-system)
     (inputs
-     `(("bdb" ,bdb)
+     `(("alsa-lib" ,alsa-lib)
+       ("bdb" ,bdb)
+       ("readline" ,readline)
        ("libuuid" ,util-linux)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
     (home-page "http://jackaudio.org/")
     (synopsis "JACK audio connection kit")
     (description
@@ -107,7 +192,7 @@ synchronous execution of all clients, and low latency operation.")
 
 (define-public jack-2
   (package (inherit jack-1)
-    (name "jack")
+    (name "jack2")
     (version "1.9.10")
     (source (origin
              (method url-fetch)
@@ -135,6 +220,84 @@ synchronous execution of all clients, and low latency operation.")
     ;; Most files are under GPLv2+, but some headers are under LGPLv2.1+
     (license (list license:gpl2+ license:lgpl2.1+))))
 
+(define-public ladspa
+  (package
+    (name "ladspa")
+    (version "1.13")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append
+                   "http://www.ladspa.org/download/ladspa_sdk_"
+                   version
+                   ".tgz"))
+             (sha256
+              (base32
+               "0srh5n2l63354bc0srcrv58rzjkn4gv8qjqzg8dnq3rs4m7kzvdm"))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:tests? #f  ; the "test" target is a listening test only
+       #:phases
+       (alist-replace
+        'configure
+        (lambda* (#:key inputs outputs #:allow-other-keys #:rest args)
+          (chdir "src")
+          (let ((out (assoc-ref outputs "out")))
+            (substitute* "makefile"
+              (("/usr/lib/ladspa/") (string-append out "/lib/ladspa/"))
+              (("/usr/include/")    (string-append out "/include/"))
+              (("/usr/bin/")        (string-append out "/bin/"))
+              (("-mkdirhier")       "mkdir -p")
+              (("^CC.*")            "CC = gcc\n")
+              (("^CPP.*")           "CPP = g++\n"))))
+        (alist-delete 'build %standard-phases))))
+    (home-page "http://ladspa.org")
+    (synopsis "Linux Audio Developer's Simple Plugin API (LADSPA)")
+    (description
+     "LADSPA is a standard that allows software audio processors and effects
+to be plugged into a wide range of audio synthesis and recording packages.")
+    (license license:lgpl2.1+)))
+
+(define-public lash
+  (package
+    (name "lash")
+    (version "0.6.0-rc2")
+    (source (origin
+              (method url-fetch)
+              ;; The tilde is not permitted in the builder name, but is used
+              ;; in the tarball.
+              (uri (string-append
+                    "mirror://savannah/lash/lash-"
+                    (string-join (string-split version #\-) "~")
+                    ".tar.bz2"))
+              (file-name (string-append name "-" version ".tar.bz2"))
+              (sha256
+               (base32
+                "12z1vx3krrzsfccpah9xjs68900xvr7bw92wx8np5871i2yv47iw"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("bdb" ,bdb)
+       ("gtk" ,gtk+-2)
+       ("jack" ,jack-1)
+       ("libuuid" ,util-linux)
+       ("readline" ,readline)
+       ("python" ,python-2)))
+    ;; According to pkg-config, packages depending on lash also need to have
+    ;; at least the following packages declared as inputs.
+    (propagated-inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("dbus" ,dbus)
+       ("libxml2" ,libxml2)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://www.nongnu.org/lash/")
+    (synopsis "Audio application session manager")
+    (description
+     "LASH is a session management system for audio applications.  It allows
+you to save and restore audio sessions consisting of multiple interconneced
+applications, restoring program state (i.e. loaded patches) and the
+connections between them.")
+    (license license:gpl2+)))
+
 (define-public liblo
   (package
     (name "liblo")
@@ -160,6 +323,35 @@ synchronous execution of all clients, and low latency operation.")
 implementation of the Open Sound Control (OSC) protocol.")
     (license license:lgpl2.1+)))
 
+(define-public lilv
+  (package
+    (name "lilv")
+    (version "0.20.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "http://download.drobilla.net/lilv-"
+                                 version
+                                 ".tar.bz2"))
+             (sha256
+              (base32
+               "0aj2plkx56iar8vzjbq2l7hi7sp0ml99m0h44rgwai2x4vqkk2j2"))))
+    (build-system waf-build-system)
+    (arguments `(#:tests? #f)) ; no check target
+    (inputs
+     `(("lv2" ,lv2)
+       ("serd" ,serd)
+       ("sord" ,sord)
+       ("sratom" ,sratom)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://drobilla.net/software/lilv/")
+    (synopsis "Library to simplify use of LV2 plugins in applications")
+    (description
+     "Lilv is a C library to make the use of LV2 plugins as simple as possible
+for applications.  Lilv is the successor to SLV2, rewritten to be
+significantly faster and have minimal dependencies.")
+    (license license:isc)))
+
 (define-public lv2
   (package
     (name "lv2")
@@ -190,6 +382,67 @@ add functionality to support the needs of increasingly powerful audio
 software.")
     (license license:isc)))
 
+(define-public lvtk
+  (package
+    (name "lvtk")
+    (version "1.2.0")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "https://github.com/lvtk/lvtk/archive/"
+                                 version
+                                 ".tar.gz"))
+             (sha256
+              (base32
+               "03nbj2cqcklqwh50zj2gwm07crh5iwqbpxbpzwbg5hvgl4k4rnjd"))))
+    (build-system waf-build-system)
+    (arguments
+     `(#:tests? #f  ; no check target
+       #:python ,python-2
+       #:configure-flags
+       (list (string-append "--boost-includes="
+                            (assoc-ref %build-inputs "boost")
+                            "/include"))))
+    (inputs
+     `(("boost" ,boost)
+       ("lv2" ,lv2)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "https://github.com/lvtk/lvtk")
+    (synopsis "C++ libraries for LV2 plugins")
+    (description
+     "The LV2 Toolkit (LVTK) contains libraries that wrap the LV2 C API and
+extensions into easy to use C++ classes.  It is the successor of
+lv2-c++-tools.")
+    (license license:gpl3+)))
+
+(define-public rubberband
+  (package
+    (name "rubberband")
+    (version "1.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri
+               (string-append "https://bitbucket.org/breakfastquay/rubberband/get/v"
+                              version
+                              ".tar.bz2"))
+              (sha256
+               (base32
+                "05amrbrxx0da3w7m237q51799r8xgs4ffqabi2qv06hq8dpcj386"))))
+    (build-system gnu-build-system)
+    (arguments `(#:tests? #f)) ; no check target
+    (inputs
+     `(("ladspa" ,ladspa)
+       ("libsamplerate" ,libsamplerate)
+       ("vamp" ,vamp)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://breakfastquay.com/rubberband/")
+    (synopsis "Audio time-stretching and pitch-shifting library")
+    (description
+     "Rubber Band is a library and utility program that permits changing the
+tempo and pitch of an audio recording independently of one another.")
+    (license license:gpl2+)))
+
 (define-public sratom
   (package
     (name "sratom")
@@ -216,3 +469,66 @@ software.")
      "Sratom is a library for serialising LV2 atoms to/from RDF, particularly
 the Turtle syntax.")
     (license license:isc)))
+
+(define-public suil
+  (package
+    (name "suil")
+    (version "0.8.2")
+    (source (origin
+             (method url-fetch)
+             (uri (string-append "http://download.drobilla.net/suil-"
+                                 version
+                                 ".tar.bz2"))
+             (sha256
+              (base32
+               "1s3adyiw7sa5gfvm5wasa61qa23629kprxyv6w8hbxdiwp0hhxkq"))))
+    (build-system waf-build-system)
+    (arguments `(#:tests? #f)) ; no check target
+    (inputs
+     `(("lv2" ,lv2)
+       ("gtk+-2" ,gtk+-2)
+       ("qt-4" ,qt-4)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://drobilla.net/software/suil/")
+    (synopsis "Library for loading and wrapping LV2 plugin UIs")
+    (description
+     "Suil is a lightweight C library for loading and wrapping LV2 plugin UIs.
+
+Suil makes it possible to load a UI of a toolkit in a host using another
+toolkit.  The API is designed such that hosts do not need to explicitly
+support specific toolkits – if Suil supports a particular toolkit, then UIs in
+that toolkit will work in all hosts that use Suil automatically.
+
+Suil currently supports every combination of Gtk 2, Qt 4, and X11.")
+    (license license:isc)))
+
+(define-public vamp
+  (package
+    (name "vamp")
+    (version "2.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://code.soundsoftware.ac.uk"
+                    "/attachments/download/690/vamp-plugin-sdk-"
+                    version
+                    ".tar.gz"))
+             (sha256
+              (base32
+               "178kfgq08cmgdzv7g8dwyjp4adwx8q04riimncq4nqkm8ng9ywbv"))))
+    (build-system gnu-build-system)
+    (arguments `(#:tests? #f)) ; no check target
+    (inputs
+     `(("libsndfile" ,libsndfile)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://vamp-plugins.org")
+    (synopsis "Modular and extensible audio processing system")
+    (description
+     "Vamp is an audio processing plugin system for plugins that extract
+descriptive information from audio data — typically referred to as audio
+analysis plugins or audio feature extraction plugins.")
+    (license
+     (license:x11-style
+      "https://code.soundsoftware.ac.uk/projects/vamp-plugin-sdk/repository/entry/COPYING"))))