gnu: r-fields: Update to 11.4.
[jackhill/guix/guix.git] / gnu / packages / php.scm
index ac0f991..18fc9f1 100644 (file)
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016 Julien Lepiller <julien@lepiller.eu>
+;;; Copyright © 2016-2020 Julien Lepiller <julien@lepiller.eu>
 ;;; Copyright © 2016 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2019 Oleg Pykhalov <go.wigust@gmail.com>
 ;;; Copyright © 2020 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 (define-public php
   (package
     (name "php")
-    (version "7.4.2")
-    (home-page "https://www.php.net/")
+    (version "7.4.10")
+    (home-page "https://secure.php.net/")
     (source (origin
               (method url-fetch)
               (uri (string-append home-page "distributions/"
                                   "php-" version ".tar.xz"))
               (sha256
                (base32
-                "04yz9f7klh642syfh49rmribzwd1k5ssxv0pc510vnhpq3m4sa4q"))
+                "045h9zb0mw369n35gd4mp5yhwh62akp0s43vg255i122n400pnf2"))
               (modules '((guix build utils)))
               (snippet
                '(with-directory-excursion "ext"
                          ;; This failing test is skipped on PHP's Travis CI as it is
                          ;; supposedly inaccurate.
                          "ext/standard/tests/file/disk_free_space_basic.phpt"
-                         ;; The two following tests erroneously expect the link count
-                         ;; of a sub-directory to increase compared to its
-                         ;; parent.
+                         ;; The following test erroneously expect the link
+                         ;; count of a sub-directory to increase compared to
+                         ;; its parent.
                          "ext/standard/tests/file/lstat_stat_variation8.phpt"
-                         "ext/standard/tests/file/lstat_stat_variation9.phpt"
 
                          ;; XXX: These gd tests fails.  Likely because our version
                          ;; is different from the (patched) bundled one.
                          ;; This bug should have been fixed in gd 2.2.2.
                          ;; Is it a regression?
                          "ext/gd/tests/bug65148.phpt"
+                         ;; This bug should have been fixed in the gd 2.2
+                         ;; series.  Perhaps a regression introduced by gd
+                         ;; 2.3.0?
+                         "ext/gd/tests/bug66590.phpt"
+                         ;; This bug should have been fixed in the php-5.5
+                         ;; series.  Perhaps a regression introduced by gd
+                         ;; 2.3.0?
+                         "ext/gd/tests/bug70102.phpt"
+                         ;; This bug should have been fixed in the php-5.6
+                         ;; series.  Perhaps a regression introduced by gd
+                         ;; 2.3.0?
+                         "ext/gd/tests/bug73869.phpt"
+                         ;; Some WebP related tests fail.
+                         "ext/gd/tests/webp_basic.phpt"
+                         "ext/gd/tests/imagecreatefromstring_webp.phpt"
                          ;; Expected error message, but from the wrong function
                          "ext/gd/tests/bug77269.phpt"
                          ;; TODO: Enable these when libgd is built with xpm support.
                          ;; differs: expected 114x115, got 117x117".
                          "ext/gd/tests/bug79068.phpt"
 
-
                          ;; XXX: These iconv tests have the expected outcome,
                          ;; but with different error messages.
                          ;; Expects "illegal character", instead gets "unknown error (84)".
@@ -354,6 +367,3 @@ systems, web content management systems and web frameworks." )
               license:lgpl2.1+                              ; ext/bcmath/libbcmath
               license:bsd-2                                 ; ext/fileinfo/libmagic
               license:expat))))                             ; ext/date/lib
-
-(define-public php-with-bcmath
-  (deprecated-package "php-with-bcmath" php))