gnu: Add r-interval.
[jackhill/guix/guix.git] / gnu / packages / openldap.scm
index 107b923..14bf874 100644 (file)
@@ -6,6 +6,7 @@
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
+;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -60,6 +61,7 @@
 (define-public openldap
   (package
    (name "openldap")
+   (replacement openldap-2.4.50)
    (version "2.4.49")
    (source (origin
             (method url-fetch)
    (inputs `(("bdb" ,bdb-5.3)
              ("cyrus-sasl" ,cyrus-sasl)
              ("gnutls" ,gnutls)
-             ("icu4c" ,icu4c)
              ("libgcrypt" ,libgcrypt)
              ("zlib" ,zlib)))
    (native-inputs `(("libtool" ,libtool)
                     ("groff" ,groff)
-                    ("bdb" ,bdb-5.3)
-                    ;; For up to date 'config.guess' and 'config.sub'.
-                    ("automake" ,automake)))
+                    ("bdb" ,bdb-5.3)))
    (arguments
     `(#:tests? #f
       #:configure-flags
       #:make-flags '("STRIP=")
       #:phases
       (modify-phases %standard-phases
-        (add-after 'unpack 'fix-configure
-          (lambda* (#:key inputs native-inputs #:allow-other-keys)
-            ;; Replace outdated config.sub and config.guess:
-            (with-directory-excursion "build"
-              (for-each (lambda (file)
-                          (install-file (string-append
-                                         (assoc-ref
-                                          (or native-inputs inputs) "automake")
-                                         "/share/automake-"
-                                         ,(version-major+minor
-                                           (package-version automake))
-                                         "/" file) "."))
-                        '("config.sub" "config.guess")))
-            #t))
         ,@(if (%current-target-system)
               '((add-before 'configure 'fix-cross-gcc
                   (lambda* (#:key target #:allow-other-keys)
    (license openldap2.8)
    (home-page "https://www.openldap.org/")))
 
+(define openldap-2.4.50
+  (package
+    (inherit openldap)
+    (version "2.4.50")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.openldap.org/software/download/"
+                                  "OpenLDAP/openldap-release/openldap-" version
+                                  ".tgz"))
+              (sha256
+               (base32
+                "1f46nlfwmys110j36sifm7ah8m8f3s10c3vaiikmmigmifapvdaw"))))))
+
 (define-public nss-pam-ldapd
   (package
     (name "nss-pam-ldapd")