gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / calcurse.scm
index f66fbdb..22b54d4 100644 (file)
@@ -1,5 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014, 2015 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2014, 2015, 2017 Eric Bavier <bavier@member.fsf.org>
+;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
+  #:use-module (gnu packages base)
   #:use-module (gnu packages ncurses))
 
 (define-public calcurse
   (package
     (name "calcurse")
-    (version "4.0.0")
+    (version "4.3.0")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "http://calcurse.org/files/calcurse-"
+      (uri (string-append "https://calcurse.org/files/calcurse-"
                           version ".tar.gz"))
       (sha256
        (base32
-        "0d33cpkbhyidvm3xx6iw9ljqdvl6477c2kcwix3bs63nj0ch06v2"))))
+        "16jzg0nasnxdlz23i121x41pq5kbxmjzk52c5d863rg117fc7v1i"))))
     (build-system gnu-build-system)
     (inputs `(("ncurses" ,ncurses)))
+    (native-inputs `(("tzdata" ,tzdata-for-tests)))
     (arguments
      ;; The ical tests all want to create a ".calcurse" directory, and may
      ;; fail with "cannot create directory '.calcurse': File exists" if run
      ;; concurently.
-     '(#:parallel-tests? #f))
-    (home-page "http://www.calcurse.org")
+     `(#:parallel-tests? #f
+       ;; Since this tzdata is only used for tests and not referenced by the
+       ;; built package, used the "fixed" obsolete version of tzdata and ensure
+       ;; it does not sneak in to the closure.
+       #:disallowed-references (,tzdata-for-tests)
+       #:phases (modify-phases %standard-phases
+                  (add-before 'check 'check-setup
+                    (lambda* (#:key inputs #:allow-other-keys)
+                      (setenv "TZDIR"   ;for test/ical-007.sh
+                              (string-append (assoc-ref inputs "tzdata")
+                                             "/share/zoneinfo")))))))
+    (home-page "https://www.calcurse.org")
     (synopsis "Text-based calendar and scheduling")
     (description
      "Calcurse is a text-based calendar and scheduling application.  It helps