gnu: ogre: Update to 1.12.6.
[jackhill/guix/guix.git] / gnu / packages / web-browsers.scm
index 2ef09d4..205538e 100644 (file)
@@ -12,6 +12,7 @@
 ;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
 ;;; Copyright © 2020 Raghav Gururajan <raghavgururajan@disroot.org>
 ;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -161,14 +162,14 @@ older or slower computers and embedded systems.")
 (define-public links
   (package
     (name "links")
-    (version "2.20.2")
+    (version "2.21")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://links.twibright.com/download/"
                                   "links-" version ".tar.bz2"))
               (sha256
                (base32
-                "097ll98ympzfx7qfdyhc52yzvsp167x5nnjs6v8ih496wv80fksb"))))
+                "0qqdcghsdqm7l6kyi0k752ws3ak5crw85pqkcb11wy67j62yspi8"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
@@ -214,16 +215,16 @@ features including, tables, builtin image display, bookmarks, SSL and more.")
 (define-public luakit
   (package
     (name "luakit")
-    (version "2.1")
+    (version "2.2")
     (source (origin
               (method git-fetch)
               (uri (git-reference
-                     (url "https://github.com/luakit/luakit.git")
+                     (url "https://github.com/luakit/luakit")
                      (commit version)))
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1qa90caxv1k6ak88fn0a7n7h0c4iv8szw6zn2axch8ig83i86az2"))))
+                "0km5nxn6innzn8pfsvlkxvfj2z5g46fp6dy5bnmaklbn13mqlcrn"))))
     (inputs
      `(("lua-5.1" ,lua-5.1)
        ("gtk+" ,gtk+)
@@ -343,7 +344,7 @@ access.")
 (define-public qutebrowser
   (package
     (name "qutebrowser")
-    (version "1.12.0")
+    (version "1.13.1")
     (source
      (origin
        (method url-fetch)
@@ -351,7 +352,7 @@ access.")
                            "qutebrowser/releases/download/v" version "/"
                            "qutebrowser-" version ".tar.gz"))
        (sha256
-        (base32 "0pywyhi4v6ymxpn85grrdr1agmcxsnm5jfqf3rlxqx5swbnxbfs1"))))
+        (base32 "1n72dvrv4dch4i07lsis76p7g16a039fwx8rk7w8q9f60wgqb5i8"))))
     (build-system python-build-system)
     (native-inputs
      `(("python-attrs" ,python-attrs))) ; for tests
@@ -456,129 +457,130 @@ driven and does not detract you from your daily work.")
     (license license:gpl3+)))
 
 (define-public nyxt
-  ;; 1.5.0 does not build anymore, let's use the master which is more stable anyways.
-  (let ((commit "9440980a9c5f75232b08ca98183b22be4a3d9bc3"))
-    (package
-      (name "nyxt")
-      (version (git-version "1.5.0" "1" commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               ;; TODO: Mirror seems to hang, let's fallback to GitHub for now.
-               ;; (url "https://source.atlas.engineer/public/nyxt")
-               (url "https://github.com/atlas-engineer/nyxt")
-               (commit commit)))
-         (sha256
-          (base32
-           "079n5ffsa8136i9ik5mn4rwa3iv0avncw6y973gj3hlf8sf4wv7g"))
-         (file-name (git-file-name "nyxt" version))))
-      (build-system gnu-build-system)
-      (arguments
-       `(#:make-flags (list "nyxt" "NYXT_INTERNAL_QUICKLISP=false"
-                            (string-append "DESTDIR=" (assoc-ref %outputs "out"))
-                            "PREFIX=")
-         #:strip-binaries? #f           ; Stripping breaks SBCL binaries.
-         #:phases
-         (modify-phases %standard-phases
-           (add-after 'unpack 'patch-version ; Version is guessed from .git which Guix does not have.
-             (lambda* (#:key inputs #:allow-other-keys)
-               (let ((version (format #f "~a" ,version)))
-                 (substitute* "source/global.lisp"
-                   (("version\\)\\)\\)")
-                    (string-append "version)))"
-                                   "\n"
-                                   "(setf +version+ \"" version "\")"))))
-               #t))
-           (add-before 'build 'make-desktop-version-number
-             (lambda _
-               (with-output-to-file "version"
-                 (lambda _
-                   (format #t "~a" ,version)))))
+  (package
+    (name "nyxt")
+    ;; Package the pre-release because latest stable 1.5.0 does not build
+    ;; anymore.
+    (version "2-pre-release-1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             ;; TODO: Mirror seems to hang, let's fallback to GitHub for now.
+             ;; (url "https://source.atlas.engineer/public/nyxt")
+             (url "https://github.com/atlas-engineer/nyxt")
+             (commit version)))
+       (sha256
+        (base32
+         "0aipsmzqnlkmy001cihz2jnc0hja8c10rm08jycxr05j3gx3qsxd"))
+       (file-name (git-file-name "nyxt" version))))
+    (build-system gnu-build-system)
+    (arguments
+     `(#:make-flags (list "nyxt" "NYXT_INTERNAL_QUICKLISP=false"
+                          (string-append "DESTDIR=" (assoc-ref %outputs "out"))
+                          "PREFIX=")
+       #:strip-binaries? #f             ; Stripping breaks SBCL binaries.
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-version ; Version is guessed from .git which Guix does not have.
+           (lambda* (#:key inputs #:allow-other-keys)
+             (let ((version (format #f "~a" ,version))
+                   (file "source/global.lisp"))
+               (chmod file #o666)
+               (let ((port (open-file file "a")))
+                 (format port "(setf +version+ ~s)" version)
+                 (close-port port)))
+             #t))
+         (add-before 'build 'make-desktop-version-number
+           (lambda _
+             (with-output-to-file "version"
+               (lambda _
+                 (format #t "~a" ,version)
+                 #t))))
 
-           (delete 'configure)
-           (add-before 'build 'fix-common-lisp-cache-folder
-             (lambda _
-               (setenv "HOME" "/tmp")
-               #t))
-           (add-after 'install 'wrap-program
-             (lambda* (#:key inputs outputs #:allow-other-keys)
-               (let* ((bin (string-append (assoc-ref outputs "out") "/bin/nyxt"))
-                      (glib-networking (assoc-ref inputs "glib-networking"))
-                      (libs '("gsettings-desktop-schemas"))
-                      (path (string-join
-                             (map (lambda (lib)
-                                    (string-append (assoc-ref inputs lib) "/lib"))
-                                  libs)
-                             ":"))
-                      (gi-path (string-join
-                                (map (lambda (lib)
-                                       (string-append (assoc-ref inputs lib) "/lib/girepository-1.0"))
-                                     libs)
-                                ":"))
-                      (xdg-path (string-join
-                                 (map (lambda (lib)
-                                        (string-append (assoc-ref inputs lib) "/share"))
-                                      libs)
-                                 ":")))
-                 (wrap-program bin
-                   `("GIO_EXTRA_MODULES" prefix
-                     (,(string-append glib-networking "/lib/gio/modules")))
-                   `("GI_TYPELIB_PATH" prefix (,gi-path))
-                   `("LD_LIBRARY_PATH" ":" prefix (,path))
-                   `("XDG_DATA_DIRS" ":" prefix (,xdg-path)))
-                 #t))))))
-      (native-inputs
-       `(("prove" ,sbcl-prove)
-         ("sbcl" ,sbcl)))
-      (inputs
-       ;; We need to avoid sbcl-* inputs (sbcl-cl-cffi-gtk in particular) as they
-       ;; seem to cause Nyxt to hang into a hogging process in about 10 minutes.
-       ;; Probably an issue between CFFI and how we build SBCL packages.
-       ;; See https://github.com/atlas-engineer/nyxt/issues/680.
-       `(("alexandria" ,cl-alexandria)
-         ("bordeaux-threads" ,cl-bordeaux-threads)
-         ("cl-containers" ,cl-containers)
-         ("cl-css" ,cl-css)
-         ("cl-json" ,cl-json)
-         ("cl-markup" ,cl-markup)
-         ("cl-ppcre" ,cl-ppcre)
-         ("cl-prevalence" ,cl-prevalence)
-         ("closer-mop" ,cl-closer-mop)
-         ("cluffer" ,cl-cluffer)
-         ("dexador" ,cl-dexador)
-         ("enchant" ,cl-enchant)
-         ("fset" ,cl-fset)
-         ("iolib" ,cl-iolib)
-         ("local-time" ,cl-local-time)
-         ("log4cl" ,cl-log4cl)
-         ("lparallel" ,cl-lparallel)
-         ("mk-string-metrics" ,cl-mk-string-metrics)
-         ("moptilities" ,cl-moptilities)
-         ("osicat" ,sbcl-osicat)       ; SBCL version needed for libosicat.so.
-         ("parenscript" ,cl-parenscript)
-         ("plump" ,cl-plump)
-         ("quri" ,cl-quri)
-         ("serapeum" ,cl-serapeum)
-         ("str" ,cl-str)
-         ("swank" ,cl-slime-swank)
-         ("trivia" ,cl-trivia)
-         ("trivial-clipboard" ,cl-trivial-clipboard)
-         ("trivial-features" ,cl-trivial-features)
-         ("trivial-package-local-nicknames" ,cl-trivial-package-local-nicknames)
-         ("trivial-types" ,cl-trivial-types)
-         ("unix-opts" ,cl-unix-opts)
-         ;; WebKitGTK deps
-         ("cl-cffi-gtk" ,cl-cffi-gtk)
-         ("cl-webkit" ,cl-webkit)
-         ("glib-networking" ,glib-networking)
-         ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
-      (synopsis "Extensible web-browser in Common Lisp")
-      (home-page "https://nyxt.atlas.engineer")
-      (description "Nyxt is a keyboard-oriented, extensible web-browser
+         (delete 'configure)
+         (add-before 'build 'fix-common-lisp-cache-folder
+           (lambda _
+             (setenv "HOME" "/tmp")
+             #t))
+         (add-after 'install 'wrap-program
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let* ((bin (string-append (assoc-ref outputs "out") "/bin/nyxt"))
+                    (glib-networking (assoc-ref inputs "glib-networking"))
+                    (libs '("gsettings-desktop-schemas"))
+                    (path (string-join
+                           (map (lambda (lib)
+                                  (string-append (assoc-ref inputs lib) "/lib"))
+                                libs)
+                           ":"))
+                    (gi-path (string-join
+                              (map (lambda (lib)
+                                     (string-append (assoc-ref inputs lib) "/lib/girepository-1.0"))
+                                   libs)
+                              ":"))
+                    (xdg-path (string-join
+                               (map (lambda (lib)
+                                      (string-append (assoc-ref inputs lib) "/share"))
+                                    libs)
+                               ":")))
+               (wrap-program bin
+                 `("GIO_EXTRA_MODULES" prefix
+                   (,(string-append glib-networking "/lib/gio/modules")))
+                 `("GI_TYPELIB_PATH" prefix (,gi-path))
+                 `("LD_LIBRARY_PATH" ":" prefix (,path))
+                 `("XDG_DATA_DIRS" ":" prefix (,xdg-path)))
+               #t))))))
+    (native-inputs
+     `(("prove" ,sbcl-prove)
+       ("sbcl" ,sbcl)))
+    (inputs
+     ;; We need to avoid sbcl-* inputs (sbcl-cl-cffi-gtk in particular) as they
+     ;; seem to cause Nyxt to hang into a hogging process in about 10 minutes.
+     ;; Probably an issue between CFFI and how we build SBCL packages.
+     ;; See https://github.com/atlas-engineer/nyxt/issues/680.
+     `(("alexandria" ,cl-alexandria)
+       ("bordeaux-threads" ,cl-bordeaux-threads)
+       ("cl-containers" ,cl-containers)
+       ("cl-css" ,cl-css)
+       ("cl-json" ,cl-json)
+       ("cl-markup" ,cl-markup)
+       ("cl-ppcre" ,cl-ppcre)
+       ("cl-prevalence" ,cl-prevalence)
+       ("closer-mop" ,cl-closer-mop)
+       ("cluffer" ,cl-cluffer)
+       ("dexador" ,cl-dexador)
+       ("enchant" ,cl-enchant)
+       ("fset" ,cl-fset)
+       ("iolib" ,cl-iolib)
+       ("local-time" ,cl-local-time)
+       ("log4cl" ,cl-log4cl)
+       ("lparallel" ,cl-lparallel)
+       ("mk-string-metrics" ,cl-mk-string-metrics)
+       ("moptilities" ,cl-moptilities)
+       ("osicat" ,sbcl-osicat)         ; SBCL version needed for libosicat.so.
+       ("parenscript" ,cl-parenscript)
+       ("plump" ,cl-plump)
+       ("quri" ,cl-quri)
+       ("serapeum" ,cl-serapeum)
+       ("str" ,cl-str)
+       ("swank" ,cl-slime-swank)
+       ("trivia" ,cl-trivia)
+       ("trivial-clipboard" ,cl-trivial-clipboard)
+       ("trivial-features" ,cl-trivial-features)
+       ("trivial-package-local-nicknames" ,cl-trivial-package-local-nicknames)
+       ("trivial-types" ,cl-trivial-types)
+       ("unix-opts" ,cl-unix-opts)
+       ;; WebKitGTK deps
+       ("cl-cffi-gtk" ,cl-cffi-gtk)
+       ("cl-webkit" ,cl-webkit)
+       ("glib-networking" ,glib-networking)
+       ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)))
+    (synopsis "Extensible web-browser in Common Lisp")
+    (home-page "https://nyxt.atlas.engineer")
+    (description "Nyxt is a keyboard-oriented, extensible web-browser
 designed for power users.  The application has familiar Emacs and VI
 key-bindings and is fully configurable and extensible in Common Lisp.")
-      (license license:bsd-3))))
+    (license license:bsd-3)))
 
 (define-public next
   (deprecated-package "next" nyxt))
@@ -620,7 +622,7 @@ key-bindings and is fully configurable and extensible in Common Lisp.")
                           (install-file "bombadillo.1" mandir)
                           (install-file "bombadillo-icon.png" pixdir)
                           #t)))))))
-    (home-page "http://bombadillo.colorfield.space")
+    (home-page "https://bombadillo.colorfield.space")
     (synopsis "Terminal browser for the gopher, gemini, and finger protocols")
     (description "Bombadillo is a non-web browser for the terminal with
 vim-like key bindings, a document pager, configurable settings, and robust