gnu: docker: Replace tini by tini-static.
[jackhill/guix/guix.git] / gnu / packages / iso-codes.scm
index 67c6dc7..637390d 100644 (file)
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -22,6 +22,7 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system python)
   #:use-module (gnu packages gettext)
 (define-public iso-codes
   (package
     (name "iso-codes")
-    (version "3.77")
+    (version "4.5.0")
+    (home-page "https://salsa.debian.org/iso-codes-team/iso-codes")
     (source (origin
-             (method url-fetch)
-             (uri (string-append
-                   "https://pkg-isocodes.alioth.debian.org/downloads/iso-codes-"
-                   version ".tar.xz"))
+             (method git-fetch)
+             (uri (git-reference
+                   (url home-page)
+                   (commit (string-append "iso-codes-" version))))
+             (file-name (git-file-name name version))
              (sha256
               (base32
-               "140dgygv22a49xb8x1941xr5ff12cphd9zzwxds98pgrqsj77k91"))))
+               "1q6x9c5x4x0x4q11iygldsmxdyzhz1mb4n8im76glwsgqsqyjs80"))))
     (build-system gnu-build-system)
     (inputs
      `(("gettext" ,gettext-minimal)
        ("perl" ,perl)
        ("python" ,python-wrapper)))
-    (home-page "https://salsa.debian.org/iso-codes-team/iso-codes")
     (synopsis "Various ISO standards")
     (description
      "This package provides lists of various ISO standards (e.g. country,
@@ -91,14 +93,14 @@ groups.")
 (define-public python-iso3166
   (package
     (name "python-iso3166")
-    (version "0.8")
+    (version "0.9")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "iso3166" version))
        (sha256
         (base32
-         "0cs9w507dj93jj9z9di93lx2fplf8pma4jkrsvvb258dv6z1gszv"))))
+         "0hm0xm30sprk1jssmn4cqks0x3nx5fp8r5ypvahcysmmayzrsnjl"))))
     (build-system python-build-system)
     (home-page "https://github.com/deactivated/python-iso3166")
     (synopsis "Self-contained ISO 3166-1 country definitions")