gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / libreoffice.scm
index 70f0e8e..a962d9a 100644 (file)
@@ -1,6 +1,8 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages libreoffice)
-  #:use-module (guix packages)
+  #:use-module (guix build-system gnu)
   #:use-module (guix download)
   #:use-module ((guix licenses)
-                #:select (gpl2+ lgpl2.1+ mpl1.1 mpl2.0 non-copyleft))
-  #:use-module (guix build-system gnu)
+                #:select (gpl2+ lgpl2.1+ lgpl3+ mpl1.1 mpl2.0
+                          non-copyleft x11-style))
+  #:use-module (guix packages)
+  #:use-module (guix utils)
+  #:use-module (gnu packages)
+  #:use-module (gnu packages autotools)
+  #:use-module (gnu packages base)
+  #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages cups)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages cyrus-sasl)
-  #:use-module (gnu packages doxygen)
+  #:use-module (gnu packages databases)
+  #:use-module (gnu packages documentation)
+  #:use-module (gnu packages flex)
+  #:use-module (gnu packages fontutils)
   #:use-module (gnu packages ghostscript)
+  #:use-module (gnu packages gl)
+  #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnome)
   #:use-module (gnu packages gperf)
+  #:use-module (gnu packages gnuzilla)
+  #:use-module (gnu packages gstreamer)
+  #:use-module (gnu packages gtk)
   #:use-module (gnu packages icu4c)
-  #:use-module (gnu packages openssl)
+  #:use-module (gnu packages image)
+  #:use-module (gnu packages java)
+  #:use-module (gnu packages linux)
+  #:use-module (gnu packages maths)
+  #:use-module (gnu packages openldap)
+  #:use-module (gnu packages pdf)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
-  #:use-module (gnu packages xml))
+  #:use-module (gnu packages rdf)
+  #:use-module (gnu packages scanner)
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages version-control)
+  #:use-module (gnu packages xml)
+  #:use-module (gnu packages xorg)
+  #:use-module (gnu packages zip))
 
 (define-public ixion
   (package
@@ -66,14 +95,14 @@ their dependencies automatically upon calculation.")
 (define-public orcus
   (package
     (name "orcus")
-    (version "0.7.1")
+    (version "0.9.2")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "http://kohei.us/files/" name "/src/lib"
                           name "-" version ".tar.xz"))
       (sha256 (base32
-               "0hva4qalg3dk6n1118ncr5fy8cqnj2f7fwldw7aa04124rj6p104"))))
+               "170racjz7s7yxza722hxsqc12788w57qnp6x6j2692pzp3qzjjfx"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
@@ -99,21 +128,24 @@ CSV, CSS and XML.")
      (origin
       (method url-fetch)
       (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
-                          version ".tar.xz"))
+                          version "/" name "-" version ".tar.xz"))
       (sha256 (base32
                "03ygxyb0vfjv8raif5q62sl33b54wkr5rzgadb8slijm6k281wpn"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("boost" ,boost)
-       ("cppunit" ,cppunit)
+     `(("cppunit" ,cppunit)
        ("doxygen" ,doxygen)
        ("pkg-config" ,pkg-config)))
     (inputs
      `(("zlib" ,zlib)))
+    (propagated-inputs                  ; Referenced by .la files
+     `(("boost" ,boost)))
     (arguments
      ;; avoid triggering configure errors by simple inclusion of boost headers
-     `(#:configure-flags '("--disable-werror")))
-    (home-page "http://sourceforge.net/p/libwpd/wiki/librevenge/")
+     `(#:configure-flags '("--disable-werror"
+                           ;; Avoid undefined library references
+                           "LDFLAGS=-lboost_system")))
+    (home-page "https://sourceforge.net/p/libwpd/wiki/librevenge/")
     (synopsis "Document importer for office suites")
     (description "Librevenge is a base library for writing document import
 filters.  It has interfaces for text documents, vector graphics,
@@ -127,8 +159,8 @@ spreadsheets and presentations.")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "mirror://sourceforge/libwpd/" name "/" name "-"
-                          version ".tar.xz"))
+      (uri (string-append "mirror://sourceforge/" name "/" name "/"
+                          name "-" version "/" name "-" version ".tar.xz"))
       (sha256 (base32
                "0b6krzr6kxzm89g6bapn805kdayq70hn16n5b5wfs2lwrf0ag2wx"))))
     (build-system gnu-build-system)
@@ -189,8 +221,8 @@ ZVR (simple compressed text format).")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "mirror://sourceforge/libwpg/" name "/" name "-"
-                          version ".tar.xz"))
+      (uri (string-append "mirror://sourceforge/" name "/" name "/"
+                          name "-" version "/" name "-" version ".tar.xz"))
       (sha256 (base32
                "097jx8a638fwwfrzf6v29r1yhc34rq9526py7wf0ck2z4fcr2w3g"))))
     (build-system gnu-build-system)
@@ -218,7 +250,8 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
       (uri (string-append "mirror://sourceforge/" name "/" name "-"
                           version ".tar.gz"))
       (sha256 (base32
-               "1dprvk4fibylv24l7gr49gfqbkfgmxynvgssvdcycgpf7n8h4zm8"))))
+               "1dprvk4fibylv24l7gr49gfqbkfgmxynvgssvdcycgpf7n8h4zm8"))
+      (patches (search-patches "libcmis-fix-test-onedrive.patch"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("cppunit" ,cppunit)
@@ -243,7 +276,7 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
           ;; fails without the following flag.
           (string-append "--with-boost="
                          (assoc-ref %build-inputs "boost")))))
-    (home-page "http://sourceforge.net/projects/libcmis/")
+    (home-page "https://sourceforge.net/projects/libcmis/")
     (synopsis "CMIS client library")
     (description "LibCMIS is a C++ client library for the CMIS interface.  It
 allows C++ applications to connect to any ECM behaving as a CMIS server such
@@ -315,19 +348,21 @@ CorelDRAW documents of all versions.")
 (define-public libetonyek
   (package
     (name "libetonyek")
-    (version "0.1.1")
+    (version "0.1.3")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "http://dev-www.libreoffice.org/src/" name "/"
                           name "-" version ".tar.xz"))
       (sha256 (base32
-               "0gn8v24jb9r9kxppbws6xlc7knpd9mk2n9xjvziccv5f2l7mlslw"))))
+               "0mghaqzj0qqza8z1gzprw62702adlww4kgdzynj5qpxxc9m2f4py"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("cppunit" ,cppunit)
        ("doxygen" ,doxygen)
+       ("glm" ,glm)
        ("gperf" ,gperf)
+       ("mdds" ,mdds)
        ("pkg-config" ,pkg-config)))
     (propagated-inputs ; in Requires or Requires.private field of .pkg
      `(("librevenge" ,librevenge)
@@ -340,6 +375,33 @@ CorelDRAW documents of all versions.")
 Apple Keynote documents.  It currently supports Keynote versions 2 to 5.")
     (license mpl2.0)))
 
+(define-public liblangtag
+  (package
+    (name "liblangtag")
+    (version "0.5.8")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "https://bitbucket.org/tagoh/liblangtag/downloads/"
+                            name "-" version ".tar.bz2"))
+        (sha256
+         (base32
+          "1akf0d7yp29pv3j2pw2riii4n5kyjr9szc0y77khnx9zzr5zdqh8"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxml2" ,libxml2)))
+    (home-page "http://tagoh.bitbucket.org/liblangtag/")
+    (synopsis "Library to access tags for identifying languages")
+    (description "Liblangtag implements an interface to work with tags
+for identifying languages as described in RFC 5646.  It supports the
+extensions described in RFC6067 and RFC6497, and Extension T for
+language/locale identifiers as described in the Unicode CLDR
+standard 21.0.2.")
+    (license (list lgpl3+ mpl2.0)))) ; dual license
+
 (define-public libexttextcat
   (package
     (name "libexttextcat")
@@ -500,7 +562,7 @@ Microsoft Visio documents of all versions.")
     (arguments
      ;; avoid triggering configure errors by simple inclusion of boost headers
      `(#:configure-flags '("--disable-werror")))
-    (home-page "http://sourceforge.net/p/libwpd/wiki/libodfgen/")
+    (home-page "https://sourceforge.net/p/libwpd/wiki/libodfgen/")
     (synopsis "ODF (Open Document Format) library")
     (description "Libodfgen is a library for generating documents in the
 Open Document Format (ODF).  It provides generator implementations for all
@@ -511,14 +573,14 @@ text documents, vector drawings, presentations and spreadsheets.")
 (define-public libmwaw
   (package
     (name "libmwaw")
-    (version "0.3.4")
+    (version "0.3.5")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "mirror://sourceforge/" name "/" name "/"
-                          name "-" version ".tar.xz"))
+      (uri (string-append "mirror://sourceforge/" name "/" name "/" name "-"
+                          version "/" name "-" version ".tar.xz"))
       (sha256 (base32
-               "1sn95flxrh85qjsg1kk700c1ggxaaccr9j1nnw7x4daw8lky25ac"))))
+               "1vx9h419fcfcs0yj071hsg9d2qvkacgca6052m8hv3h743cdmzil"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("doxygen" ,doxygen)
@@ -531,7 +593,7 @@ text documents, vector drawings, presentations and spreadsheets.")
     (arguments
      ;; avoid triggering configure errors by simple inclusion of boost headers
      `(#:configure-flags '("--disable-werror")))
-    (home-page "http://sourceforge.net/p/libmwaw/wiki/Home/")
+    (home-page "https://sourceforge.net/p/libmwaw/wiki/Home/")
     (synopsis "Import library for some old Macintosh text documents")
     (description "Libmwaw contains some import filters for old Macintosh
 text documents (MacWrite, ClarisWorks, ... ) and for some graphics and
@@ -541,14 +603,14 @@ spreadsheet documents.")
 (define-public libwps
   (package
     (name "libwps")
-    (version "0.3.1")
+    (version "0.4.0")
     (source
      (origin
       (method url-fetch)
       (uri (string-append "mirror://sourceforge/" name "/" name "/"
-                          name "-" version ".tar.xz"))
+                          name "-" version "/" name "-" version ".tar.xz"))
       (sha256 (base32
-               "14wfhw1ahavhx4hrdzc4hdwxjlffrm939kswf2x1250jnmyjlb5v"))))
+               "0nlrdk7di015l0sk0ivjdqs86zdcvf73p9z9s9ry5glyhrknzxjk"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("doxygen" ,doxygen)
@@ -570,21 +632,24 @@ Works word processor file format.")
 (define-public hunspell
   (package
     (name "hunspell")
-    (version "1.3.3")
+    (version "1.5.4")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "mirror://sourceforge/" name "/"
-                          name "-" version ".tar.gz"))
+      (uri (string-append "https://github.com/hunspell/hunspell/archive/v"
+                          version ".tar.gz"))
       (sha256 (base32
-               "0v14ff9s37vkh45diaddndcrj0hmn67arh8xh8k79q9c1vgc1cm7"))))
+               "0ngwk18dwd8p5a5f20h2jlgrz9wbc1k189mmmprb2zmqwfi02b45"))
+      (file-name (string-append name "-" version ".tar.gz"))))
     (build-system gnu-build-system)
+    (inputs
+     `(("perl" ,perl)))
     (home-page "http://hunspell.sourceforge.net/")
     (synopsis "Spell checker")
     (description "Hunspell is a spell checker and morphological analyzer
 library and program designed for languages with rich morphology and complex
 word compounding or character encoding.")
-    ;; triple license, including "mpl1.1 or later"
+    ;; Triple license, including "mpl1.1 or later".
     (license (list mpl1.1 gpl2+ lgpl2.1+))))
 
 (define-public hyphen
@@ -594,7 +659,8 @@ word compounding or character encoding.")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "mirror://sourceforge/hunspell/"
+      (uri (string-append "mirror://sourceforge/hunspell/Hyphen/"
+                          (version-major+minor version) "/"
                           name "-" version ".tar.gz"))
       (sha256 (base32
                "01ap9pr6zzzbp4ky0vy7i1983fwyqy27pl0ld55s30fdxka3ciih"))))
@@ -615,7 +681,7 @@ patterns, which are pre-processed by a perl script.")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "mirror://sourceforge/hunspell/"
+      (uri (string-append "mirror://sourceforge/hunspell/MyThes/" version "/"
                           name "-" version ".tar.gz"))
       (sha256 (base32
                "0prh19wy1c74kmzkkavm9qslk99gz8h8wmjvwzjc6lf8v2az708y"))))
@@ -629,6 +695,177 @@ patterns, which are pre-processed by a perl script.")
     (synopsis "Thesaurus")
     (description "MyThes is a simple thesaurus that uses a structured text
 data file and an index file with binary search to look up words and phrases
-and to return information on pronunciations, meaningss and synonyms.")
+and to return information on pronunciations, meanings and synonyms.")
     (license (non-copyleft "file://COPYING"
                            "See COPYING in the distribution."))))
+
+;; LibreOffice requires an xmlsec source tarball; it does not even check
+;; for the presence of an externally compiled library.
+(define xmlsec-src-libreoffice
+  (origin
+    (method url-fetch)
+    (uri
+      (string-append
+        "http://dev-www.libreoffice.org/src/"
+        "1f24ab1d39f4a51faf22244c94a6203f-xmlsec1-1.2.14.tar.gz"))
+    (sha256 (base32
+              "0jnxxygg6z5zi6za94dvxmg1bfar1wh8p5xa2bzbha0qcn2m02ir"))))
+
+(define-public libreoffice
+  (package
+    (name "libreoffice")
+    (version "5.1.6.2")
+    (source
+     (origin
+      (method url-fetch)
+      (uri
+        (string-append
+          "http://download.documentfoundation.org/libreoffice/src/"
+          (version-prefix version 3) "/libreoffice-" version ".tar.xz"))
+      (sha256 (base32
+               "150xb76pc3889gfy4jrnq8sidymm1aihkm5pzy8b1fdy51zip804"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(;; autoreconf is run by the LibreOffice build system, since after
+       ;; unpacking the external xmlsec tarball, it applies a series of
+       ;; patches to Makefile.am, configure.in, config.guess and config.sub.
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("bison" ,bison)
+       ("cppunit" ,cppunit)
+       ("flex" ,flex)
+       ("pkg-config" ,pkg-config)
+       ("python" ,python-wrapper)
+       ("which" ,which)))
+    (inputs
+     `(("bluez" ,bluez)
+       ("boost" ,boost)
+       ("clucene" ,clucene)
+       ("cups" ,cups)
+       ("dbus-glib" ,dbus-glib)
+       ("fontconfig" ,fontconfig)
+       ("gconf" ,gconf)
+       ("glew" ,glew)
+       ("glm" ,glm)
+       ("gperf" ,gperf)
+       ("graphite2" ,graphite2)
+       ("gst-plugins-base" ,gst-plugins-base)
+       ("gtk+" ,gtk+-2)
+       ("harfbuzz" ,harfbuzz)
+       ("hunspell" ,hunspell)
+       ("hyphen" ,hyphen)
+       ("libabw" ,libabw)
+       ("libcdr" ,libcdr)
+       ("libcmis" ,libcmis)
+       ("libjpeg" ,libjpeg)
+       ("libe-book" ,libe-book)
+       ("libetonyek" ,libetonyek)
+       ("libexttextcat" ,libexttextcat)
+       ("libfreehand" ,libfreehand)
+       ("libmspub" ,libmspub)
+       ("libmwaw" ,libmwaw)
+       ("libodfgen" ,libodfgen)
+       ("libpagemaker" ,libpagemaker)
+       ("libvisio" ,libvisio)
+       ("libwpg" ,libwpg)
+       ("libwps" ,libwps)
+       ("libxrandr" ,libxrandr)
+       ("libxrender" ,libxrender)
+       ("libxslt" ,libxslt)
+       ("libxt" ,libxt)
+       ("lpsolve" ,lpsolve)
+       ("mdds" ,mdds)
+       ("mythes" ,mythes)
+       ("neon" ,neon)
+       ("nspr" ,nspr)
+       ("nss" ,nss)
+       ("openldap" ,openldap)
+       ("openssl" ,openssl)
+       ("orcus" ,orcus)
+       ("perl" ,perl)
+       ("perl-zip" ,perl-zip)
+       ("poppler" ,poppler)
+       ("postgresql" ,postgresql)
+       ("python" ,python)
+       ("redland" ,redland)
+       ("sane-backends" ,sane-backends)
+       ("unixodbc" ,unixodbc)
+       ("unzip" ,unzip)
+       ("vigra" ,vigra)
+       ("xmlsec-src" ,xmlsec-src-libreoffice)
+       ("zip" ,zip)))
+    (arguments
+     `(#:tests? #f ; Building the tests already fails.
+       #:make-flags '("build-nocheck") ; Do not build unit tests, which fails.
+       #:phases
+         (modify-phases %standard-phases
+           (add-before 'configure 'prepare-src
+             (lambda* (#:key inputs #:allow-other-keys)
+               (let ((xmlsec (assoc-ref inputs "xmlsec-src")))
+                 (substitute*
+                   (list "sysui/CustomTarget_share.mk"
+                         "solenv/gbuild/gbuild.mk"
+                         "solenv/gbuild/platform/unxgcc.mk"
+                         "external/libxmlsec/xmlsec1-oldlibtool.patch")
+                   (("/bin/sh") (which "bash")))
+                 (mkdir "external/tarballs")
+                 (symlink
+                   xmlsec
+                   (string-append "external/tarballs/"
+                     "1f24ab1d39f4a51faf22244c94a6203f-"
+                     "xmlsec1-1.2.14.tar.gz"))
+                 ;; The following is required for building xmlsec from the
+                 ;; unpatched external tarball; since "configure" starts with
+                 ;; "/bin/sh", it needs to be executed by a command invoking
+                 ;; the shell.
+                 (setenv "SHELL" (which "bash"))
+                 (setenv "CONFIG_SHELL" (which "bash"))
+                 (substitute* "external/libxmlsec/ExternalProject_xmlsec.mk"
+                   (("./configure") "$(CONFIG_SHELL) ./configure" ))
+                 #t)))
+           (add-after 'install 'bin-install
+             ;; Create 'soffice' and 'libreoffice' symlinks to the executable
+             ;; script.
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out (assoc-ref outputs "out"))
+                      (bin (string-append out "/bin"))
+                      (soffice (string-append
+                                out "/lib/libreoffice/program/soffice")))
+                 (mkdir bin)
+                 (symlink soffice (string-append bin "/soffice"))
+                 (symlink soffice (string-append bin "/libreoffice")))
+               #t)))
+       #:configure-flags
+        (list
+          "--enable-release-build"
+          "--enable-verbose"
+          "--without-parallelism" ; otherwise the build fails
+          "--disable-fetch-external" ; disable downloads
+          "--with-system-libs" ; enable all --with-system-* flags
+          (string-append "--with-boost-libdir="
+                         (assoc-ref %build-inputs "boost") "/lib")
+          ;; Avoid undefined symbols required by boost::spirit
+          "LDFLAGS=-lboost_system"
+          ;; Avoid a dependency on ucpp.
+          "--with-idlc-cpp=cpp"
+          ;; The fonts require an external tarball (crosextrafonts).
+          ;; They should not be needed when system fonts are available.
+          "--without-fonts"
+          ;; With java, the build fails since sac.jar is missing.
+          "--without-java"
+          ;; FIXME: Enable once the corresponding inputs are packaged.
+          "--without-system-npapi-headers"
+          "--disable-coinmp"
+          "--disable-firebird-sdbc" ; embedded firebird
+          "--disable-gltf"
+          "--without-doxygen"
+          "--disable-gtk3"
+          "--disable-liblangtag")))
+    (home-page "https://www.libreoffice.org/")
+    (synopsis "Office suite")
+    (description "LibreOffice is a comprehensive office suite.  It contains
+a number of components: Writer, a word processor; Calc, a spreadsheet
+application; Impress, a presentation engine; Draw, a drawing and
+flowcharting application; Base, a database and database frontend;
+Math for editing mathematics.")
+    (license mpl2.0)))