gnu: Remove cmake/fixed.
[jackhill/guix/guix.git] / gnu / packages / ccache.scm
index 5c12145..b3f0cbb 100644 (file)
@@ -1,7 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015, 2016, 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public ccache
   (package
     (name "ccache")
-    (version "3.4")
+    (version "3.6")
     (source
      (origin
-      (method url-fetch)
-      (uri (string-append "https://www.samba.org/ftp/ccache/ccache-"
-                          version ".tar.xz"))
-      (sha256
-       (base32
-        "0sfisvjs2iham29flxgmnfg7kzqz66bhk6q0qcwbdv1n569say5j"))))
+       (method url-fetch)
+       (uri (string-append "https://www.samba.org/ftp/ccache/ccache-"
+                           version ".tar.xz"))
+       (sha256
+        (base32 "07wv75xdcxpdkfsz9h5ffrm8pjbvr1dh6wnb02nyzz18cdbjkcd6"))))
     (build-system gnu-build-system)
-    (native-inputs `(("perl" ,perl)     ;for test.sh
+    (native-inputs `(("perl" ,perl)     ; for test/run
                      ("which" ,(@ (gnu packages base) which))))
     (inputs `(("zlib" ,zlib)))
     (arguments
                    (lambda _
                      (substitute* '("unittest/test_hashutil.c" "test/suites/base.bash")
                        (("#!/bin/sh") (string-append "#!" (which "sh"))))
-                     #t))
-                 (add-before 'check 'munge-failing-test
-                   (lambda _
-                     ;; XXX The new ‘Multiple -fdebug-prefix-map’ test added in
-                     ;; 3.3.5 fails (why?).  Force it to report success instead.
-                     (substitute* "test/suites/debug_prefix_map.bash"
-                       (("grep \"name\"") "true"))
                      #t)))))
     (home-page "https://ccache.samba.org/")
     (synopsis "Compiler cache")