Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / gnome.scm
index 89984c5..e94779c 100644 (file)
@@ -2121,7 +2121,15 @@ editors, IDEs, etc.")
   (package
     (inherit vte)
     (name "vte-ng")
-    (version "0.52.2.a")
+    (version "0.54.2.a")
+    (home-page "https://github.com/thestinger/vte-ng")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference (url home-page) (commit version)))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1r7d9m07cpdr4f7rw3yx33hmp4jmsk0dn5byq5wgksb2qjbc4ags"))))
     (native-inputs
      `(("gtk-doc" ,gtk-doc)
        ("gperf" ,gperf)
@@ -2129,14 +2137,6 @@ editors, IDEs, etc.")
        ("automake" ,automake)
        ("libtool" ,libtool)
        ,@(package-native-inputs vte)))
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/thestinger/"
-                                  name "/archive/" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
-              (sha256
-               (base32
-                "1fd65mk7c87k03vhnb2ixkjvv9nja04mfq813iyjji1b11f2sh7v"))))
     (arguments
      `(#:phases (modify-phases %standard-phases
                   (replace 'bootstrap