gnu: dealii: Update to 8.5.0.
[jackhill/guix/guix.git] / gnu / packages / kerberos.scm
index b6d25f4..59fd944 100644 (file)
@@ -42,7 +42,7 @@
 (define-public mit-krb5
   (package
     (name "mit-krb5")
-    (version "1.14.3")
+    (version "1.14.4")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://web.mit.edu/kerberos/dist/krb5/"
@@ -50,7 +50,7 @@
                                   "/krb5-" version ".tar.gz"))
               (sha256
                (base32
-                "1jgjiyh1sp72lkxvk437lz5hzcibvw99jc4ihzfz03fg43aj0ind"))))
+                "158bgq9xcg5ljgzia1880ak7m9g6vf2r009rzdqif5n9h111m9h3"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("bison" ,bison)
@@ -78,7 +78,7 @@
              (let ((perl (assoc-ref inputs "perl")))
                (substitute* "plugins/kdb/db2/libdb2/test/run.test"
                  (("/bin/cat") (string-append perl "/bin/perl"))
-                 (("D/bin/sh") (string-append "D" (which "bash")))
+                 (("D/bin/sh") (string-append "D" (which "sh")))
                  (("bindir=/bin/.") (string-append "bindir=" perl "/bin"))))
 
              ;; avoid service names since /etc/services is unavailable
@@ -93,7 +93,8 @@ authentication for client/server applications by using secret-key
 cryptography.")
     (license (license:non-copyleft "file://NOTICE"
                                    "See NOTICE in the distribution."))
-    (home-page "http://web.mit.edu/kerberos/")))
+    (home-page "http://web.mit.edu/kerberos/")
+    (properties '((cpe-name . "kerberos")))))
 
 (define-public shishi
   (package
@@ -124,7 +125,7 @@ cryptography.")
        ;; #endif
        ("libgcrypt" ,libgcrypt-1.5)
        ("libtasn1" ,libtasn1)))
-    (home-page "http://www.gnu.org/software/shishi/")
+    (home-page "https://www.gnu.org/software/shishi/")
     (synopsis "Implementation of the Kerberos 5 network security system")
     (description
      "GNU Shishi is a free implementation of the Kerberos 5 network security
@@ -143,6 +144,8 @@ secure manner through client-server mutual authentication via tickets.")
               (sha256
                (base32
                 "19gypf9vzfrs2bw231qljfl4cqc1riyg0ai0xmm1nd1wngnpphma"))
+              (patches (search-patches "heimdal-CVE-2017-6594.patch"
+                                       "heimdal-CVE-2017-11103.patch"))
               (modules '((guix build utils)))
               (snippet
                '(substitute* "configure"