gnu: Add ronn-ng
[jackhill/guix/guix.git] / gnu / packages / re2c.scm
index c7f2966..427195f 100644 (file)
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017 Sergei Trofimovich <slyfox@inbox.ru>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 (define-public re2c
   (package
     (name "re2c")
-    (version "0.16")
+    (version "1.2.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://github.com/skvadrik/" name
                                  "/releases/download/" version "/"
-                                 name "-" version ".tar.gz"))
+                                 name "-" version ".tar.xz"))
              (sha256
               (base32
-               "114y0s4vmzip4hkf4cbz4yv8s498gzaylnphbzmwqhbn55j2bha8"))))
+               "05xq0571mkgr20v827jm63nhsirr8arghg4fszzswrmrnl3dfk0s"))))
     (build-system gnu-build-system)
-    (home-page "http://re2c.org/")
+    (home-page "https://re2c.org/")
     (synopsis "Lexer generator for C/C++")
     (description
      "@code{re2c} generates minimalistic hard-coded state machine (as opposed