gnu: Update harfbuzz to 0.9.20.
[jackhill/guix/guix.git] / gnu / packages / make-bootstrap.scm
index 7eb3567..ce270bd 100644 (file)
@@ -127,7 +127,10 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                       ;; cross-compiling).
                       (inputs (match (assoc "perl" (package-inputs coreutils))
                                 (#f '())
-                                (x  (list x))))))
+                                (x  (list x))))
+
+                      ;; Remove the `debug' output.
+                      (outputs '("out"))))
         (bzip2 (package (inherit bzip2)
                  (arguments
                   (substitute-keyword-arguments (package-arguments bzip2)
@@ -451,6 +454,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
   ;; than in hard-coded configure-time paths.
   (let* ((guile (package (inherit guile-2.0)
                   (name (string-append (package-name guile-2.0) "-static"))
+                  (synopsis "Statically-linked and relocatable Guile")
                   (inputs
                    `(("patch/relocatable"
                       ,(search-patch "guile-relocatable.patch"))
@@ -542,7 +546,8 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
                        #t
                        '(zero? (system* guile2 "--version")))))))))
     (inputs `(("guile" ,%guile-static)))
-    (outputs '("out"))))
+    (outputs '("out"))
+    (synopsis "Minimal statically-linked and relocatable Guile")))
 
 (define (tarball-package pkg)
   "Return a package containing a tarball of PKG."