gnu: monero-gui: Update to 0.16.0.2.
[jackhill/guix/guix.git] / gnu / packages / bison.scm
index eae8673..725f382 100644 (file)
@@ -2,6 +2,7 @@
 ;;; Copyright © 2012, 2013, 2015, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -31,7 +32,7 @@
 (define-public bison
   (package
     (name "bison")
-    (version "3.5")
+    (version "3.5.3")
     (source
      (origin
       (method url-fetch)
@@ -39,7 +40,7 @@
                           version ".tar.xz"))
       (sha256
        (base32
-        "0hd6lgkxb9i46alcwn87jygs53q4vkq7k0jzb84ikbdln4is1r2m"))))
+        "1i57hbczvr8674z73775jxdd3y59qggs5lmfd60gmwm5i1gmpy1b"))))
     (build-system gnu-build-system)
     (arguments
      '(;; Building in parallel on many-core systems may cause an error such as
@@ -64,6 +65,17 @@ grammar.  It is versatile enough to have many applications, from parsers for
 simple tools through complex programming languages.")
     (license gpl3+)))
 
+(define-public bison-3.6
+  (package
+    (inherit bison)
+    (version "3.6.3")
+    (source
+     (origin
+      (method url-fetch)
+      (uri (string-append "mirror://gnu/bison/bison-" version ".tar.xz"))
+      (sha256
+       (base32 "0gdpnjh6ra9xa9vj6hzjdf0c04x4pjyy8vssm3qdb7fya4v7knq6"))))))
+
 (define-public bison-3.0
   (package
     (inherit bison)