gnu: Add cl-ana.statistical-learning.
[jackhill/guix/guix.git] / gnu / packages / cpp.scm
index f30da0e..ae1e3e3 100644 (file)
@@ -6,7 +6,6 @@
 ;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2019 Pierre Neidhardt <mail@ambrevar.xyz>
 ;;; Copyright © 2019 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
-;;; Copyright © 2019 Brett Gilio <brettg@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,9 +35,7 @@
   #:use-module (gnu packages check)
   #:use-module (gnu packages code)
   #:use-module (gnu packages compression)
-  #:use-module (gnu packages gcc)
   #:use-module (gnu packages llvm)
-  #:use-module (gnu packages ncurses)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages tls)
@@ -188,7 +185,7 @@ batches.")
                 (modules '((guix build utils)))
                 (snippet '(delete-file-recursively "./test/thirdparty"))))
       (native-inputs
-       `(("catch2" ,catch-framework2)))
+       `(("catch2" ,catch-framework2-1)))
       (build-system cmake-build-system)
       (arguments
        `(#:phases
@@ -308,17 +305,12 @@ tools (containers, algorithms) used by other QuantStack packages.")
        (file-name (git-file-name name version))))
     (build-system cmake-build-system)
     (arguments
-     `(#:tests? #f ; no check target.
-       #:configure-flags
-       (list (string-append "-DCMAKE_CXX_FLAGS='-isystem "
-                            (assoc-ref %build-inputs "gcc")
-                            "/include/c++'"))))
+     '(#:tests? #f)) ; no check target.
     (inputs
-     `(("clang" ,clang)
-       ("ncurses" ,ncurses)))
+     `(("rapidjson" ,rapidjson)))
     (native-inputs
-     `(("rapidjson" ,rapidjson)
-       ("gcc" ,gcc)))
+     `(("clang" ,clang)
+       ("llvm" ,llvm)))
     (home-page "https://github.com/MaskRay/ccls")
     (synopsis "C/C++/Objective-C language server")
     (description