Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / qt.scm
index 04e6a38..309fcc4 100644 (file)
@@ -7,7 +7,7 @@
 ;;; Copyright © 2016 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
 ;;; Copyright © 2017 Quiliro <quiliro@fsfla.org>
-;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2018 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -372,16 +372,16 @@ developers using C++ or QML, a CSS & JavaScript like language.")
 (define-public qtbase
   (package
     (name "qtbase")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1kq422vb2zaic099pgzwk7c0qzgc3xap6qahw5vklrq0mgivvrk9"))
+               "0rny87ypnkkvyp9p76nim77v6np0cdf1dbjfmcilklzphkdlcvpd"))
              ;; Use TZDIR to avoid depending on package "tzdata".
              (patches (search-patches "qtbase-use-TZDIR.patch"))
              (modules '((guix build utils)))
@@ -392,7 +392,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
                   (lambda (dir)
                     (delete-file-recursively (string-append "src/3rdparty/" dir)))
                   (list "double-conversion" "freetype" "harfbuzz-ng"
-                        "libpng" "libjpeg" "pcre2" "sqlite" "xcb"
+                        "libpng" "libjpeg" "pcre2" "xcb"
                         "xkbcommon" "zlib"))
                 #t))))
     (build-system gnu-build-system)
@@ -434,7 +434,7 @@ developers using C++ or QML, a CSS & JavaScript like language.")
        ("pcre2" ,pcre2)
        ("postgresql" ,postgresql)
        ("pulseaudio" ,pulseaudio)
-       ("sqlite" ,sqlite)
+       ;("sqlite" ,sqlite)
        ("unixodbc" ,unixodbc)
        ("xcb-util" ,xcb-util)
        ("xcb-util-image" ,xcb-util-image)
@@ -477,42 +477,45 @@ developers using C++ or QML, a CSS & JavaScript like language.")
                  (("NO_DEFAULT_PATH") ""))
                ;; do not pass "--enable-fast-install", which makes the
                ;; configure process fail
-               (zero? (system*
-                       "./configure"
-                       "-verbose"
-                       "-prefix" out
-                       "-docdir" (string-append out "/share/doc/qt5")
-                       "-headerdir" (string-append out "/include/qt5")
-                       "-archdatadir" (string-append out "/lib/qt5")
-                       "-datadir" (string-append out "/share/qt5")
-                       "-examplesdir" (string-append
-                                       out "/share/doc/qt5/examples")
-                       "-opensource"
-                       "-confirm-license"
-                       ;; Do not build examples; if desired, these could go
-                       ;; into a separate output, but for the time being, we
-                       ;; prefer to save the space and build time.
-                       "-no-compile-examples"
-                       ;; Most "-system-..." are automatic, but some use
-                       ;; the bundled copy by default.
-                       "-system-sqlite"
-                       "-system-harfbuzz"
-                       "-system-pcre"
-                       ;; explicitly link with openssl instead of dlopening it
-                       "-openssl-linked"
-                       ;; explicitly link with dbus instead of dlopening it
-                       "-dbus-linked"
-                       ;; don't use the precompiled headers
-                       "-no-pch"
-                       ;; drop special machine instructions that do not have
-                       ;; runtime detection
-                       ,@(if (string-prefix? "x86_64"
-                                             (or (%current-target-system)
-                                                 (%current-system)))
-                             '()
-                             '("-no-sse2"))
-                       "-no-mips_dsp"
-                       "-no-mips_dspr2")))))
+               (invoke
+                 "./configure"
+                 "-verbose"
+                 "-prefix" out
+                 "-docdir" (string-append out "/share/doc/qt5")
+                 "-headerdir" (string-append out "/include/qt5")
+                 "-archdatadir" (string-append out "/lib/qt5")
+                 "-datadir" (string-append out "/share/qt5")
+                 "-examplesdir" (string-append
+                                  out "/share/doc/qt5/examples")
+                 "-opensource"
+                 "-confirm-license"
+                 ;; Do not build examples; if desired, these could go
+                 ;; into a separate output, but for the time being, we
+                 ;; prefer to save the space and build time.
+                 "-no-compile-examples"
+                 ;; Most "-system-..." are automatic, but some use
+                 ;; the bundled copy by default.
+                 ;; System sqlite fails on 5.10+
+                 ;;.obj/qsql_sqlite.o: In function `QSQLiteResultPrivate::initColumns(bool)':
+                 ;;qsql_sqlite.cpp:(.text+0x190c): undefined reference to `sqlite3_column_table_name16'
+                 ;"-system-sqlite"
+                 "-system-harfbuzz"
+                 "-system-pcre"
+                 ;; explicitly link with openssl instead of dlopening it
+                 "-openssl-linked"
+                 ;; explicitly link with dbus instead of dlopening it
+                 "-dbus-linked"
+                 ;; don't use the precompiled headers
+                 "-no-pch"
+                 ;; drop special machine instructions that do not have
+                 ;; runtime detection
+                 ,@(if (string-prefix? "x86_64"
+                                       (or (%current-target-system)
+                                           (%current-system)))
+                     '()
+                     '("-no-sse2"))
+                 "-no-mips_dsp"
+                 "-no-mips_dspr2"))))
          (add-after 'install 'patch-mkspecs
            (lambda* (#:key outputs #:allow-other-keys)
              (let* ((out (assoc-ref outputs "out"))
@@ -602,16 +605,16 @@ developers using C++ or QML, a CSS & JavaScript like language.")
 (define-public qtsvg
   (package (inherit qtbase)
     (name "qtsvg")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0yh3an9rc7fh013cw3bm318ap6428icsmnj38hhg1w6lpwr2gwm2"))))
+               "0m0zglp0m5gv75ivma6l3hm8brb0cf44dhbc6lqwfdwacxhgx3jb"))))
     (propagated-inputs `())
     (native-inputs `(("perl" ,perl)))
     (inputs
@@ -664,7 +667,7 @@ HostData=lib/qt5
            (lambda* (#:key inputs outputs #:allow-other-keys)
              ;; Valid QT_BUILD_PARTS variables are:
              ;; libs tools tests examples demos docs translations
-             (zero? (system* "qmake" "QT_BUILD_PARTS = libs tools tests"))))
+             (invoke "qmake" "QT_BUILD_PARTS = libs tools tests")))
          (add-before 'check 'set-display
            (lambda _
              ;; make Qt render "offscreen", required for tests
@@ -677,19 +680,21 @@ HostData=lib/qt5
 (define-public qtimageformats
   (package (inherit qtsvg)
     (name "qtimageformats")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1nfxvf96wh1smdmcsk4m9f7zg69fgp844f8772qpv6v4m20p1qb9"))
+               "0w0yy7zzln3v7dm7ksjxkzhq8r0a9nwk823wv4f1x7vsa3pnyh2q"))
              (modules '((guix build utils)))
-             (snippet '(begin (delete-file-recursively "src/3rdparty")
-                              #t))))
+             (snippet
+              '(begin
+                 (delete-file-recursively "src/3rdparty")
+                 #t))))
     (native-inputs `())
     (inputs
      `(("jasper" ,jasper)
@@ -706,16 +711,16 @@ support for MNG, TGA, TIFF and WBMP image formats.")))
 (define-public qtx11extras
   (package (inherit qtsvg)
     (name "qtx11extras")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1a125fi7lbxfps207i12jammm4cjbiawmp4sqa3bxqah8p21i6w7"))))
+               "13vbx61wcd8pnpgk3j5r665pm03s7jp2s98apvc6fhp1njlr0rhi"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -730,16 +735,16 @@ from within Qt 5.")))
 (define-public qtxmlpatterns
   (package (inherit qtsvg)
     (name "qtxmlpatterns")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0ybz0i3wblvrm958s9ykp3a79bakjbb7k74q71mqaaswkv9imxgs"))))
+               "13nj2pa706sy874bqbv7y94ypicr4k09x6n2jyxkw93flb5pi8qr"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:phases phases)
@@ -759,16 +764,16 @@ xmlpatternsvalidator.")))
 (define-public qtdeclarative
   (package (inherit qtsvg)
     (name "qtdeclarative")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0r9dhfc6qmxlzn2v9r6z6n2mcq6pv1nmyh91g9hcdlkx40xqlqyw"))))
+               "1h2pbyr7dnak4q96373xpa6gk6rl528rnqima8xnvhdi2y5kgagf"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -791,27 +796,16 @@ with JavaScript and C++.")))
 (define-public qtconnectivity
   (package (inherit qtsvg)
     (name "qtconnectivity")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "12qckqz6ldvn1czkkigadmgl07yk4gs74hy4ifh4hmpm7cv519yv"))))
-    (arguments
-     (substitute-keyword-arguments (package-arguments qtsvg)
-       ((#:phases phases)
-        `(modify-phases ,phases
-           (add-after 'unpack 'disable-failing-tests
-             ;; this test fails on armhf and aarch64
-             (lambda _
-               (substitute* "tests/auto/qndefnfcsmartposterrecord/tst_qndefnfcsmartposterrecord.cpp"
-                 (("QCOMPARE\\(record.action\\(\\), QNdefNfcSmartPosterRecord::UnspecifiedAction")
-                 "//QCOMPARE(record.action(), QNdefNfcSmartPosterRecord::UnspecifiedAction"))
-               #t))))))
+               "0wqq5q5saf007aphvpn5pvj6l0qp0z7wxvfba6v9iq5ylyqm6bnd"))))
     (native-inputs
      `(("perl" ,perl)
        ("pkg-config" ,pkg-config)
@@ -826,16 +820,16 @@ with Bluetooth and NFC.")))
 (define-public qtwebsockets
   (package (inherit qtsvg)
     (name "qtwebsockets")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "00786d9m8skj68n5x9d8151zmmskx7ckhgcdd08hs9nly04h55vj"))))
+               "1drr6nxxbkwpmz39bhyfmmsqjhy11bj3w1nc3q9dwhpcbf04an3x"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -853,16 +847,16 @@ consume data received from the server, or both.")))
 (define-public qtsensors
   (package (inherit qtsvg)
     (name "qtsensors")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0n6lkkn7c9x8vcplmfvkx7jq6najh2mrwnfb3blrmkmpash3lgvr"))))
+               "1az22rdkpc1m44qb3dyh7cpiprplkvynzjr629ai05i8ngbfdi0g"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:parallel-tests? _ #f) #f) ; can lead to race condition
@@ -886,16 +880,16 @@ recognition API for devices.")))
 (define-public qtmultimedia
   (package (inherit qtsvg)
     (name "qtmultimedia")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0x2f3vpax7rq0lxnncbp5b248bxdicrwn8hv4hsas2g2283s0lj9"))
+               "0g4x1w251imq58zp1px6yschwj6icsxzwl3fy7pjfbgd27qjhlzg"))
              (modules '((guix build utils)))
              (snippet
               '(begin
@@ -912,9 +906,9 @@ recognition API for devices.")))
            (replace 'configure
              (lambda* (#:key outputs #:allow-other-keys)
                (let ((out (assoc-ref outputs "out")))
-                 (zero? (system* "qmake" "QT_BUILD_PARTS = libs tools tests"
-                                 (string-append "QMAKE_LFLAGS_RPATH=-Wl,-rpath," out "/lib -Wl,-rpath,")
-                                 (string-append "PREFIX=" out))))))))
+                 (invoke "qmake" "QT_BUILD_PARTS = libs tools tests"
+                         (string-append "QMAKE_LFLAGS_RPATH=-Wl,-rpath," out "/lib -Wl,-rpath,")
+                         (string-append "PREFIX=" out)))))))
        ((#:tests? _ #f) #f)))           ; TODO: Enable the tests
     (native-inputs
      `(("perl" ,perl)
@@ -937,21 +931,22 @@ set of plugins for interacting with pulseaudio and GStreamer.")))
 (define-public qtwayland
   (package (inherit qtsvg)
     (name "qtwayland")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0x4q17k23akf14i3pyllr96s8lvprk1x006wp0mi5rhk4199cx1z"))
+               "09s1ckqj0cgjmmi7jylsf039vgzlq7i9rr4swb590fkz427lx0b8"))
              (modules '((guix build utils)))
              (snippet
                ;; The examples try to build and cause the build to fail
-              '(begin (delete-file-recursively "examples")
-                      #t))))
+              '(begin
+                 (delete-file-recursively "examples")
+                 #t))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:phases phases)
@@ -988,16 +983,16 @@ compositor libraries.")))
 (define-public qtserialport
   (package (inherit qtsvg)
     (name "qtserialport")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "172i5cpqnk0c3m0hg08hgj15qvsyd1xvw9yf2dqicg3l10lqwg8c"))))
+               "1cbf1jsginp5p3y17cyb6dfhsafxal0bn9pya6aybz0q799zgvl5"))))
     (native-inputs `(("perl" ,perl)))
     (inputs
      `(("qtbase" ,qtbase)
@@ -1022,16 +1017,16 @@ interacting with serial ports from within Qt.")))
 (define-public qtserialbus
   (package (inherit qtsvg)
     (name "qtserialbus")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1i6b7w9z30mzzi0dcmrxx1scpzpnnw2fag1igvrnzvw1jwp414ff"))))
+               "0r3crk7gw0xs6wk1gvw2k8r9s9vam3sfwrji1njhswavii9fbp85"))))
     (inputs
      `(("qtbase" ,qtbase)
        ("qtserialport" ,qtserialport)))
@@ -1043,16 +1038,16 @@ and others.")))
 (define-public qtwebchannel
   (package (inherit qtsvg)
     (name "qtwebchannel")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1acs0fa5rxm3cir0lydc9a8685qagf1786vkssv51wk3v9r3lc4h"))))
+               "05fa5pwvk24cjp8m6pbw3ma95vnls762crpjdgvygfk0h8xilxmh"))))
     (native-inputs
      `(("perl" ,perl)
        ("qtdeclarative" ,qtdeclarative)
@@ -1067,16 +1062,16 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
 (define-public qtlocation
   (package (inherit qtsvg)
     (name "qtlocation")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "186jzv19v674n8jmm13v5xwv211lygih5657rlvbhc1s4jq6iv9p"))))
+               "074cjqhr14mqlsqj9rzagzdcqnayyichp31lq02k05q07wg93xi8"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1097,16 +1092,16 @@ positioning and geolocation plugins.")))
 (define-public qttools
   (package (inherit qtsvg)
     (name "qttools")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "11vfk6c8snsqwqj1xk53c0h2mkqr4gfa9kinp8py56x7sn15galm"))))
+               "1nb77bfs63nyy0wkhsci9qbqmahncy3sdcrwj4qr1prc4y2cm4wx"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1124,16 +1119,16 @@ that helps in Qt development.")))
 (define-public qtscript
   (package (inherit qtsvg)
     (name "qtscript")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0lz0iv1baah7cxrpyiqzqp4fxxf75i21qd06ha7r5d80hq3xlia0"))
+               "1ib8a5gsxarbm2j94j5d097ly3ap4snqkx2imz3sl6xk6gknm4i5"))
              (patches (search-patches "qtscript-disable-tests.patch"))))
     (native-inputs
      `(("perl" ,perl)
@@ -1148,16 +1143,16 @@ ECMAScript and Qt.")))
 (define-public qtquickcontrols
   (package (inherit qtsvg)
     (name "qtquickcontrols")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "12yrmv6afjbd1fw3r8zjdrbq5l7cy7k5bxcyiv1m97gykfh0b8hn"))))
+               "01ziibf4afdhb5b3gfci8maprmviqwhdvma2z1jlq2ck45cpsqi6"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1172,16 +1167,16 @@ can be used to build complete interfaces in Qt Quick.")))
 (define-public qtquickcontrols2
   (package (inherit qtsvg)
     (name "qtquickcontrols2")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0334ayansm743kf113rs3k9hi9qb6giscfx9xig3y1z7asisfa0m"))))
+               "1hsa8n4dlqpyz9xq2kq1hsxrxsjc7ywzzfhqijylgzzclvlqgb7y"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1197,16 +1192,16 @@ not available.")))
 (define-public qtgraphicaleffects
   (package (inherit qtsvg)
     (name "qtgraphicaleffects")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1vxq4j7cb5cya1g234rxhfb361n45gp8c70gj8pc03njswkm7xwp"))))
+               "0xzr4421w7idlgndxnd68wwc2asabycjiskkyl1f8nwqv34lcy3j"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1230,15 +1225,16 @@ coloring, and many more.")))
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
                "0zwch9vn17f3bpy300jcfxx6cx9qymk5j7khx0x9k1xqid4166c3"))
              (modules '((guix build utils)))
              (snippet
-              '(begin (delete-file-recursively "tools/opengldummy/3rdparty")
-                      #t))))
+              '(begin
+                 (delete-file-recursively "tools/opengldummy/3rdparty")
+                 #t))))
     (native-inputs `())
     (inputs
      `(("qtbase" ,qtbase)
@@ -1251,16 +1247,16 @@ backend for QtQuick scene graph.")
 (define-public qtgamepad
   (package (inherit qtsvg)
     (name "qtgamepad")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1ci6aapq0i8qbzkn9xxvxn1n81z3y28yrlyzw0anqzj9qp97cl6f"))))
+               "0g52c03gdgz57h7szdxvc5hdy45l7q7m29yfzhwqc57hwdfl98bi"))))
     (native-inputs
      `(("perl" ,perl)
        ("pkg-config" ,pkg-config)))
@@ -1281,16 +1277,16 @@ and mobile applications targeting TV-like form factors.")))
 (define-public qtscxml
   (package (inherit qtsvg)
     (name "qtscxml")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0x8bjp9jzib4kfn7rbricw4qr259qqsdbrz0dw39453s2m7cbv0x"))
+               "00wb89ris8fyivhz9qpqn72mzpkh6mqdjss82j3q10g3c142072k"))
              (modules '((guix build utils)))
              (snippet
               '(begin
@@ -1312,16 +1308,16 @@ also contains functionality to support data models and executable content.")))
 (define-public qtpurchasing
   (package (inherit qtsvg)
     (name "qtpurchasing")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "08sk8vw16pa1qv36rfr9dsbzlwlv6kznfpsq8wfabhkgbfl6awqs"))))
+               "1c92yv2yi38sic06nyr9r6zpq3y4sxnasmj14d3jmg50gc1ncqfs"))))
     (inputs
      `(("qtbase" ,qtbase)
        ("qtdeclarative" ,qtdeclarative)))
@@ -1332,20 +1328,21 @@ purchasing goods and services.")))
 (define-public qtcanvas3d
   (package (inherit qtsvg)
     (name "qtcanvas3d")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0agdxgk7knf6zkjdi6316y2k9zq72wcg5zn3cbhw4hzjw81qadgg"))
+               "1kqcaks6lkz8cp9s3pwrvgrr8381rjzf5fbf2bzshdw7psphxiiz"))
              (modules '((guix build utils)))
              (snippet
-              '(begin (delete-file-recursively "examples/canvas3d/3rdparty")
-                      #t))))
+              '(begin
+                 (delete-file-recursively "examples/canvas3d/3rdparty")
+                 #t))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
       ;; Building the tests depends on the bundled 3rd party javascript files,
@@ -1356,8 +1353,8 @@ purchasing goods and services.")))
          (replace 'configure
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out")))
-               (zero? (system* "qmake" "QT_BUILD_PARTS = libs tools"
-                               (string-append "PREFIX=" out))))))))
+               (invoke "qmake" "QT_BUILD_PARTS = libs tools"
+                       (string-append "PREFIX=" out)))))))
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
     (native-inputs `())
     (inputs
@@ -1370,16 +1367,16 @@ drawing calls from Qt Quick JavaScript.")))
 (define-public qtcharts
   (package (inherit qtsvg)
     (name "qtcharts")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1rykb72gr95rxd0rvbl846ys8xvyyhrms1jz7l4hlwp6zn1jkxvm"))))
+               "0lg39vd6i0l76spjz6bhb1kkpbk2mgc0hxccj7733xxbxaz14vn4"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1397,16 +1394,16 @@ selecting one of the charts themes.")
 (define-public qtdatavis3d
   (package (inherit qtsvg)
     (name "qtdatavis3d")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1ggwfnqf17mp5dkfr82q1qrimkb6wv3304vl8mjv1nq0zisckhjv"))))
+               "1s7gmgh6g3aia74yiqahffrc6n8f4491vb7g3i4i10ilandipg34"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:tests? _ #f) #f))) ; TODO: Enable the tests
@@ -1424,16 +1421,16 @@ customized by using themes or by adding custom items and labels to them.")
 (define-public qtnetworkauth
   (package (inherit qtsvg)
     (name "qtnetworkauth")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "0mqcqkp9h5bgzb3wfy239wh1c9s9zxd7mww11c0jyp56wk5balcx"))))
+               "1kr8hwjsb8a5cypvqj48vrnkcvm2rcni102dh6i909i70a7hcsym"))))
     (arguments
      (substitute-keyword-arguments (package-arguments qtsvg)
        ((#:phases phases)
@@ -1453,16 +1450,26 @@ implementation of OAuth and OAuth2 authenticathon methods for Qt.")))
 (define-public qtremoteobjects
   (package (inherit qtsvg)
     (name "qtremoteobjects")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "1wb50dapv0l45c0rfmpiaddvwv9na50lmd5zmm052q9d1xb15f6b"))))
+               "1chn1xxhapfwvhrlv4chwfgf2dw8x8kn1lssdmpmg5s420z3pbq9"))))
+    (arguments
+     (substitute-keyword-arguments (package-arguments qtsvg)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (add-after 'unpack 'remove-failing-test
+             (lambda _
+               ;; This test can't find its imports.
+               (substitute* "tests/auto/qml/qml.pro"
+                 (("integration") "# integration"))
+               #t))))))
     (inputs
      `(("qtbase" ,qtbase)
        ("qtdeclarative" ,qtdeclarative)))
@@ -1475,16 +1482,16 @@ processes or computers.")))
 (define-public qtspeech
   (package (inherit qtsvg)
     (name "qtspeech")
-    (version "5.9.4")
+    (version "5.11.0")
     (source (origin
              (method url-fetch)
              (uri (string-append "https://download.qt.io/official_releases/qt/"
                                  (version-major+minor version) "/" version
-                                 "/submodules/" name "-opensource-src-"
+                                 "/submodules/" name "-everywhere-src-"
                                  version ".tar.xz"))
              (sha256
               (base32
-               "17h8hrixxcsn7pd5iipbj2hxpp5m2dhfq3w04wkamambb49qs80x"))))
+               "1bgfg0akqf1nfzm28n8dhvhj0p1niwxrfs763gj7m0g6vpwjbhd1"))))
     (inputs
      `(("qtbase" ,qtbase)))
     (native-inputs
@@ -1712,7 +1719,7 @@ contain over 620 classes.")
 (define-public qscintilla
   (package
     (name "qscintilla")
-    (version "2.10.2")
+    (version "2.10.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://sourceforge/pyqt/QScintilla2/"
@@ -1720,7 +1727,7 @@ contain over 620 classes.")
                                   version ".tar.gz"))
               (sha256
                (base32
-                "1l2ylsv6s3wfhyx7qr5cxgkwwwhvbrpd2k7akgm9bvbyf4h1vcql"))))
+                "1rw1nlwnyzj5pb86cc5kk56qhrvwvrjvjzgrkwh3g7b9wxl7lrfj"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases