gnu: Add Moose.
[jackhill/guix/guix.git] / gnu / packages / perl.scm
index dd9d483..44332fe 100644 (file)
@@ -374,6 +374,29 @@ CPAN::Meta object are present.")
      "Data::OptList provides a simple syntax for name/value option pairs.")
     (license (package-license perl))))
 
+(define-public perl-data-tumbler
+  (package
+    (name "perl-data-tumbler")
+    (version "0.008")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RE/REHSACK/"
+                           "Data-Tumbler-" version ".tar.gz"))
+       (sha256
+        (base32
+         "13kww2xj30rkk8w9h50h4blypdb689zgils0zyah587kip0z6509"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-most" ,perl-test-most)))
+    (propagated-inputs
+     `(("perl-file-homedir" ,perl-file-homedir)))
+    (home-page "http://search.cpan.org/dist/Data-Tumbler")
+    (synopsis "Dynamic generation of nested combinations of variants")
+    (description "Data::Tumbler - Dynamic generation of nested combinations of
+variants")
+    (license (package-license perl))))
+
 (define-public perl-devel-caller
   (package
     (name "perl-devel-caller")
@@ -394,6 +417,25 @@ CPAN::Meta object are present.")
     (description "Devel::Caller provides meatier version of caller.")
     (license (package-license perl))))
 
+(define-public perl-devel-checkbin
+  (package
+    (name "perl-devel-checkbin")
+    (version "0.02")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/T/TO/TOKUHIROM/"
+                           "Devel-CheckBin-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0g71sma9jy0fjm619hcrcsb9spg2y03vjxx36y8k1xpa2553sr7m"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Devel-CheckBin")
+    (synopsis "Check that a command is available")
+    (description "Devel::CheckBin is a perl module that checks whether a
+particular command is available.")
+    (license (package-license perl))))
+
 (define-public perl-devel-globaldestruction
   (package
     (name "perl-devel-globaldestruction")
@@ -624,6 +666,28 @@ import(), @EXPORT and @EXPORT_OK and not a whole lot else.")
                               "Exporter-Lite-" version))
     (license (package-license perl))))
 
+(define-public perl-exporter-tiny
+  (package
+    (name "perl-exporter-tiny")
+    (version "0.042")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/T/TO/TOBYINK/"
+                           "Exporter-Tiny-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0gq2ia8c6n84gdrlc73vab61djs8gs8zf7fqx8cxbg5zxg2j45lg"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Exporter-Tiny")
+    (synopsis "Exporter with the features of Sub::Exporter but only core dependencies")
+    (description "Exporter::Tiny supports many of Sub::Exporter's
+external-facing features including renaming imported functions with the `-as`,
+`-prefix` and `-suffix` options; explicit destinations with the `into` option;
+and alternative installers with the `installler` option.  But it's written in
+only about 40% as many lines of code and with zero non-core dependencies.")
+    (license (package-license perl))))
+
 (define-public perl-extutils-installpaths
   (package
     (name "perl-extutils-installpaths")
@@ -731,6 +795,31 @@ types Perl-related files, or replicating search queries run on a distribution
 in various parts of the CPAN ecosystem.")
     (license (package-license perl))))
 
+(define-public perl-file-homedir
+  (package
+    (name "perl-file-homedir")
+    (version "1.00")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+                           "File-HomeDir-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0hvihydd0y4gdxafi8dpybk9ll8q35bz5ycibfic0gh92cslzfc5"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-file-which" ,perl-file-which)
+       ("perl-file-temp" ,perl-file-temp)))
+    (arguments `(#:tests? #f))          ;Not appropriate for chroot
+    (home-page "http://search.cpan.org/dist/File-HomeDir")
+    (synopsis "Find your home and other directories on any platform")
+    (description "File::HomeDir is a module for locating the directories that
+are \"owned\" by a user (typicaly your user) and to solve the various issues
+that arise trying to find them consistently across a wide variety of
+platforms.")
+    (license (package-license perl))))
+
 (define-public perl-file-list
   (package
     (name "perl-file-list")
@@ -760,6 +849,27 @@ provided base directory and can return files (and/or directories if desired)
 matching a regular expression.")
     (home-page "http://search.cpan.org/~dopacki/File-List/")))
 
+(define-public perl-file-temp
+  (package
+    (name "perl-file-temp")
+    (version "0.2304")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DA/DAGOLDEN/"
+                           "File-Temp-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1b11scbw77924awwdf5yw8sk8z0s2hskvpyyxws9yz4gwhim6h8k"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-parent" ,perl-parent)))
+    (home-page "http://search.cpan.org/dist/File-Temp")
+    (synopsis "Return name and handle of a temporary file safely")
+    (description "File::Temp can be used to create and open temporary files in
+a safe way.")
+    (license (package-license perl))))
+
 (define-public perl-file-which
   (package
     (name "perl-file-which")
@@ -865,6 +975,31 @@ Perlish API and none of the bloat and rarely used features of IPC::Run.")
     ;; licenses, any version."
     (license (list bsd-3 gpl3+))))
 
+(define-public perl-list-moreutils
+  (package
+    (name "perl-list-moreutils")
+    (version "0.402")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RE/REHSACK/"
+                           "List-MoreUtils-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1i0k7kqg1m9nf2xvq9l4lyf38fxvi9952vmmvhcdaf3qa95pxb24"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-config-autoconf" ,perl-config-autoconf)
+       ("perl-inc-latest" ,perl-inc-latest)
+       ("perl-test-writevariants" ,perl-test-writevariants)))
+    (propagated-inputs
+     `(("perl-exporter-tiny" ,perl-exporter-tiny)))
+    (home-page "http://search.cpan.org/dist/List-MoreUtils")
+    (synopsis "Provide the stuff missing in List::Util")
+    (description "List::MoreUtils provides some trivial but commonly needed
+functionality on lists which is not going to go into List::Util.")
+    (license (package-license perl))))
+
 (define-public perl-module-build-tiny
   (package
     (name "perl-module-build-tiny")
@@ -945,6 +1080,110 @@ implementations.")
 handling of Perl modules, which are normally handled at compile time.")
     (license (package-license perl))))
 
+(define-public perl-module-runtime-conflicts
+  (package
+    (name "perl-module-runtime-conflicts")
+    (version "0.001")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+                           "Module-Runtime-Conflicts-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0pz23ch78lbpn4kdbm04icgsmbr7jvmxwq1p5m4x2pap8qwd0wqg"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-module-runtime" ,perl-module-runtime)
+       ("perl-dist-checkconflicts" ,perl-dist-checkconflicts)))
+    (home-page "http://search.cpan.org/dist/Module-Runtime-Conflicts")
+    (synopsis "Provide information on conflicts for Module::Runtime")
+    (description "This module provides conflicts checking for Module::Runtime,
+which had a recent release that broke some versions of Moose.  It is called
+from Moose::Conflicts and moose-outdated.")
+    (license (package-license perl))))
+
+(define-public perl-moose
+  (package
+    (name "perl-moose")
+    (version "2.1403")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+                                  "Moose-" version ".tar.gz"))
+              (sha256
+               (base32
+                "16iaazikbnq2jjjac84jrdpfzm4qwqg1nbfgs11jlwn84q4jp1n3"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-cpan-meta-check" ,perl-cpan-meta-check)
+       ("perl-dist-checkconflicts" ,perl-dist-checkconflicts)
+       ("perl-test-cleannamespaces" ,perl-test-cleannamespaces)
+       ("perl-test-fatal" ,perl-test-fatal)
+       ("perl-test-requires" ,perl-test-requires)
+       ("perl-test-warnings" ,perl-test-warnings)))
+    ;; XXX::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
+    ;; # === Other Modules ===
+    ;; #
+    ;; #     Module                       Want    Have
+    ;; #     ---------------------------- ---- -------
+    ;; #     Algorithm::C3                 any missing
+    ;; #     DBM::Deep                     any missing
+    ;; #     DateTime                      any missing
+    ;; #     DateTime::Calendar::Mayan     any missing
+    ;; #     DateTime::Format::MySQL       any missing
+    ;; #     Declare::Constraints::Simple  any missing
+    ;; #     Dist::CheckConflicts          any    0.11
+    ;; #     HTTP::Headers                 any missing
+    ;; #     IO::File                      any    1.16
+    ;; #     IO::String                    any missing
+    ;; #     Locale::US                    any missing
+    ;; #     Module::Refresh               any missing
+    ;; #     MooseX::NonMoose              any missing
+    ;; #     Params::Coerce                any missing
+    ;; #     Regexp::Common                any missing
+    ;; #     SUPER                         any missing
+    ;; #     Test::Deep                    any missing
+    ;; #     Test::DependentModules        any missing
+    ;; #     Test::LeakTrace               any missing
+    ;; #     Test::Output                  any missing
+    ;; #     URI                           any missing
+    (propagated-inputs
+     `(("perl-class-load" ,perl-class-load)
+       ("perl-class-load-xs" ,perl-class-load-xs)
+       ("perl-data-optlist" ,perl-data-optlist)
+       ("perl-devel-globaldestruction" ,perl-devel-globaldestruction)
+       ("perl-devel-overloadinfo" ,perl-devel-overloadinfo)
+       ("perl-devel-partialdump" ,perl-devel-partialdump)
+       ("perl-devel-stacktrace" ,perl-devel-stacktrace)
+       ("perl-dist-checkconflicts" ,perl-dist-checkconflicts)
+       ("perl-eval-closure" ,perl-eval-closure)
+       ("perl-list-moreutils" ,perl-list-moreutils)
+       ("perl-module-runtime" ,perl-module-runtime)
+       ("perl-module-runtime-conflicts" ,perl-module-runtime-conflicts)
+       ("perl-mro-compat" ,perl-mro-compat)
+       ("perl-package-deprecationmanager" ,perl-package-deprecationmanager)
+       ("perl-package-stash" ,perl-package-stash)
+       ("perl-package-stash-xs" ,perl-package-stash-xs)
+       ("perl-params-util" ,perl-params-util)
+       ("perl-parent" ,perl-parent)
+       ("perl-scalar-list-utils" ,perl-scalar-list-utils)
+       ("perl-sub-exporter" ,perl-sub-exporter)
+       ("perl-sub-name" ,perl-sub-name)
+       ("perl-task-weaken" ,perl-task-weaken)
+       ("perl-try-tiny" ,perl-try-tiny)))
+    (home-page "http://search.cpan.org/dist/Moose")
+    (synopsis "Postmodern object system for Perl 5")
+    (description
+     "Moose is a complete object system for Perl 5.  It provides keywords for
+attribute declaration, object construction, inheritance, and maybe more.  With
+Moose, you define your class declaratively, without needing to know about
+blessed hashrefs, accessor methods, and so on.  You can concentrate on the
+logical structure of your classes, focusing on \"what\" rather than \"how\".
+A class definition with Moose reads like a list of very concise English
+sentences.")
+    (license (package-license perl))))
+
 (define-public perl-mro-compat
   (package
     (name "perl-mro-compat")
@@ -1032,6 +1271,34 @@ independent of the main namespace and only available through an object
 instance, not by name.")
     (license (package-license perl))))
 
+(define-public perl-package-deprecationmanager
+  (package
+    (name "perl-package-deprecationmanager")
+    (version "0.13")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/D/DR/DROLSKY/"
+                           "Package-DeprecationManager-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0fkvq3xxwc3l5hg64dr9sj3l12dl59i44cg407qx9sd6r51j3qfi"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-fatal" ,perl-test-fatal)
+       ("perl-test-requires" ,perl-test-requires)
+       ("perl-test-output" ,perl-test-output)))
+    (propagated-inputs
+     `(("perl-list-moreutils" ,perl-list-moreutils)
+       ("perl-params-util" ,perl-params-util)
+       ("perl-sub-install" ,perl-sub-install)))
+    (arguments `(#:tests? #f))          ;XXX: Failing for some reason...
+    (home-page "http://search.cpan.org/dist/Package-DeprecationManager")
+    (synopsis "Manage deprecation warnings for your distribution")
+    (description "This module allows you to manage a set of deprecations for
+one or more modules.")
+    (license artistic2.0)))
+
 (define-public perl-package-stash
   (package
     (name "perl-package-stash")
@@ -1128,6 +1395,25 @@ is particularly useful for debugging.")
 checking parameters easier.")
     (license (package-license perl))))
 
+(define-public perl-parent
+  (package
+    (name "perl-parent")
+    (version "0.228")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/C/CO/CORION/"
+                           "parent-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0w0i02y4z8465z050kml57mvhv7c5gl8w8ivplhr3cms0zbaq87b"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/parent")
+    (synopsis "Establish an ISA relationship with base classes at compile time")
+    (description "Allows you to both load one or more modules, while setting
+up inheritance from those modules at the same time.")
+    (license (package-license perl))))
+
 (define-public perl-probe-perl
   (package
     (name "perl-probe-perl")
@@ -1263,6 +1549,28 @@ the unsightly mess of C<no strict> or typeglobs lying about where just anyone
 can see them.")
     (license (package-license perl))))
 
+(define-public perl-sub-name
+  (package
+    (name "perl-sub-name")
+    (version "0.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/E/ET/ETHER/"
+                           "Sub-Name-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1sdlc8pv7vyyc48gzh70hbwzn0hzwl3zbcy2dkmfw8vjzgya5i06"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-devel-checkbin" ,perl-devel-checkbin)))
+    (home-page "http://search.cpan.org/dist/Sub-Name")
+    (synopsis "(Re)name a sub")
+    (description "Assigns a new name to referenced sub.  If package
+specification is omitted in the name, then the current package is used.  The
+return value is the sub.")
+    (license (package-license perl))))
+
 (define-public perl-sub-uplevel
   (package
     (name "perl-sub-uplevel")
@@ -1304,6 +1612,29 @@ clock speed.")
                               "Sys-CPU-" version))
     (license (package-license perl))))
 
+(define-public perl-task-weaken
+  (package
+    (name "perl-task-weaken")
+    (version "1.04")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/A/AD/ADAMK/"
+                           "Task-Weaken-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1i7kd9v8fjsqyhr4rx4a1jv7n5vfjjm1v4agb24pizh0b72p3qk7"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Task-Weaken")
+    (synopsis "Ensure that a platform has weaken support")
+    (description "One recurring problem in modules that use Scalar::Util's
+weaken function is that it is not present in the pure-perl variant.  If
+Scalar::Util is not available at all, it will issue a normal dependency on the
+module.  However, if Scalar::Util is relatively new ( it is >= 1.19 ) and the
+module does not have weaken, the install will bail out altogether with a long
+error encouraging the user to seek support.")
+    (license (package-license perl))))
+
 (define-public perl-test-cleannamespaces
   (package
     (name "perl-test-cleannamespaces")
@@ -1385,6 +1716,54 @@ functions")
     ;; license, any version, ..."
     (license gpl3+)))
 
+(define-public perl-test-directory
+  (package
+    (name "perl-test-directory")
+    (version "0.041")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/S/SA/SANBEG/"
+                           "Test-Directory-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1ncql08cizhicbxwd753b4czns8nlcnlw0zfjcfrbdd41x4j6hqr"))))
+    (build-system perl-build-system)
+    (native-inputs `(("perl-test-exception" ,perl-test-exception)))
+    (home-page "http://search.cpan.org/dist/Test-Directory")
+    (synopsis "Perl extension for maintaining test directories")
+    (description "Testing code can involve making sure that files are created
+and deleted as expected.  Doing this manually can be error prone, as it's easy
+to forget a file, or miss that some unexpected file was added.  This module
+simplifies maintaining test directories by tracking their status as they are
+modified or tested with this API, making it simple to test both individual
+files, as well as to verify that there are no missing or unknown files.")
+    (license (package-license perl))))
+
+(define-public perl-test-exception
+  (package
+    (name "perl-test-exception")
+    (version "0.36")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/E/EX/EXODIST/"
+                           "Test-Exception-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1zpwimspbq11wjrli481qk17aabzxab15cnnryflx45nzn3za2xk"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build)))
+    (propagated-inputs
+     `(("perl-sub-uplevel" ,perl-sub-uplevel)))
+    (home-page "http://search.cpan.org/dist/Test-Exception")
+    (synopsis "Test exception based code")
+    (description "This module provides a few convenience methods for testing
+exception based code.  It is built with Test::Builder and plays happily with
+Test::More and friends.")
+    (license (package-license perl))))
+
 (define-public perl-test-fatal
   (package
     (name "perl-test-fatal")
@@ -1436,6 +1815,32 @@ testing exception-throwing code with about the same amount of typing.")
 automatically aggregated and output to STDOUT.")
     (license (package-license perl))))
 
+(define-public perl-test-most
+  (package
+    (name "perl-test-most")
+    (version "0.34")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/O/OV/OVID/"
+                           "Test-Most-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0i72aih3pakm8gh73wx1n4dwq8lbx6dvxhla46gsapszws6hr0n2"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-test-differences" ,perl-test-differences)
+       ("perl-test-warn" ,perl-test-warn)
+       ("perl-exception-class" ,perl-exception-class)
+       ("perl-test-deep" ,perl-test-deep)
+       ("perl-test-exception" ,perl-test-exception)))
+    (home-page "http://search.cpan.org/dist/Test-Most")
+    (synopsis "Most commonly needed test functions and features")
+    (description "This module provides the most commonly used testing
+functions, along with automatically turning on strict and warning and gives a
+bit more fine-grained control over test suites.")
+    (license (package-license perl))))
+
 (define-public perl-test-nowarnings
   (package
     (name "perl-test-nowarnings")
@@ -1611,6 +2016,31 @@ hooking into done_testing as well as via an END block.  You can declare a
 plan, or not, and things will still Just Work.")
     (license (package-license perl))))
 
+(define-public perl-test-writevariants
+  (package
+    (name "perl-test-writevariants")
+    (version "0.010")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/R/RE/REHSACK/"
+                           "Test-WriteVariants-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0kklp05fj98yiq8znyfx9lx1vmjay2ypfb868qdwv3kf93m5zjwr"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-most" ,perl-test-most)
+       ("perl-test-directory" ,perl-test-directory)))
+    (propagated-inputs
+     `(("perl-data-tumbler" ,perl-data-tumbler)
+       ("perl-file-homedir" ,perl-file-homedir)))
+    (home-page "http://search.cpan.org/dist/Test-WriteVariants")
+    (synopsis "Dynamic generation of tests")
+    (description "The Test::WriteVariants module provides for the dynamic
+generation of tests in nested combinations of contexts.")
+    (license (package-license perl))))  ;See LICENSE
+
 (define-public perl-text-diff
   (package
     (name "perl-text-diff")
@@ -1773,6 +2203,31 @@ for use in reading and writing CPAN metadata files like META.yml and
 MYMETA.yml.")
     (license (package-license perl))))
 
+(define-public perl-module-build
+  (package
+    (name "perl-module-build")
+    (version "0.4211")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/L/LE/LEONT/"
+                           "Module-Build-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1c5hfhajr963w4mdjivsc7yz4vf4pz1rrfch5a93fbac1x2mr58h"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-cpan-meta" ,perl-cpan-meta)))
+    (home-page "http://search.cpan.org/dist/Module-Build")
+    (synopsis "Build and install Perl modules")
+    (description "\"Module::Build\" is a system for building, testing, and
+installing Perl modules.  It is meant to be an alternative to
+\"ExtUtils::MakeMaker\".  Developers may alter the behavior of the module
+through subclassing in a much more straightforward way than with
+\"MakeMaker\".  It also does not require a \"make\" on your system - most of
+the \"Module::Build\" code is pure-perl and written in a cross-platform way.")
+    (license (package-license perl))))
+
 (define-public perl-parse-cpan-meta
   (package
     (name "perl-parse-cpan-meta")
@@ -1794,4 +2249,25 @@ MYMETA.yml.")
 files, using JSON::PP and/or CPAN::Meta::YAML.")
     (license (package-license perl))))
 
+(define-public perl-scalar-list-utils
+  (package
+    (name "perl-scalar-list-utils")
+    (version "1.41")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/P/PE/PEVANS/"
+                           "Scalar-List-Utils-" version ".tar.gz"))
+       (sha256
+        (base32
+         "04l1q4hps9n8b1hk9kpgpc1cryim7pl9sfdyb7fz5nq4gmz307j7"))))
+    (build-system perl-build-system)
+    (home-page "http://search.cpan.org/dist/Scalar-List-Utils")
+    (synopsis "Common Scalar and List utility subroutines")
+    (description "This package contains a selection of subroutines that people
+have expressed would be nice to have in the perl core, but the usage would not
+really be high enough to warrant the use of a keyword, and the size so small
+such that being individual extensions would be wasteful.")
+    (license (package-license perl))))
+
 ;;; END: Core module overrides