gnu: python-pandas: Fix build on 32-bit.
[jackhill/guix/guix.git] / gnu / packages / gsasl.scm
index 8fb21ee..4c8f818 100644 (file)
 
 (define-module (gnu packages gsasl)
   #:use-module (gnu packages)
-  #:use-module ((gnu packages compression) #:prefix guix:)
-  #:use-module (gnu packages gnutls)
+  #:use-module (gnu packages compression)
   #:use-module (gnu packages libidn)
   #:use-module (gnu packages nettle)
-  #:use-module (gnu packages shishi)
-  #:use-module (guix licenses)
+  #:use-module (gnu packages kerberos)
+  #:use-module (gnu packages tls)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu))
    (build-system gnu-build-system)
    (synopsis "Library that implements NTLM authentication")
    (description
-    "Libntlm is a library that implements NTLM authentication")
-   (license lgpl2.1+)
+    "Libntlm is a library that implements NTLM authentication.")
+   (license license:lgpl2.1+)
    (home-page "http://www.nongnu.org/libntlm/")))
 
 (define-public gss
   (package
    (name "gss")
-   (version "1.0.2")
+   (version "1.0.3")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/gss/gss-" version
                                 ".tar.gz"))
             (sha256 (base32
-                     "1qa8lbkzi6ilfggx7mchfzjnchvhwi68rck3jf9j4425ncz7zsd9"))))
+                     "1syyvh3k659xf1hdv9pilnnhbbhs6vfapayp4xgdcc8mfgf9v4gz"))))
    (build-system gnu-build-system)
    (inputs `(("nettle" ,nettle)
              ("shishi" ,shishi)
-             ("zlib" ,guix:zlib)
-            ))
+             ("zlib" ,zlib)))
    (synopsis "Generic Security Service library")
    (description
     "The GNU Generic Security Service provides a free implementation of the
@@ -68,7 +67,7 @@ interface for programs to access security services.  Security services present
 a generic, GSS interface, with which the calling application interacts via
 this library, freeing the application developer from needing to know about
 the underlying security implementation.")
-   (license gpl3+)
+   (license license:gpl3+)
    (home-page "http://www.gnu.org/software/gss/")))
 
 (define-public gsasl
@@ -85,7 +84,7 @@ the underlying security implementation.")
    (inputs `(("libidn" ,libidn)
              ("libntlm" ,libntlm)
              ("gss" ,gss)
-             ("zlib" ,guix:zlib)))
+             ("zlib" ,zlib)))
    (propagated-inputs
     ;; Propagate GnuTLS because libgnutls.la reads `-lnettle', and Nettle is a
     ;; propagated input of GnuTLS.
@@ -96,5 +95,5 @@ the underlying security implementation.")
 Security Layer framework.  On network servers such as IMAP or SMTP servers,
 SASL is used to handle client/server authentication.  This package contains
 both a library and a command-line tool to access the library.")
-   (license gpl3+)
+   (license license:gpl3+)
    (home-page "http://www.gnu.org/software/gsasl/")))