gnu: sbcl-trivial-clipboard: Update to 20200904.
[jackhill/guix/guix.git] / gnu / packages / apr.scm
index 3e53a61..1a4a1c6 100644 (file)
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
 ;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
 
 (define-module (gnu packages apr)
-  #:use-module (guix licenses)
+  #:use-module ((guix licenses) #:prefix l:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
   #:use-module (gnu packages)
   #:use-module (gnu packages perl)
+  #:use-module (gnu packages xml)
   #:use-module (gnu packages autotools))
 
 (define-public apr
   (package
     (name "apr")
-    (version "1.5.1")
+    (version "1.6.5")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://apache/apr/apr-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "1b4qw686bwjn19iyb0lg918q23xxd6s2gnyczhjq992d3m1vwjp9"))
+               "01d1n1ql66bxsjx0wyzazmkqdqdmr0is6a7lwyy5kzy4z7yajz56"))
              (patches
-              (list (search-patch "apr-skip-getservbyname-test.patch")))
+              (search-patches "apr-skip-getservbyname-test.patch"))
              (patch-flags '("-p0"))))
     (build-system gnu-build-system)
     (arguments
@@ -59,35 +60,37 @@ an API to which software developers may code and be assured of predictable if
 not identical behaviour regardless of the platform on which their software is
 built, relieving them of the need to code special-case conditions to work
 around or take advantage of platform-specific deficiencies or features.")
-    (license asl2.0)))
+    (license l:asl2.0)))
 
 (define-public apr-util
   (package
     (name "apr-util")
-    (version "1.5.3")
+    (version "1.6.1")
     (source (origin
              (method url-fetch)
              (uri (string-append "mirror://apache/apr/apr-util-"
                                  version ".tar.bz2"))
              (sha256
               (base32
-               "0s1rpqjy5xr03k9s4xrsm5wvhj5286vlkf6jvqayw99yy5sb3vbq"))))
+               "0nq3s1yn13vplgl6qfm09f7n0wm08malff9s59bqf9nid9xjzqfk"))))
     (build-system gnu-build-system)
     (inputs
-      `(("apr" ,apr)))
+     `(("apr" ,apr)))
+    (propagated-inputs
+     `(("expat" ,expat)))
     (arguments
      '(#:phases
-       (alist-replace
-        'configure
-        (lambda* (#:key inputs outputs #:allow-other-keys)
-          (let ((out (assoc-ref outputs "out"))
-                (apr (assoc-ref inputs "apr")))
-            (setenv "CONFIG_SHELL" (which "bash"))
-            (zero?
-             (system* "./configure"
-                      (string-append "--prefix=" out)
-                      (string-append "--with-apr=" apr)))))
-        %standard-phases)
+       (modify-phases %standard-phases
+         (replace 'configure
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out   (assoc-ref outputs "out"))
+                   (apr   (assoc-ref inputs  "apr"))
+                   (expat (assoc-ref inputs  "expat")))
+               (setenv "CONFIG_SHELL" (which "bash"))
+               (invoke "./configure"
+                       (string-append "--prefix=" out)
+                       (string-append "--with-apr=" apr)
+                       (string-append "--with-expat=" expat))))))
 
        ;; There are race conditions during 'make check'.  Typically, the
        ;; 'testall' executable is not built yet by the time 'make check' tries
@@ -98,4 +101,4 @@ around or take advantage of platform-specific deficiencies or features.")
     (synopsis "One of the Apache Portable Runtime Library companions")
     (description
      "APR-util provides a number of helpful abstractions on top of APR.")
-    (license asl2.0)))
+    (license l:asl2.0)))