Merge branch 'master' into core-updates
[jackhill/guix/guix.git] / gnu / packages / file.scm
index 24ed37a..9ba51d1 100644 (file)
@@ -43,7 +43,9 @@
 
    ;; When cross-compiling, this package depends upon a native install of
    ;; itself.
-   (self-native-input? #t)
+   (native-inputs (if (%current-target-system)
+                      `(("self" ,this-package))
+                      '()))
 
    (synopsis "File type guesser")
    (description