gnu: ccache: Update to 3.2.5.
[jackhill/guix/guix.git] / gnu / packages / xiph.scm
index 550cc61..d1597e9 100644 (file)
@@ -4,6 +4,8 @@
 ;;; Copyright © 2013 David Thompson <dthompson2@worcester.edu>
 ;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
 ;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015 Paul van der Walt <paul@denknerd.org>
+;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
   #:use-module (gnu packages bison)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
-  #:use-module (gnu packages doxygen)
+  #:use-module (gnu packages documentation)
   #:use-module (gnu packages image)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages python)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pulseaudio)
-  #:use-module ((guix licenses)
-                #:renamer (symbol-prefix-proc 'license:))
+  #:use-module (gnu packages tls)
+  #:use-module (gnu packages xml)
+  #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
   #:use-module (guix build-system gnu)
             flac
             libkate
             vorbis-tools
-            opus))
+            opus
+            opusfile
+            opus-tools))
 
 (define libogg
   (package
    (name "libogg")
-   (version "1.3.0")
+   (version "1.3.2")
    (source (origin
             (method url-fetch)
             (uri (string-append "http://downloads.xiph.org/releases/ogg/libogg-"
                                 version ".tar.xz"))
             (sha256
              (base32
-              "0jy79ffkl34vycnwfsj4svqsdg1lwy2l1rr49y8r4d44kh12a5r3"))))
+              "16z74q422jmprhyvy7c9x909li8cqzmvzyr8cgbm52xcsp6pqs1z"))))
    (build-system gnu-build-system)
-   (synopsis "libogg, a library for manipulating the ogg multimedia format")
+   (synopsis "Library for manipulating the ogg multimedia format")
    (description
     "The libogg library allows to manipulate the ogg multimedia container
 format, which encapsulates raw compressed data and allows the interleaving of
-audio and video data. In addition to encapsulation and interleaving of
+audio and video data.  In addition to encapsulation and interleaving of
 multiple data streams, ogg provides packet framing, error detection, and
 periodic timestamps for seeking.")
-   (license (license:bsd-style "file://COPYING"
+   (license (license:non-copyleft "file://COPYING"
                                "See COPYING in the distribution."))
    (home-page "http://xiph.org/ogg/")))
 
 (define libvorbis
   (package
    (name "libvorbis")
-   (version "1.3.4")
+   (version "1.3.5")
    (source (origin
             (method url-fetch)
-            (uri (string-append "http://downloads.xiph.org/releases/vorbis/libvorbis-"
-                                version ".tar.xz"))
+            (uri (string-append "http://downloads.xiph.org/releases/vorbis/"
+                                "libvorbis-" version ".tar.xz"))
             (sha256
              (base32
-              "0wpk87jnhngcl3nc5i39flkycx1sjzilx8jjx4zc4p8r55ylj19g"))))
+              "1lg1n3a6r41492r7in0fpvzc7909mc5ir9z0gd3qh2pz4yalmyal"))))
    (build-system gnu-build-system)
    (propagated-inputs `(("libogg" ,libogg)))
    (arguments `(#:configure-flags '("LDFLAGS=-lm")
                 #:parallel-tests? #f))
-   (synopsis "libvorbis, a library implementing the vorbis audio format")
+   (synopsis "Library implementing the vorbis audio format")
    (description
     "The libvorbis library implements the ogg vorbis audio format,
 a fully open, non-proprietary, patent-and-royalty-free, general-purpose
 compressed audio format for mid to high quality (8kHz-48.0kHz, 16+ bit,
 polyphonic) audio and music at fixed and variable bitrates from 16 to
 128 kbps/channel.")
-   (license (license:bsd-style "file://COPYING"
+   (license (license:non-copyleft "file://COPYING"
                                "See COPYING in the distribution."))
    (home-page "http://xiph.org/vorbis/")))
 
@@ -101,12 +106,12 @@ polyphonic) audio and music at fixed and variable bitrates from 16 to
     (version "1.1.1")
     (source (origin
              (method url-fetch)
-             (uri (string-append "http://downloads.xiph.org/releases/theora/libtheora-"
-                                 version ".tar.xz"))
+             (uri (string-append "http://downloads.xiph.org/releases/theora/"
+                                 "libtheora-" version ".tar.xz"))
              (sha256
               (base32
                "0q8wark9ribij57dciym5vdikg2464p8q2mgqvfb78ksjh4s8vgk"))
-             (patches (list (search-patch "libtheora-config-guess.patch")))))
+             (patches (search-patches "libtheora-config-guess.patch"))))
     (build-system gnu-build-system)
     (inputs `(("libvorbis" ,libvorbis)))
     ;; The .pc files refer to libogg.
@@ -141,13 +146,13 @@ for speech.  It is well-adapted to internet applications, such as VoIP.  It
 features compression of different bands in the same bitstream, intensity
 stereo encoding, and voice activity detection.")
     ;; 'src/getopt.c' is under LGPLv2+
-    (license (license:bsd-style "file://COPYING"
+    (license (license:non-copyleft "file://COPYING"
                                 "See COPYING in the distribution."))))
 
 (define ao
   (package
     (name "ao")
-    (version "1.1.0")
+    (version "1.2.0")
     (source
      (origin
       (method url-fetch)
@@ -155,66 +160,66 @@ stereo encoding, and voice activity detection.")
                           version ".tar.gz"))
       (sha256
        (base32
-        "1m0v2y6bhr4iwsgdkc7b3y0qgpvpv1ifbxsy8n8ahsvjn6wmppi9"))))
+        "1bwwv1g9lchaq6qmhvj1pp3hnyqr64ydd4j38x94pmprs4d27b83"))))
     (build-system gnu-build-system)
     ;; FIXME: Add further backends, see the summary printed after configure.
     ;; XXX: Should back-ends be pushed to different outputs?  For instance,
     ;; "out" would include only the ALSA back-end, while "pulse" would
     ;; contain 'lib/ao/plugins-4/libpulse.*'.
-    (inputs `(("pkg-config" ,pkg-config)
-              ("alsa-lib" ,alsa-lib)
-              ("pulseaudio" ,pulseaudio)))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("pulseaudio" ,pulseaudio)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
     (synopsis "Cross platform audio library")
     (description
      "Libao is a cross-platform audio library that allows programs to
 output audio using a simple API on a wide variety of platforms.
 It currently supports:
-Null output (handy for testing without a sound device),
-WAV files,
-AU files,
-RAW files,
-OSS (Open Sound System, used on Linux and FreeBSD),
-ALSA (Advanced Linux Sound Architecture),
-aRts (Analog RealTime Synth, used by KDE),
-PulseAudio (next generation GNOME sound server),
-esd (EsounD or Enlightened Sound Daemon),
-Mac OS X,
-Windows (98 and later),
-AIX,
-Sun/NetBSD/OpenBSD,
-IRIX,
-NAS (Network Audio Server),
-RoarAudio (Modern, multi-OS, networked Sound System),
-OpenBSD's sndio.")
+@enumerate
+@item Null output (handy for testing without a sound device),
+@item WAV files,
+@item AU files,
+@item RAW files,
+@item OSS (Open Sound System, used on Linux and FreeBSD),
+@item ALSA (Advanced Linux Sound Architecture),
+@item aRts (Analog RealTime Synth, used by KDE),
+@item PulseAudio (next generation GNOME sound server),
+@item esd (EsounD or Enlightened Sound Daemon),
+@item Mac OS X,
+@item Windows (98 and later),
+@item AIX,
+@item Sun/NetBSD/OpenBSD,
+@item IRIX,
+@item NAS (Network Audio Server),
+@item RoarAudio (Modern, multi-OS, networked Sound System),
+@item OpenBSD's sndio.
+@end enumerate
+")
     (license license:gpl2+)
     (home-page "http://www.xiph.org/ao/")))
 
 (define flac
   (package
    (name "flac")
-   (version "1.3.0")
+   (version "1.3.1")
    (source (origin
             (method url-fetch)
             (uri (string-append "http://downloads.xiph.org/releases/flac/flac-"
                                 version ".tar.xz"))
             (sha256
              (base32
-              "1p0hh190kqvpkbk1bbajd81jfbmkyl4fn2i7pggk2zppq6m68bgs"))))
+              "0v65w7ph6ldwp5a8fbhp0a3w8f737ck468fr7yb7sxmskl4w0ws7"))))
    (build-system gnu-build-system)
    (arguments
-    `(#:parallel-tests? #f
-      ;; By default, man pages are put in PREFIX/man,
-      ;; but we want them in PREFIX/share/man.
-      #:configure-flags (list (string-append "--mandir="
-                                             (assoc-ref %outputs "out")
-                                             "/share/man"))))
+    `(#:parallel-tests? #f))
    ;; FIXME: configure also looks for xmms, input could be added once it exists
-   (inputs `(("libogg" ,libogg)))
-   (synopsis "flac free lossless audio codec")
+   (propagated-inputs `(("libogg" ,libogg))) ; required by flac.pc
+   (synopsis "Free lossless audio codec")
    (description
 "FLAC stands for Free Lossless Audio Codec, an audio format that is lossless,
 meaning that audio is compressed in FLAC without any loss in quality.")
-   (license (license:bsd-style "file://COPYING"
+   (license (license:non-copyleft "file://COPYING"
                                "See COPYING in the distribution.")) ; and LGPL and GPL
    (home-page "http://xiph.org/flac/")))
 
@@ -238,17 +243,17 @@ meaning that audio is compressed in FLAC without any loss in quality.")
              ("libpng" ,libpng)
 ("python" ,python-wrapper)
              ("zlib" ,zlib)))
-   (synopsis "kate, a karaoke and text codec for embedding in ogg")
+   (synopsis "Karaoke and text codec for embedding in ogg")
    (description
     "Kate is an overlay codec, originally designed for karaoke and text,
-that can be multiplixed in Ogg. Text and images can be carried by a Kate
-stream, and animated. Most of the time, this would be multiplexed with
+that can be multiplixed in Ogg.  Text and images can be carried by a Kate
+stream, and animated.  Most of the time, this would be multiplexed with
 audio/video to carry subtitles, song lyrics (with or without karaoke data),
 etc., but doesn't have to be.
 
 Series of curves (splines, segments, etc.) may be attached to various
 properties (text position, font size, etc.) to create animated overlays.
-This allows scrolling or fading text to be defined. This can even be used
+This allows scrolling or fading text to be defined.  This can even be used
 to draw arbitrary shapes, so hand drawing can also be represented by a
 Kate stream.")
    (license license:bsd-3)
@@ -260,11 +265,15 @@ Kate stream.")
    (version "1.4.0")
    (source (origin
             (method url-fetch)
-            (uri (string-append "http://downloads.xiph.org/releases/vorbis/vorbis-tools-"
-                                version ".tar.gz"))
+            (uri (string-append "http://downloads.xiph.org/releases/vorbis/"
+                                "vorbis-tools-" version ".tar.gz"))
             (sha256
              (base32
-              "1g12bnh5ah08v529y72kfdz5lhvy75iaz7f9jskyby23m9dkk2d3"))))
+              "1g12bnh5ah08v529y72kfdz5lhvy75iaz7f9jskyby23m9dkk2d3"))
+            (patches (search-patches 
+                       "vorbis-tools-CVE-2014-9638+CVE-2014-9639.patch"
+                       "vorbis-tools-CVE-2014-9640.patch"
+                       "vorbis-tools-CVE-2015-6749.patch"))))
    (build-system gnu-build-system)
    (inputs `(("ao" ,ao)
              ("curl" ,curl)
@@ -272,9 +281,9 @@ Kate stream.")
              ("libkate" ,libkate)
              ("libogg" ,libogg)
              ("libvorbis" ,libvorbis)
-             ("pkg-config" ,pkg-config)
              ("speex" ,speex)))
-   (synopsis "ogg vorbis tools")
+   (native-inputs `(("pkg-config" ,pkg-config)))
+   (synopsis "Ogg vorbis tools")
    (description
     "Ogg vorbis is a non-proprietary, patent-and-royalty-free,
 general-purpose compressed audio format.
@@ -291,7 +300,7 @@ ogginfo, to obtain information (tags, bitrate, length, etc.) about
 (define opus
   (package
     (name "opus")
-    (version "1.1")
+    (version "1.1.2")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -299,14 +308,135 @@ ogginfo, to obtain information (tags, bitrate, length, etc.) about
                     ".tar.gz"))
               (sha256
                (base32
-                "158xprn2086arvdib3vbbygz7z6jqkw2nci7nlywzzwallap0wmr"))))
+                "1z87x5c5x951lhnm70iqr2gqn15wns5cqsw8nnkvl48jwdw00a8f"))))
     (build-system gnu-build-system)
-    (synopsis "highly versatile audio codec")
+    (synopsis "Versatile audio codec")
     (description
-     "Opus is a totally open, royalty-free, highly versatile audio codec. Opus
+     "Opus is a totally open, royalty-free, highly versatile audio codec.  Opus
 is unmatched for interactive speech and music transmission over the Internet,
-but is also intended for storage and streaming applications. It is
+but is also intended for storage and streaming applications.  It is
 standardized by the Internet Engineering Task Force (IETF) as RFC 6716 which
 incorporated technology from Skype's SILK codec and Xiph.Org's CELT codec.")
     (license license:bsd-3)
-    (home-page "http://www.opus-codec.org/")))
+    (home-page "http://www.opus-codec.org")))
+
+(define opus-tools
+  (package
+    (name "opus-tools")
+    (version "0.1.9")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://downloads.xiph.org/releases/opus/opus-tools-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "0fk4nknvl111k89j5yckmyrh6b2wvgyhrqfncp7rig3zikbkv1xi"))))
+    (build-system gnu-build-system)
+    (arguments
+     ;; The package developers misuse pkg-config such that it doesn't work
+     ;; when cross compiling.  Therefore we avoid it completly and set the
+     ;; necessary flags ourselves.
+     `(#:configure-flags (list (string-append "CFLAGS=-I"
+                                              (assoc-ref %build-inputs "libogg")
+                                              "/include -I"
+                                              (assoc-ref %build-inputs "opus")
+                                              "/include/opus"))))
+    (inputs `(("libogg" ,libogg)
+              ("opus" ,opus)
+              ("flac" ,flac)))
+    (synopsis
+     "Command line utilities to encode, inspect, and decode .opus files")
+    (description "Opus is a royalty-free, highly versatile audio codec.
+Opus-tools provide command line utilities for creating, inspecting and
+decoding .opus files.")
+    (license license:bsd-3)
+    (home-page "http://www.opus-codec.org")))
+
+(define opusfile
+  (package
+    (name "opusfile")
+    (version "0.7")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://downloads.xiph.org/releases/opus/opusfile-" version
+                    ".tar.gz"))
+              (sha256
+               (base32
+                "00f3wwjv3hxwg05g22s6mkkxikz80ljsn70g39cmi43jph9ysawy"))))
+    (build-system gnu-build-system)
+    (propagated-inputs
+     `(("opus" ,opus)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libogg" ,libogg)
+       ("openssl" ,openssl)))
+    (synopsis "Versatile audio codec")
+    (description
+     "The opusfile library provides seeking, decode, and playback of Opus
+streams in the Ogg container (.opus files) including over http(s) on posix and
+windows systems.")
+    (license license:bsd-3)
+    (home-page "http://www.opus-codec.org")))
+
+(define-public icecast
+  (package
+    (name "icecast")
+    (version "2.4.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://downloads.xiph.org/releases/icecast/icecast-"
+                    version ".tar.gz"))
+              (sha256
+               (base32
+                "14n5vm2xnyn8y7kl46lnnlgv6v5fjykhc57ffdsh0qaxfs6a8p68"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (inputs
+     `(("libxslt" ,libxslt)
+       ("libxml2" ,libxml2)
+       ("openssl" ,openssl)
+       ("curl" ,curl)
+       ("libogg" ,libogg)
+       ("libvorbis" ,libvorbis)
+       ("libtheora" ,libtheora)
+       ("speex" ,speex)))
+    (synopsis "Streaming media server")
+    (description "Icecast is a streaming media server which currently supports
+Ogg (Vorbis and Theora), Opus, WebM and MP3 audio streams.  It can be used to
+create an Internet radio station or a privately running jukebox and many
+things in between.")
+    (home-page "http://icecast.org/")
+    (license license:gpl2)))
+
+(define-public libshout
+  (package
+    (name "libshout")
+    (version "2.4.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "http://downloads.xiph.org/releases/libshout/"
+                    name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "0kgjpf8jkgyclw11nilxi8vyjk4s8878x23qyxnvybbgqbgbib7k"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     ;; shout.pc refers to all these.
+     `(("libtheora" ,libtheora)
+       ("libvorbis" ,libvorbis)
+       ("speex"     ,speex)))
+    (home-page "http://www.icecast.org/")
+    (synopsis "Audio streaming library for icecast encoders")
+    (description
+     "Libshout is a library for communicating with and sending data to an
+icecast server.  It handles the socket connection, the timing of the data,
+and prevents bad data from getting to the icecast server.")
+    (license license:gpl2+)))