gnu: ccache: Update to 3.2.5.
[jackhill/guix/guix.git] / gnu / packages / bittorrent.scm
index 15b69cf..75e5519 100644 (file)
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 Taylan Ulrich Bayirli/Kammer <taylanbayirli@gmail.com>
-;;; Copyright © 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
                      (mkdir-p (string-append gui "/bin"))
                      (rename-file (string-append out "/bin/transmission-gtk")
                                   (string-append gui
-                                                 "/bin/transmission-gtk"))))
+                                                 "/bin/transmission-gtk"))
+
+                     ;; Move the '.desktop' file as well.
+                     (mkdir (string-append gui "/share"))
+                     (rename-file (string-append out "/share/applications")
+                                  (string-append gui "/share/applications"))))
                  %standard-phases)))
     (inputs
      `(("inotify-tools" ,inotify-tools)
@@ -202,7 +207,7 @@ interface, for the Transmission BitTorrent daemon.")
 (define-public aria2
   (package
     (name "aria2")
-    (version "1.20.0")
+    (version "1.24.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://github.com/tatsuhiro-t/aria2/"
@@ -210,7 +215,7 @@ interface, for the Transmission BitTorrent daemon.")
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1l4gzz3yr0cl6a9xdy7843c5sb7afyq0i80wi2hasfpfdx5k95mz"))))
+                "0dxzyy3x20vla4c4563zjqkl71djv731db6wn3h0gysgf399d91m"))))
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags '("--enable-libaria2")
@@ -225,10 +230,10 @@ interface, for the Transmission BitTorrent daemon.")
                (("CPPUNIT_TEST_SUITE_REGISTRATION\\(LpdMessageReceiverTest\\);" text)
                 (string-append "// " text))))))))
     (native-inputs
-     `(("pkg-config", pkg-config)))
+     `(("cppunit" ,cppunit) ; for the tests
+       ("pkg-config" ,pkg-config)))
     (inputs
      `(("c-ares" ,c-ares)
-       ("cppunit" ,cppunit) ; for the tests
        ("gnutls" ,gnutls)
        ("gmp" ,gmp)
        ("libssh2" ,libssh2)
@@ -236,7 +241,7 @@ interface, for the Transmission BitTorrent daemon.")
        ("nettle" ,nettle)
        ("sqlite" ,sqlite)
        ("zlib" ,zlib)))
-    (home-page "http://aria2.sourceforge.net/")
+    (home-page "https://aria2.github.io/")
     (synopsis "Utility for parallel downloading files")
     (description
       "Aria2 is a lightweight, multi-protocol & multi-source command-line