gnu: biber: Downgrade to 2.11.
[jackhill/guix/guix.git] / gnu / packages / patches / glibc-bootstrap-system.patch
dissimilarity index 65%
index 2f8e7da..39eb47e 100644 (file)
@@ -1,30 +1,28 @@
-We want to allow builds in chroots that lack /bin/sh.  Thus, system(3)
-and popen(3) need to be tweaked to use the right shell.  For the bootstrap
-glibc, we just use whatever `sh' can be found in $PATH.  The final glibc
-instead uses the hard-coded absolute file name of `bash'.
-
---- a/sysdeps/posix/system.c
-+++ b/sysdeps/posix/system.c
-@@ -134,7 +134,7 @@ do_system (const char *line)
-       INIT_LOCK ();
-       /* Exec the shell.  */
--      (void) __execve (SHELL_PATH, (char *const *) new_argv, __environ);
-+      (void) __execvpe (SHELL_NAME, (char *const *) new_argv, __environ);
-       _exit (127);
-     }
-   else if (pid < (pid_t) 0)
-
---- b/libio/iopopen.c  2012-06-30 21:12:34.000000000 +0200
-+++ b/libio/iopopen.c  2012-12-19 12:52:29.000000000 +0100
-@@ -226,7 +226,7 @@ _IO_new_proc_open (fp, command, mode)
-           _IO_close (fd);
-       }
--      _IO_execl ("/bin/sh", "sh", "-c", command, (char *) 0);
-+      execlp ("sh", "sh", "-c", command, (char *) 0);
-       _IO__exit (127);
-     }
-   _IO_close (child_end);
-
-
+We want to allow builds in chroots that lack /bin/sh.  Thus, system(3)
+and popen(3) need to be tweaked to use the right shell.  For the bootstrap
+glibc, we just use whatever `sh' can be found in $PATH.  The final glibc
+instead uses the hard-coded absolute file name of `bash'.
+
+--- a/sysdeps/posix/system.c
++++ b/sysdeps/posix/system.c
+@@ -140,7 +140,7 @@ do_system (const char *line)
+   __posix_spawnattr_setflags (&spawn_attr,
+                             POSIX_SPAWN_SETSIGDEF | POSIX_SPAWN_SETSIGMASK);
+-  status = __posix_spawn (&pid, SHELL_PATH, 0, &spawn_attr,
++  status = posix_spawnp (&pid, SHELL_NAME, 0, &spawn_attr,
+                         (char *const[]){ (char*) SHELL_NAME,
+                                          (char*) "-c",
+                                          (char *) line, NULL },
+--- a/libio/iopopen.c
++++ b/libio/iopopen.c
+@@ -85,7 +85,7 @@ spawn_process (posix_spawn_file_actions_t *fa, FILE *fp, const char *command,
+       return false;
+     }
+-  if (__posix_spawn (&((_IO_proc_file *) fp)->pid, _PATH_BSHELL, fa, 0,
++  if (posix_spawnp (&((_IO_proc_file *) fp)->pid, "sh", fa, 0,
+                    (char *const[]){ (char*) "sh", (char*) "-c",
+                    (char *) command, NULL }, __environ) != 0)
+     return false;
+