gnu: Add wl-clipboard.
[jackhill/guix/guix.git] / gnu / packages / music.scm
index 568b6f4..12b55ae 100644 (file)
@@ -2247,14 +2247,14 @@ from the command line.")
 (define-public qtractor
   (package
     (name "qtractor")
-    (version "0.9.2")
+    (version "0.9.3")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://downloads.sourceforge.net/qtractor/"
                                   "qtractor-" version ".tar.gz"))
               (sha256
                (base32
-                "1j3rpvdkw9rw48j4zyfn6rprp01csy4rl6zckcjyx0vh7vaycchr"))))
+                "1010gvkzdzdk39g1g6wx2j19ls0kdl6l9q51xzk2qik7h2fwxl71"))))
     (build-system gnu-build-system)
     (arguments
      `(#:tests? #f))                    ; no "check" target
@@ -2688,13 +2688,14 @@ Songs can be searched by artist, name or even by a part of the song text.")
 (define-public beets
   (package
     (name "beets")
-    (version "1.4.6")
+    (version "1.4.7")
     (source (origin
               (method url-fetch)
               (uri (pypi-uri "beets" version))
+              (patches (search-patches "beets-python-3.7-fix.patch"))
               (sha256
                (base32
-                "0l2vfrknwcsm6bn83m7476qrz45qwgxcb5k0h7kn96kr70irn1v2"))))
+                "0w3gz69s9gf5ih69d4sddgh7ndj7658m621bp742zldvjakdncrs"))))
     (build-system python-build-system)
     (arguments
      `(#:phases
@@ -2703,6 +2704,12 @@ Songs can be searched by artist, name or even by a part of the song text.")
            (lambda _
              (setenv "HOME" (string-append (getcwd) "/tmp"))
              #t))
+         (add-after 'unpack 'make-python3.7-compatible
+           (lambda _
+             ;; See <https://github.com/beetbox/beets/issues/2978>.
+             (substitute* "beets/autotag/hooks.py"
+              (("re\\._pattern_type") "re.Pattern"))
+             #t))
          (replace 'check
            (lambda _
              (invoke "nosetests" "-v"))))))
@@ -2779,7 +2786,7 @@ for improved Amiga ProTracker 2/3 compatibility.")
 (define-public schismtracker
   (package
     (name "schismtracker")
-    (version "20180513")
+    (version "20181223")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2788,7 +2795,7 @@ for improved Amiga ProTracker 2/3 compatibility.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0fayix1zbl96zhkfszgj71qr25dnddgy9hr6149nslww4gl7jk36"))
+                "18k5j10zq39y2q294avdmar87x93k57wqmq8bpz562hdqki2mz1l"))
               (modules '((guix build utils)))
               (snippet
                ;; Remove use of __DATE__ and __TIME__ for reproducibility.
@@ -3298,7 +3305,8 @@ plugins, a switch trigger, a toggle switch, and a peakmeter.")
            "1wg47vjw9djn99gbnsl2bcwj4xhdid61m4wrbn2nlp797flj91ic"))))
       (build-system waf-build-system)
       (arguments
-       `(#:tests? #f ; no "check" target
+       `(#:python ,python-2
+         #:tests? #f ; no "check" target
          #:configure-flags (list "--no-webkit")
          #:phases
          (modify-phases %standard-phases
@@ -3602,7 +3610,7 @@ audio samples and various soft sythesizers.  It can receive input from a MIDI ke
 (define-public musescore
   (package
     (name "musescore")
-    (version "2.3.2")
+    (version "3.0")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -3611,7 +3619,7 @@ audio samples and various soft sythesizers.  It can receive input from a MIDI ke
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0ncv0xfmq87plqa43cm0fpidlwzz1nq5s7h7139llrbc36yp3pr1"))
+                "0g8n8xpw5d6wh8bwbvy12sinl9i0ir009sr28i4izr28lr4x8v50"))
               (modules '((guix build utils)))
               (snippet
                ;; Un-bundle OpenSSL and remove unused libraries.
@@ -3626,27 +3634,21 @@ audio samples and various soft sythesizers.  It can receive input from a MIDI ke
                               "thirdparty/openssl"
                               "thirdparty/portmidi"))
                   #t))))
-    (build-system gnu-build-system)
+    (build-system cmake-build-system)
     (arguments
-     `(#:make-flags
-       `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))
-         "USE_SYSTEM_FREETYPE=ON"
-         "DOWNLOAD_SOUNDFONT=OFF"
-         ;; The following is not supported since Qt 5.11.  May be removed in
-         ;; a future release.
-         "BUILD_WEBKIT=OFF")
-       ;; There are tests, but no simple target to run.  The command
-       ;; used to run them is:
+     `(#:configure-flags
+       `("-DUSE_SYSTEM_FREETYPE=ON"
+         "-DBUILD_WEBENGINE=OFF"
+         "-DDOWNLOAD_SOUNDFONT=OFF")
+       ;; There are tests, but no simple target to run.  The command used to
+       ;; run them is:
        ;;
        ;;   make debug && sudo make installdebug && cd \
        ;;   build.debug/mtest && make && ctest
        ;;
        ;; Basically, it requires to start a whole new build process.
        ;; So we simply skip them.
-       #:tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (delete 'configure))))
+       #:tests? #f))
     (inputs
      `(("alsa-lib" ,alsa-lib)
        ("freetype" ,freetype)
@@ -3665,8 +3667,7 @@ audio samples and various soft sythesizers.  It can receive input from a MIDI ke
        ("qtsvg" ,qtsvg)
        ("qtxmlpatterns" ,qtxmlpatterns)))
     (native-inputs
-     `(("cmake" ,cmake)
-       ("pkg-config" ,pkg-config)
+     `(("pkg-config" ,pkg-config)
        ("qttools" ,qttools)))
     (synopsis "Music composition and notation software")
     (description "MuseScore is a music score typesetter.  Its main purpose is
@@ -3934,9 +3935,9 @@ OSC connections.")
            (lambda* (#:key inputs #:allow-other-keys)
              (with-directory-excursion "faust"
                (delete-file "main.cpp")
-               (zero? (system* "faust" "-i"
-                               "-a" "lv2synth.cpp"
-                               "-o" "main.cpp" "main.dsp"))))))))
+               (invoke "faust" "-i"
+                       "-a" "lv2synth.cpp"
+                       "-o" "main.cpp" "main.dsp")))))))
     (inputs
      `(("boost" ,boost)
        ("lv2" ,lv2)